Introduction

GetDataBack pour FAT © 2001-2010 par Runtime Software LLC

75-5744 Alii Dr., Suite #256, Kailua Kona, HI 96740, USA
Téléphone (USA): 1-808-329-2202, Fax: 1-818-475-1741
Téléphone (Germany): +49-30-280 8008
Email: info@runtime.org, Web: http://www.runtime.org

GetDataBack a été conçu pour vous aider à récupérer vos fichiers si la table de partition, le secteur de démarrage, la FAT, ou le répertoire racine de votre lecteur ont été endommagés par un virus, un effacement accidentel, un formatage, un fdisk ou une panne de courant.

GetDataBack peut même récupérer vos données si le lecteur n'est plus reconnu par Windows. Il est également utilisable même si toutes les informations de la MFT sont manquantes.

Des algorithmes avancés vous garantissent que tous les fichiers et dossiers sont placés ensembles comme ils l'étaient auparavant. GetDataBack fonctionne au niveau partition. Il restaure une partition à la fois.

GetDataBack est un outil sûr. Il fonctionne en lecture seule, ce qui signifie que le programme ne tentera jamais d'écrire sur le lecteur que vous souhaitez récupérer.
Remarque: Si vous souhaitez effectuer une récupération, n'installez PAS le logiciel sur le lecteur que vous souhaitez récupérer. Installez-le plutôt sur un lecteur différent et connectez celui-ci à la machine comme lecteur secondaire !

GetDataBack permet à l'utilisateur autorisé de traiter sa propre récupération de données en le guidant à travers trois étapes simples à comprendre, tout en proposant à l'utilisateur avancé d'interférer avec la récupération et d'améliorer les résultats, en examinant le journal de l'examen, les détails du système de fichiers, les informations de fichiers et dossiers, en sélectionnant la plage de secteurs à examiner via l'option d'examen partiel, en choisissant la recherche poussée pour les systèmes de fichiers ou la recherche des fichiers perdus, en appelant Runtime's DiskExplorer.

GetDataBack récupère les données à partir des

  • Disques Durs
  • Lecteurs USB et Firewire
  • Partitions
  • Disquettes
  • Images de Lecteurs
  • Lecteurs Zip/Jaz
  • Cartes Smart Media et Compact Flash
  • Lecteurs Flash USB
  • Lecteurs distants via un câble série ou TCP/IP
  • Volume RAID utilisant une image virtuelle

Cette version de GetDataBack récupère les systèmes de fichiers FAT:

  • FAT12: habituellement associée aux disquettes et aux disques durs supérieurs à 16Mo.
  • FAT16: utilisée sur les disques durs pour toutes les versions DOS, Windows 2.xx, Windows 3.xx et les premières versions de Windows 95 et NT. Taille maximal d'une partition: 2Go.
  • FAT32: habituellement utilisée sur les lecteurs supérieurs à 512Mo sous Windows95 (OEM Rel. B), Windows 98, ME et lecteurs formatés FAT sous W2K et XP.

Ce programme s'exécute sous les systèmes d'exploitation : Windows 95/98/ME, Windows NT, 2000, XP.

Si vous souhaitez récupérer une partition NTFS, téléchargez GetDataBack pour NTFS sur http://www.runtime.org/gdb.htm.

Écran d'Introduction

Avec ce premier écran, vous pourrez informer le logiciel sur ce qui est arrivé à votre disque dur. De cette façon, vous pourrez optimiser le réglage des options pour cette récupération particulière. Vous pourrez choisir un des scénarios suivants:

  • Je ne sais pas, utiliser les réglages par défaut.

    Choisissez cette option si vous ne savez pas exactement ce qui est arrivé à votre lecteur, ou si aucune des situations ci-dessous ne peut s'appliquer.
    Les options standard (récupération des fichiers effacés, autoriser les doublons) seront activées.
    Vous pouvez aussi choisir cette option si vous souhaitez définir vous-même les options.
  • Altération systématique du système de fichier comme lors d'un Formatage ou d'un Fdisk.

    Activez ce bouton radio si vos données sont inaccessibles pour les raisons suivantes:

    • le lecteur a subi un formatage complet, un formatage rapide ou un fdisk par erreur, mais aucune donnée n'a été écrite par la suite sur le lecteur,
    • le lecteur est devenu soudainement inaccessible, comme à la suite, par exemple, d'un problème matériel ou d'alimentation.
    • le lecteur présente quelques "secteurs défectueux".

    Ce qui désactivera toutes les options pour permettre une récupération propre.

  • Altération importante du système de fichiers , comme lors de l'installation d'un nouveau système d'exploitation.

    Choisissez cette option si une quantité importante de données a été copiée sur le lecteur après la perte des données, dans les cas suivants

    • ré installation du système d'exploitation,
    • effacement partiel du lecteur,
    • remplacement du lecteur par un logiciel de clonage.

    Ce qui activera les options standard (récupérer les fichiers supprimés, autoriser les noms de doublons) et définira aussi un indicateur dans le fichier journal ainsi qu'un instantané pour nos techniciens dans la cas où vous les contacteriez ultérieurement pour une assistance technique.
  • Je veux récupérer les fichiers supprimés.
    Activez cette option si vous souhaitez récupérer les fichiers ou dossiers effacés accidentellement, et que le système de fichiers n'est pas endommagé.
    Ce qui vous garantira que les options récupérer les fichiers supprimés et autoriser les doublons seront activées.

Vous pouvez régler manuellement d'autres options en choisissant Options du menu Outils, en cliquant sur le bouton Options, ou en cliquant sur "Voir les options en cours" de l'Etape1.

Ne pas - au cas où - activer toutes les options disponibles du logiciel. Suivez plutôt les réglages recommandé. Activer toutes les options - surtout celles concernant les fichiers perdus et la recherche poussée - n'améliorera habituellement pas la qualité de votre récupération et ne fera que ralentir le processus.

A Faire et A ne Pas Faire lors d'une récupération de données

N'écrivez rien sur le lecteur dont vous souhaitez récupérer les données! Ce qui comprend l'installation de programmes, la navigation sur Internet ou même l'amorçage à partir de ce lecteur.

Branchez plutôt ce lecteur comme lecteur secondaire (esclave) sur un système fonctionnel. Installez et exécutez GetDataBack sur le système sain. Lisez la section récupération des données pour savoir comment procéder.

Si vous pensez que votre lecteur peut présenter un problème physique ou si vous obtenez des erreurs de lecture lors de l'examen avec GetDataBack, pensez à créer d'abord une image du lecteur.

Si votre lecteur présente des problèmes physiques sévères, nous vous conseillons vivement de vous abstenir de tenter le tout pour le tout en voulant vous-même récupérer les données à tout prix et de confier votre lecteur à un laboratoire spécialisé.

L'examen d'un lecteur externe peut prendre beaucoup de temps, surtout si vous utilisez un port USB1. Si possible, ôtez le lecteur de son support et branchez-le directement à la nappe IDE interne de votre ordinateur. Cherchez sur Internet pour savoir comment mener ceci à bien.

Si vous avez des questions concernant ce logiciel, consultez notre F.A.Q. ou contactez le support technique.

Voir aussi : Effectuer une récupération, F.A.Q., Assistance technique, Liste des vérifications Accord de Licence


Installation

N'installez pas GetDataBack sur le lecteur que vous souhaitez récupérer! Il est fortement conseillé de procéder comme suit:

Installez le programme sur un autre ordinateur qui ne présente aucun problème. Si vous avez le choix, préférez l'ordinateur qui possède le plus de RAM et qui est le plus rapide. Branchez le lecteur à récupérer comme esclave sur cette machine. Vérifiez bien que que le cavalier est placé correctement sur le lecteur et que celui-ci est reconnu par le BIOS.

Après avoir téléchargé GetDataBack, exécutez le programme d'installation. Ce programme va vous guider tout au long du processus d'installation.

Utilisateurs NT/XP: Vous devez posséder les droits Administrateur pour exécuter ce programme.

Langue: Vous pouvez choisir la langue du programme (actuellement Anglais, Allemand ou Français). Cliquez sur Outils -> Sélectionner la langue et choisissez votre langue. Si vous choisissez "default" la langue sera définie par votre configuration locale de Windows.

Voir aussi : Effectuer une récupération des données


System Requirements

Configuration Nécessaire

  • Processeur Pentium
  • 32-128 Mo de RAM (en fonction de la capacité du lecteur à récupérer)
  • Windows 95/98/ME, Windows NT, 2000, XP

Pour de meilleurs résultats, choisissez votre ordinateur le plus rapide et le plus chargé en RAM, et branchez le lecteur à récupérer sur cette machine.

Voir aussi : Installation, Effectuer une Récupération des Données


GDB

GDBNT.INI

Ce fichier contient certaines définitions concernant le moteur de récupération de GetDataBack:

  • La section LostFiles contient les définitions de fichiers concernant la fonction Récupérer les Fichiers Perdus
  • La section Modèles contient les définitions du système de fichiers pour la fonction Modèle de l'Etape 1.


Version Info

Infos de Version

Cette fenêtre affiche les numéros et dates de version des composants de programme suivants:

  • Nom du produit est le nom du logiciel.
  • Version est le numéro de la version actuelle.
  • Nom du programme est le nom du fichier EXE.
  • Date du fichier programme est la date du fichier EXE.
  • Emplacement DRV16 est le dossier contenant DRV16. Ce fichier est le pilote permettant d'accéder au disque dur et est nécessaire pour Windows 95/98/ME.
  • Version DRV16 est le numéro de version du pilote du disque dur.
  • Date DRV16 est la date du pilote du disque dur.
  • Fichier d'aide est le nom de ce fichier d'aide.
  • Répertoire d'installation est le dossier dans lequel ce logiciel est installé.
  • Fichier INI est le nom du fichier INI de ce logiciel.


Menu structure

Structure du Menu

Fichier |  |
 | Charger une récupération | charge un examen précédent ou une arborescence de récupération
 | Enregistrer une récupération | enregistre un examen ou une arborescence de récupération
 | Quitter | quitte le programme
Récupération |  |
 | Copier... | copie les fichiers ou dossiers récupérés vers une destination sûre
 | Ouvrir | ouvre un fichier avec son application native
 | Ouvrir avec... | sélectionne une application pour ouvrir un fichier
 | Afficher les infos... | affiche des informations concernant les détails de la récupération d'un fichier
 | Afficher | affiche un fichier avec la visionneuse interne
 | Renommer | renomme un fichier
Outils |  |
 | Chercher des fichiers... | cherche des fichiers dans l'arborescence de récupération
 | Recherche suivante | poursuit la dernière recherche
 | Appeler DiskExplorer | appelle Runtime's DiskExplorer pour la structure actuellement sélectionnée
 | Créer un Fichier Image... | clone le lecteur ou la partition actuellement sélectionnée
 | Options... | modifie les réglages de la récupération
 | Sélectionner la langue | change la langue du logiciel
Aide |  |
 | Sommaire | appelle l'aide intégrée
 | Enregistrement | permet d'entrer une clé de licence pour libérer la pleine puissance du logiciel
 | A propos de | affiche les informations de copyright, de licence et de version
 | Infos de version | affiche davantage d'informations concernant la version
 | Afficher la structure des données | affiche la structure des données utilisées par GetDataBack (utilisation interne)
 | Instantané système pour le support client | Crée un instantané de la récupération pour l'assistance technique


Registration

Enregistrement

Enregistrer votre logiciel va vous permettre de copier vos fichiers et dossiers récupérés dans un emplacement sûr.

Enregistrez votre exemplaire en ligne sur notre site web http://www.runtime.org et obtenez immédiatement une clé d'enregistrement.

Si vous préférez ne pas acheter en ligne, téléphonez au 1-808-329-2202 (USA) ou au +49-30-280 8008 (Allemagne).

Entrer la Clé de Licence

Lorsque vous entrez la clé de licence, soyez sûr d'entrer le nom et la clé de licence, exactement comme vous les avez reçus dans l'email qui vous a été adressé. Le nom et la clé fonctionnent ensembles et GetDataBack sera enregistré avec succès seulement si vous entrez les deux. Nous vous conseillons de copier et de coller les informations à partir du message d'enregistrement.


License Agreement

Accord de Licence et Déni de Responsabilité

Ci-dessous les conditions selon lesquelles un logiciel Runtime Software est vendu, assisté techniquement et utilisable. En utilisant et en enregistrant un logiciel Runtime Software, vous acceptez ce qui suit.
Ce document peut être étoffé ou remplacé par les conditions concernant les applications spécifiques.

Ni le ou les auteurs, ni Runtime Software ne seront tenus pour responsables de tout frais, dommage ou perte à la suite de votre utilisation de ce logiciel, quelle qu'en soit la cause.
Toutes les marques déposées utilisées ici sont enregistrées par leurs propriétaires. Cette information est proposée à la place d'une liste spécifique des marques déposées et de leurs propriétaires.

Si vous enregistrez un logiciel de Runtime Software, nous supposons que vous le faites après avoir testé la version shareware et vous être assuré qu'il répond à votre matériel et à vos besoins. Nous ne pourrons pas vous rembourser l'enregistrement du shareware si vous changez d'avis par le suite.

Aucune partie de la documentation de ce logiciel ou de l'un de ses fichiers associés ne pourra être reproduit dans sa totalité ou en partie sur un quelconque média ou sous la forme d'une transmission exclusive du fichier archive du logiciel sans l'autorisation expresse écrite de Runtime Software. Vous ne pouvez pas modifier ou proposer un correctif pour les fichiers exécutables du logiciel de quelque manière que ce soit, y compris, mais sans limitation, décompiler, désassembler ou modifier la conception du programme.

L'enregistre du logiciel vous permet d'acheter une licence utilisateur simple que vous pouvez utiliser à vie, et soumise aux termes évoqués ici. Ce qui signifie que votre logiciel enregistré ne peut être utilisé que par une personne à la fois. Une licence utilisateur simple ne vous permet pas de rendre ce logiciel disponible sur un réseau pour plusieurs utilisateurs, de le distribuer sous une forme quelconque ou de le proposer en parallèle à tout autre produit sans la permission expresse de Runtime Software. Si vous avez des questions concernant le licence du logiciel, n'hésitez pas à nous contacter.

Si vous avez téléchargé ce logiciel ou s'il vous a été fourni sur un disque pour essai, vous pouvez utiliser gratuitement la version limitée du logiciel, mais pour utiliser la version complète du logiciel, vous devez l'enregistrer immédiatement.

Vous pouvez distribuer le logiciel (sur CD-ROM, Livre, Catalogue, Internet etc.) tant que vous respectez chaque condition et toutes les conditions ci-dessous:

1. Vous ne distribuez que des exemplaires identiques, non modifiés de la version du shareware d'origine non enregistrée, y compris le DENI DE RESPONSABILITE.
2. Vous ne demandez aucun frais ni compensation financière pour ces exemplaires, sans la permission préalable de Runtime Software.
3. Vous insérez la phrase "Copyright par Runtime Software" à tout exemplaire du logiciel.


Glossary

Glossaire

Allocation d'Index

Une allocation d'index est la valeur externe de l'attribut $A0 non résident, qui contient une liste de noms de fichiers établissant un répertoire.

Arborescence de Récupération

Affichage style Explorateur de tous les fichiers et dossiers. Voir Étape 3, Charger et Enregistrer une Récupération.

Attributs

Les Attributs font souvent référence aux attributs DOS: Archive, Lecture Seule, Dossier, Caché, Système, Volume. Voir : Étape 3.
Sous NTFS, les attributs sont des structures qui décrivent entièrement un fichier.

Cloner un lecteur

Créer l'image exacte secteur par secteur d'un lecteur. Recommandé lorsque vous souhaitez effectuer la récupération des données d'un lecteur endommagé physiquement (secteurs défectueux). Avec cette image, vous pourrez travailler comme vous l'auriez fait sur le lecteur d'origine.

Cluster

Un cluster est la plus petite unité adressable par le système de fichiers. Un cluster représente toujours le multiple d'un secteur. Les tailles de clusteurs représentent 1, 2, 4, 8, 16, 32, 64, 128 secteurs.

Descripteur de Média

Octet indicateur dans le secteur de démarrage et au début d'une FAT décrivant le type de lecteur. Habituellement xF8 pour les disques durs.

Entrée de Fichier (entrée MFT uniquement)

Une entrée de fichier NTFS est une entrée dans la MFT.

Entrée de Partition

Une entrée de partition décrit le type, l'emplacement et la taille d'une partition.

Entrée de Répertoire

Dans un système de fichiers FAT une entrée de répertoire est une zone de 32 octets contenant des informations de fichier comme le nom, la date, la taille, le premier cluster du fichier.

Examen

Un examen est le processus consistant à scanner chaque secteur élémentaire d'un lecteur. Voir Étape 1, Charger et Enregistrer la Récupération.

FAT

La FAT (Table d'Allocation des Fichiers) contient les information d'allocation des fichiers d'un système de fichiers FAT. Il existe trois sortes de FAT:

12 bit FAT (FAT12) | peut adresser jusqu'à 4096 clusters
16 bit FAT (FAT16) | peut adresser jusqu'à 65536 clusters
32 bit FAT (FAT32) | peut adresser jusqu'à 4294967296 clusters

Le système de fichiers conserve deux exemplaires de la FAT: FAT1 et FAT2.

Fichier Image

Un fichier image est la copie secteur par secteur d'un lecteur. Un fichier image est utilisable comme source pour GetDataBack.

Fichier Perdu

Les Fichiers Perdus sont des fichiers sans aucune information de répertoire enregistrée.

Fichier supprimé

Un fichier est supprimé au sein d'un système de fichiers FAT en remplaçant le 1er caractère de son entrée de dossier par xE5 et en libérant les entrées de la FAT des clusters qu'il utilisait. Au niveau d'un système de fichiers NTFS, un fichier est supprimé en faisant en sorte que sa référence au niveau de la MFT soit inutilisée. Modifiez les Options si vous souhaitez inclure les fichiers supprimés dans la récupération.

Hexadécimal

Le système hexadécimal est basé sur le nombre 16, contrairement au système décimal qui est basé sur le nombre 10. Les autres symboles de caractères sont A, B, C, D, E et F. Exemple: hex AA = déc 170. (10*16 + 10*1).

Lecteur Logique

Les Lecteurs Logiques sont des lecteurs comme A:, B:, C:, ... Ils sont accessibles à l'aide des routines du système d'exploitation.

Lecteur Physique

Les Lecteurs Physiques sont des médias tangible comme les disques durs et les disquettes. Ils sont accessibles via les fonctions BIOS de bas niveau.

LFN

Le LFN (nom de fichier long) a d'abord été introduit dans le système de fichiers FAT avec Windows95. Le LFN utilise plusieurs entrées de répertoire qui font apparaître le nom de fichier long utilisé sous Windows95.
NTFS utilise des attributs pour enregistrer un LFN.

Liste d'Exécution

Une liste d'exécution est un liste des clusters utilisés pour un Attribut NT. Si les attributs sont trop importants pour s'ajuster dans l'Entrée MFT, certains d'entre eux seront non résidents, ce qui signifie qu'une partie de la valeur de l'attribut spécifique se trouvera en dehors de l'entrée. Dans ce cas, l'allocation des données externes sera décrite par une liste d'exécution.

Modèles

Un modèle est une définition de système de fichier qui peut être utilisé sur les structures d'un système de fichiers connu, comme une disquette, un lecteur Zip, etc.

NTFS

Système de fichiers introduit avec WindowsNT, utilisé par Windows NT, Windows 2000 et Windows XP.

Partition

Une partition est une région continue d'un lecteur physique. Elle est normalement interprétée par le système d'exploitation comme un lecteur logique.

Récupération des données

Le processus de récupération des fichiers d'un lecteur qui n'est plus accessible à partir du système d'exploitation.

Région de Clusters

Ce terme fait référence à la zone du système de fichiers adressable par un certain nombre de clusters. Il s'agit - dans un système de fichiers FAT - des secteurs suivant le Secteur de Démarrage, les FAT et le Dossier Racine (FAT12, FAT16 seulement).

Répertoire

Dans un système de fichiers FAT, un répertoire est une liste d'entrées de répertoires. Dans un système NTFS, un répertoire est une liste d'entrées d'Index.

Répertoire Racine

Le répertoire racine d'un système de fichiers représente la racine de l'arborescence des répertoires.
Dans la FAT12 et la FAT16, le répertoire racine est situé dans la région qui suit la seconde FAT. Dans la FAT32, le répertoire racine débute par le cluster spécifié dans le secteur de démarrage.
Dans NTFS, le répertoire racine est décrit par le tampon d'index de l'entrée #5 de la MFT.

Secteur

Un Secteur est la plus petite unité accessible d'un lecteur. La taille d'un secteur est toujours de 512 octets. Plusieurs secteurs sont groupée en "clusters".

Secteurs par Cluster

Ce terme décrit la taille de cluster que le système de fichiers utilise. Il est essentiel pour traduire un nombre de clusters en un nombre de secteurs physiques.

Secteur de Démarrage

Un secteur de Démarrage est un secteur particulier décrivant le système de fichier suivant ce secteur.

Système de fichiers

Le système de fichiers (tel que FAT ou NTFS) représente le plan selon lequel un fichier est enregistré sur un disque. A ne pas confondre avec le système d'exploitation (tel que Windows95 ou WindowsNT).

Système de fichiers FAT

Nom d'un système de fichiers utilisant une "table d'allocation des fichiers". Introduit avec DOS et utilisé dans toutes les versions de Windows.

Table de Partition

La table de partition est la liste des entrées d'une partition située dans le secteur 0 d'un lecteur. Si un lecteur contient des "partitions étendues", il existe une liste liée de plusieurs tables de partitions sur le lecteur.

Introduction Menu Glossaire


Prepare a Recovery

Effectuer une Récupération des Données

Vous trouverez ci-dessous la description d'une récupération typique de données:

  1. Installez GetDataBack sur une machine Windows saine, sans que le lecteur dont vous souhaitez récupérer les données soit branché. Vérifiez que vous avez suffisamment d'espace sur le "bon lecteur" pour y enregistrer les données récupérées. Vous pouvez aussi copier les données sur un LAN si vous en avez l'accès. La machine sur laquelle vous exécutez GetDataBack peut fonctionner sous les systèmes d'exploitation suivants: Windows95/98/ME, Windows NT, W2K, Windows XP.

  2. Éteignez l'ordinateur et branchez le lecteur dont vous souhaitez récupérer les données (le "mauvais lecteur") comme lecteur secondaire. Vous devrez placer son cavalier autrement. Vérifiez qu'il est bien reconnu par le BIOS lors du démarrage de l'ordinateur.
  3. Lancez GetDataBack et vérifiez que HD128: est le "bon lecteur" et que HD129: est le "mauvais lecteur. Exécutez les Étapes 1 à 3 du processus de récupération pour le "mauvais lecteur" HD129:. Suivez les instructions proposées pour chacune des étapes.
  4. Lorsque l'Étape 3 est terminée et que vous êtes prêt à copier les fichiers récupérés sur le "bon lecteur", vous devez achetez une clé de licence si ça n'est déjà fait. Ne quittez pas GetDataBack pour acheter ou entrer le code de la licence, mais entrez simplement le code et poursuivez en copiant les fichiers. Il est préférable de commencer par les fichiers dont vous avez le plus besoin.
  5. Après avoir copié les fichiers désirés, éteignez l'ordinateur et débranchez le "mauvais lecteur". Rangez-le dans un endroit sûr.
  6. Il est conseillé de créer maintenant une nouvelle mouture du système. Utilisez d'autres composants que ceux du "mauvais lecteur". Installez le système d'exploitation. Installez les programmes à partir de leurs CD-ROM d'installation. Enfin, importez les données récupérées dans le nouveau lecteur.
  7. Vérifiez que vous avez restauré toutes les données dont vous avez besoin. Ne recyclez pas le "mauvais lecteur" avant d'être absolument sûr de ceci. Il est préférable d'attendre 4 semaines avant de réutiliser le "mauvais lecteur". Si le "mauvais lecteur" présente des problèmes mécaniques, il faut songer définitivement à ne plus le réutiliser.

Si vous remarquez des problèmes mécaniques avec le lecteur, comme la présence de secteurs défectueux ou un bruit inhabituel, cessez la récupération et créez d'abord une image du lecteur. Quand c'est fait, vous pouvez récupérer les données à partir de cette image du lecteur comme vous l'auriez fait à partir du lecteur d'origine. Un lecteur endommagé mécaniquement peut tomber entièrement en panne à tout instant. Votre objectif principal doit être d'extraire toutes les données brutes d'un tel lecteur aussi vite que possible. Créer une image réduit également la charge du lecteur car chaque secteur est immédiatement en lecture seule. Les sociétés professionnelles de récupérations de données créent toujours une image avant de tenter la récupération des fichiers.

Si vous vous écartez du processus décrit ci-dessus, soyez toujours certain

  • de ne jamais installer GetDataBack sur le "mauvais lecteur",
  • de ne jamais utiliser le "mauvais lecteur" comme lecteur du système de démarrage (C:),
  • de ne pas avoir de fichiers et dossiers temporaires qui utilisent le "mauvais lecteur",
  • de ne jamais copier les fichiers récupérés sur le "mauvais lecteur",
  • de créer d'abord une image si le "mauvais lecteur" rencontre des problèmes mécaniques.

GetDataBack vous propose beaucoup d'options: Vous pouvez récupérer les données du disque dur, actuel, de fichiers image ou même de lecteurs distants via un câble série ou le TCP/IP. Vous pouvez même récupérer les données via Internet ou en créant un disque de démarrage WinPE/BartPE.

Voir aussi : F.A.Q., Assistance Technique, Liste de Vérifications


Step 1

Étape 1 - Sélectionner un Lecteur

A l'Etape 1, vous allez sélectionner le lecteur dont vous souhaitez récupérer les données. Tous les lecteurs et périphériques accessibles sont affichés parmi les lecteurs disponibles du côté gauche. Quand vous sélectionnez un lecteur ou une partition, d'autres informations apparaissent (comme la géométrie et le nombre de secteurs) concernant le lecteur que vous avez sélectionné, à la section Détails.

Quelle entrée choisir?

Du fait que le partitionnement d'origine n'est plus cohérent, il est préférable d'examiner le lecteur physique entier.

Vous devriez opter pour les lecteur physique plutôt que pour les lecteurs logiques, car les lecteurs logiques sont déjà interprétés par le système d'exploitation. Très souvent, vous ne verrez même pas le lecteur logique susceptible de contenir vos données à récupérer. Les lecteurs physiques offrent un accès de bas niveau aux données brutes du lecteur le moins perturbé.

Lors d'une récupération des fichiers supprimés, vous pouvez choisir la partition qui contenait ces fichiers avant leur suppression plutôt que de choisir le lecteur entier - mais seulement si la partition d'origine est encore intacte.

Lecteurs Physiques

Tous les lecteurs physiques disponibles seront énumérés avec leurs partitions en-dessous - cliquez sur le signe plus pour afficher les partitions. Les lecteurs physiques sont nommés par leur numéro de BIOS : FD0 est le premier lecteur de disquette, FD1 est le second lecteur de disquette, HD128: est le premier disque dur, HD129: est le second disque dur, etc.

Lecteurs Logiques

Tous les lecteurs logiques de votre système seront affichés avec la lettre de lecteur qui leur a été assignée (A:, B:, C:, ...).

Fichiers Image et lecteurs distants

Vous pouvez aussi charger un fichier image ou un lecteur distant en cliquant sur le bouton correspondant

Si le fichier image correspond à l'image d'un lecteur physique, toutes les partitions seront également affichées et vous pourrez le traiter comme un lecteur physique.

Les lecteurs distants sont les lecteurs physiques d'un autre ordinateur, accessibles via un câble série ou le TCP/IP. Ils sont à traiter comme des lecteurs physiques.

Images Virtuelles (RAIDS)

Vous chargerez probablement une image virtuelle si vous voulez récupérer un volume RAID cassé. Des images virtuelles sont des fichiers texte simples décrivant le RAID. Si vous connaissez les détails de votre RAID vous pouvez créer ce fichier vous-même. Normalement vous utiliseriez le fichier d'image virtuel produit par RAID Reconstructor de Runtime.

Sélectionnez maintenant le lecteur ou la partition que vous souhaitez récupérer et cliquez sur Suivant.

GetDataBack va alors examiner le lecteur et le processus de récupération va alors battre son plein.

En fonction de la taille du lecteur, ce processus peut prendre de quelques minutes à plusieurs heures. N'interrompez pas le processus sauf en cas de nécessité - sinon, vous devrez recommencer la totalité de l'examen.

Effectuer une récupération multi-partitions

Lorsque vous devez récupérer les données d'un lecteur qui présente plus d'une partition et que vous avez besoin des données de toutes ces partitions, lisez les informations ci-dessous.

Du fait que GetDataBack effectue la récupération au niveau partition, la règle générale est la suivante :

Sélectionner une entrée qui contient la totalité de la partition à récupérer. L'entrée choisie ne doit pas être un sous-ensemble de cette partition. Elle doit être plutôt un sur-ensemble.

Exemples:

Vous souhaitez récupérer: Sélectionnez cette entrée:
2nd lecteur qui contenait une partition 2nd disque dur (HD129:)
1ère partition du 2nd lecteur (40Go) contenant 4 partitions de 10Go chacune. L'arborescence a cet aspect:

(1) 2nd disque dur 40000Mo (HD129:)
(2) + 1ere partition (FAT32) 10000Mo
(3) + 2nd partition (DOS Etendue) 30000MB
(4) + 1ère partition (FAT32) 10000Mo
(5) + 2nd partition (DOS Etendue) 10000Mo
(6) + 1ère partition (FAT32) 10000Mo
(7) + 2nd partition (DOS Etendue) 10000Mo
(8) + 1ère partition (FAT32) 10000Mo

L'entrée (2) est l'entrée à choisir.

Si vous souhaitez récupérer aussi les autres partitions, sélectionnez l'entrée (4) pour la 2nd partition, l'entrée (6) pour la 3ème partition et l'entrée (8) pour la 4ème partition.

Vous pouvez aussi sélectionner l'entrée (1) et les 4 partitions apparaîtront à l'Etape 2. Cependant, il est conseillé de récupérer les partitions une par une si possible.

Même exemple que ci-dessusn mais l'arborescence a cet aspect:

(1) 2nd disque dur 40000Mo (HD129:)

La table de partition est manifestement endommagée. Ainsi, vous devez choisir l'entrée (1) et les 4 partitions apparaîtront à l'Etape 2.

Vous pouvez définir manuellement une plage de secteurs dans Examen Partiel à gauche pour que la plage sélectionnée soit mieux adaptée. Experts seulement!

Normalement vous devriez récupérer la partition FAT comme source pour en effectuer la récupération des données. C'est seulement si la bonne partition (avec une taille et une position approximative correctes) n'apparaît pas que vous utiliserez la partition DOS étendue ou le lecteur entier.

Remarque: Choisir une certaine partition n'est rien de moins que choisir un certain secteur de début et de fin à examiner sur un lecteur particulier.

Examen Partiel

Cliquez sur Examen Partiel à droite de l'écran si vous souhaitez réduire la zone du lecteur que GetDataBack inclura à son examen.

Comprenez bien que vous ne devriez modifier la plage de secteurs que si vous savez exactement ce que vous faites.

Normalement, cette plage est déjà correctement définie et vous n'avez rien à modifier.

Réduire la plage de secteurs à examiner à la zone où se situait le système de fichiers accélérera la récupération et en améliorera les résultats.

Cependant, ne modifiez pas la plage de secteurs à examiner sauf

  • si la partition à récupérer ne s'affiche pas correctement à l'Etape 1 et que vous avez dû sélectionner la totalité du lecteur,
  • ou si la plage de secteurs pré définie ne semble pas satisfaisante et si vous savez où se situe approximativement la partition.

Pour ce faire, sélectionnez "Rechercher un lecteur partiel" et entrez le premier et le dernier secteur du lecteur ou de la partition. Si vous ne connaissez pas la plage avec précision, il est préférable d'entrer une plage plus large que trop petite: La plage sélectionnée doit contenir complètement la partition à récupérer.

Système de Fichiers

Normalement, le logiciel n'a aucun problème pour détecter le bon système de fichiers, mais pour en être sûr, vérifiez que le bon système de fichiers du lecteur à récupérer est sélectionné. Si ça n'est pas le cas, choisissez le type correct de système de fichiers à partir de la liste déroulante:

  • FAT12 est normalement associée aux disquettes et aux lecteurs inférieurs à 16Mo.
  • FAT16 est utilisée pour les lecteurs sous toutes les versions DOS, Windows 2.xx, Windows 3.xx et les premières versions de Windows 95 et NT. Taille maximale d'une partition: 2Go.
  • FAT32 est normalement utilisée sur les lecteurs supérieurs à 512Mo sous Windows95 (OEM Rel. B), Windows 98, ME et les lecteurs formatés FAT sous W2K et XP.

Modèle

Si vous connaissez exactement les paramètres du système de fichiers, vous pouvez proposer un Modèle pour prendre en charge la reconnaissance du système de fichiers. Sinon, sélectionnez "aucun".

Voir les Options en Cours

Ouvrez cet onglet pour afficher les options actuellement définies.

Charger un Examen

Cliquez sur le bouton Charger si, plutôt que d'examiner un lecteur ou une partition, vous préférez charger un examen ou une récupération de données déjà effectués.

Voir aussi : Lecteurs, Examiner le lecteur


Drives

Lecteurs

En plus des lecteurs physiques et logiques, des lecteurs de disquettes, Jaz et Zip, GetDataBack accepte les fichiers image et les images virtuelles comme sources de données à récupérer. GetDataBack accepte cinq différents types de sources de données à sélectionner:

  • Lecteurs physiques
  • Lecteurs logiques
  • Fichiers image
  • Lecteurs distants
  • Images virtuelles

Voir aussi : Étape 1


Physical drives

Lecteurs physiques

Les lecteurs physiques sont des médias tangibles comme les disques durs et les disquettes. Ils portent des noms spécifiques :

FD0 | 1er lecteur de disquette
FD1 | 2nd lecteur de disquette
HD128 | 1er disque dur
HD129 | 2nd disque dur

Ces lecteurs peuvent présenter des partitions que vous pouvez sélectionner. Si vous le faites, seule la partie du lecteur ("fenêtre") qui constitue cette partition est visible de GetDataBack. Si possible, vous devriez sélectionner une telle partition comme entité de l'examen que GetDataBack doit effectuer. Si vous ne voyez aucune entrée de partition, sélectionnez l'entrée symbolisée par [image] .

Voir aussi : Lecteurs, Étape 1


Logical Drives

Lecteurs logiques

Les lecteurs logiques sont des volumes connus du système d'exploitation sous : A:, B:, C: etc..

Vous pouvez choisir cette option dans le but d'explorer un tel volume. Une autre façon d'accéder à ces lecteurs consiste à sélectionner une partition dans un lecteur physique.

Voir aussi : Lecteurs


Image Files

Fichier Image

Un fichier image est un fichier contenant l'image brute d'un lecteur. Vous pouvez effectuer une récupération à partir d'un fichier image comme à partir d'un lecteur physique ou logique. Cliquez sur Fichier image (Autre chargement) à l'Etape 1 pour ouvrir un fichier image comme un lecteur.

Même les partitions visibles à l'intérieur des lecteurs physiques sont affichées lorsqu'elles sont contenues dans le fichier image.

Cloner un lecteur entier

Vous pouvez créer un fichier image à l'aide de la commande Outils->Créer un fichier image. Vous pouvez utiliser le fichier image au lieu du lecteur d'origine. Vous pouvez aussi utiliser des fichiers image créés avec un autre logiciel, comme Runtime's DiskExplorer.

Fichiers Multiples

Un fichier image peut être composé:

  • d'un fichier (ex.: 'drive128.img')

  • de plusieurs fichiers (ex.: 'drive128.img', 'drive128.001', 'drive128.002', ...)

Ce qui est utile lors de la création d'un fichier image de lecteur supérieur à la taille de fichier maximum (2Go ou 4Go, en fonction du système d'exploitation). Les fragments d'une image à fichiers multiples occupent environ 656Mo. Une taille inférieure indique la fin du jeu de fichiers.

Compression

Vous pouvez utiliser des fichiers image compressés (ex.: 'drive128.imc') en sélectionnant 'Fichier image de données compressé (*.imc)' comme type de fichier dans la boîte de dialogue d'ouverture de fichier. Cette fonction vous permet de créer des images de lecteurs de taille inférieure à l'original.

Les fichiers compressés peuvent aussi être des images à fichiers multiples.

Voir aussi : Lecteurs, Ouverture d'un Fichier et Création d'un Fichier


File Open and File Create

Ouverture d'un Fichier et Création d'un Fichier

Cette boîte de dialogue nécessite un nom de fichier à ouvrir ou à créer.

Vous pouvez choisir entre les Types de Fichiers suivants :

  • Fichiers image (IMG) qui sont des copies brutes de lecteurs.
  • Fichiers image compressés (IMC) qui sont des copies brutes compressées de lecteurs.
  • Images virtuelles (VIM) (lecture seule) qui sont des scripts décrivant l'agencement de plusieurs autres types de lecteurs.

Les Fichiers image et les fichiers image compressés se présentent sous deux moutures en fonction de cette option:

  • Fichiers multiples désactivé pour enregistrer les données dans un seul fichier.
  • Fichiers multiples activé pour enregistrer les données dans plusieurs fichiers de 656Mo chacun. Ce qui crée des images plus pratiques et aide à contourner les restrictions concernant la taille des fichiers.

Voir aussi : Lecteurs


Virtual images

Image Virtuelle

*

Les Images Virtuelles sont de petits fichiers texte décrivant les données qui vont être chargées. Ainsi, vous pouvez "coller" ensemble des sources de données différentes. C'est très utile si vous voulez récupérer le volume RAID.
Par exemple, RAID Reconstructor de Runtime crée des images virtuelles que vous pouvez utiliser ici.

Les images virtuelles ont toujours des extensions "vim".

Vous pouvez également créer vos propres images virtuelles. Les images virtuelles sont des fichiers XML ayant des commandes ("tags"). Vous pouvez réunir autant de disques que vous le voulez, tant que la capacité totale n'excède pas 2 To.

<virtualimage>

C'est le Tag racine qui inclut tous les autres Tags.

Exemple:

<virtualimage>
:
:(other tags)
:
</virtualimage>

<sector>

Ce Tag règle le nombre de secteurs de l'image virtuelle à une nouvelle valeur. Tous les vides (trous,) créés par cette modifiication, seront remplacés par des 0.

Exemple:

<virtualimage>
:
<sector>1000</sector>
:
</virtualimage>

<drive>

Ce Tag décrit un disque en cours d'utilisation. Vous pouvez aussi spécifier certains secteurs à l'intérieur de ce disque.

Exemple:

<virtualimage>
<drive>HD128:</drive>
</virtualimage>

Cet exemple d'une image virtuelle complète utilise votre 1er disque dur (HD128:). Assurez-vous de toujours ajouter deux-points au nom du disque.

Un autre exemple:

<virtualimage>
<drive>HD128:0-999</drive>
<drive>c:\images\myimage.img:1000-</drive>
</virtualimage>

Cet exemple dresse la carte des 1000 premiers secteurs du disque dur 128 de votre image virtuelle. Les secteurs compris après le secteur 1000 seront ignorés du dossier de l'image "c:\images\myimage.img". Les gammes sont spécifiées en ajoutant deux numéros, séparées par un tiret. Si vous omettez le deuxième nombre, la gamme s'étendra jusqu'à la fin du disque respectif.

les noms des disques possibles sont:

HD128:, HD129:, etc | 1er, 2ème disque physique etc.
FD0:, FD1: | 1ère, 2ème disquette
C:, D:, etc. | Volume logique C:, D:, etc.
myfile.img, myfile.imc | Fichiers Image
NULL: | Disque Virtuel, donne des secteurs vides. Doit être suivi par une gamme.

<loop>

Utiliser le Tag <loop> pour définir les volumes RAID.

Exemple de définition de 3 disques RAID-5 avec une taille de bloc de 128, retour en arrière:

<virtualimage>
<loop>
<drive>c:\img\raid5\r1.img:</drive>
<drive>c:\img\raid5\r2.img:</drive>
<drive>c:\img\raid5\r3.img:</drive>
<cycle blocksize="128">
<stripe>1,2</stripe>
<stripe>1,3</stripe>
<stripe>2,3</stripe>
</cycle>
</loop>
</virtualimage>

Après avoir introduit le tag <loop>, indiquez les disques que vous voudriez utiliser en RAID. Pour la syntaxe du tag <drive> voir les spécifications ci-dessus.

Dans le tag <cycle> , définissez les "stripes" composant le RAID. Chaque "stripe" est une séquence de données prises sur les précédents disques définis. Définissez la taille des blocs comme un attribut pour le tag <cycle>. Vous devriez lire l'exemple ci-dessus:

  1. Prendre les 128 secteurs du 1er disque (secteurs 0-127).

  2. Prendre les 128 secteurs du 2ème disque (secteurs 0-127).

  3. Prendre les 128 secteurs du 1er disque (secteurs 128-255).

  4. Prendre les 128 secteurs du 3ème disque (secteurs 128-255).

  5. Prendre les 128 secteurs du 2ème disque (secteurs 256-383).

  6. Prendre les 128 secteurs du 3ème disque (secteurs 256-383).

Cela continue jusqu'à ce que la fin d'un disque ne soit atteinte. Le plus petit disque détermine la taille de la boucle. Si le disque le plus petit est de 10000 secteurs, la taille totale est 20000 arrondie jusqu'au cycle complet, qui est 20736. Vous pouvez changer la taille de la boucle de deux façons:

1) Spécifiez le nombre de répétition de la boucle. Vous pouvez le faire en ajoutant un attribut "répèter" au tag <loop>, par exemple : <loop repeat="27" >. Dans l'exemple de RAID, en répétant le cycle 27 fois rapportera 6x128x27 secteurs, soit 20736.

2) Spécifiez une gamme. En ajoutant l'attribut "range" au tag <loop>, exemple.: <loop range="10-20".

"La répétition" a la priorité sur la taille implicite déterminée par les disques."La gamme" a la priorité sur "la répétition".

Vous pouvez même définir un volume RAID5 incomplet . Si, comme dans l'exemple ci-dessus, le 3ème disque était manquant, vous pourriez décrire le volume comme cela:

<virtualimage>
<loop>
<drive>c:\img\raid5\r1.img:</drive>
<drive>c:\img\raid5\r2.img:</drive>
<cycle blocksize="128">
<stripe>1,2</stripe>
<stripe>1,1x2</stripe>
<stripe>2,1x2</stripe>
</cycle>
</loop>
</virtualimage>

L'expression 1x2 calculera le secteur manquant, à l'origine sur le 3ème disque.

Voir aussi : Drives


Remote Drive Access

Lecteurs distants

Cette fonction vous permet d'exécuter GetDataBack sur un ordinateur ("distant") tout en accédant aux lecteurs d'un autre ordinateur ("hôte").

L'ordinateur "distant" exécute GetDataBack, l'ordinateur "hôte" exécute HDHost. HDHost est un programme disponible au téléchargement sur http://www.runtime.org.

Du côté hôte, appelez le programme HDHOST.EXE et configurez la connexion souhaitée. Quand c'est fait, cliquez sur Attendre la connexion.

Du côté GetDataBack, cliquez sur Lecteurs Physiques Distants (Autre chargement...) à l'Etape 1. Une nouvelle fenêtre apparaît vous demandant de sélectionner et de configurer le type de connexion. Quand c'est fait, cliquez sur Connexion et une autre fenêtre apparaît pour afficher les lecteurs physiques disponibles sur l'ordinateur hôte. Sélectionnez-en un et vous êtes renvoyé à l'écran de sélection d'un lecteur. Cliquez sur Ok et le lecteur distant est chargé.

Vous pouvez établir deux types différents de connexion:

  • une communication série via un RS232 (port Com)
  • une communication TCP/IP via une carte d'interface réseau (NIC)

La communication série est vraiment lente, et vous choisirez probablement le TCP/IP. Cependant, la communication série est plus facile à définir et chaque ordinateur est équipé d'un port série.

Communication Série

La communication série nécessite un câble Null-Modem pour relier les deux ordinateurs via le port COM. Des deux côtés, sélectionnez le numéro de port auquel ce câble est connecté. Les deux côtés doivent utiliser le même Débit en Bauds.

Communication TCP/IP

La communication TCP/IP d'un LAN nécessite une carte d'interface réseau (NIC).

Comme Connexion, choisissez l'IP associée à votre NIC. Si l'ordinateur n'obtient pas d'adresse IP assignée par un serveur DHCP, vous devrez assigner une adresse IP statique dans la configuration réseau de Windows. L'adresse typique pour cette machine est 192.168.1.51 et pour l'hôte 192.168.1.50.

Comme pour l'IP de l'hôte, choisissez l'IP de la connexion de l'hôte. Vous devrez spécifier une adresse IP statique (comme 192.168.1.50) dans la configuration réseau de Windows pour l'ordinateur hôte.

Conseils:

  • Si vous rencontrez des problèmes de connexion, essayez de faire un PING entre l'hôte et le distant. Affichez la ligne de commande et entrez ping 192.168.1.50 sur cet ordinateur. Essayez de faire un ping 192.168.1.51 sur l'ordinateur hôte (ce qui suppose que 192.168.1.50 soit l'IP de l'hôte et 192.168.1.51 l'IP de cet ordinateur). Le ping doit être réussi des deux côtés.
  • Désactivez tous les Pare-feux.

Voir aussi : Lecteurs


Templates

Modèles

L'utilisation de Modèles n'est habituellement pas nécessaire car GetDataBack est supposé détecter les systèmes de fichiers automatiquement. Dans de rares circonstances - comme les disquettes ne contenant que quelques fichiers - la détection automatique peut échouer et l'utilisation d'un Modèle peut être conseillée.

Si vous connaissez exactement les paramètres du système de fichiers du lecteur à récupérer, vous pouvez proposer un Modèle pour prendre en charge la reconnaissance du système de fichiers.

Quelques Modèles (pour disquette 1.44 Mo et certains lecteurs Jaz et Zip) sont disponibles dans GetDataBack.

Pour créer de nouveaux Modèles, ouvrez le fichier GDB.INI. L'emplacement de GDB.INI est indiqué dans Aide->Infos de Version

Allez à la section Modèles du fichier GDB.INI et entrez les paramètres du système de fichiers dans l'ordre suivant (séparés par une virgule):

  • Nom du Modèle (libre choix)
  • Emplacement du système de fichiers (Numéro de Secteur du secteur de démarrage)
  • Système de fichiers (FAT12, 16 ou 32)
  • Nombre de secteurs réservés (cette valeur peut être obtenue à partir du secteur de démarrage)
  • Taille de cluster (cette valeur peut être obtenue à partir du secteur de démarrage)
  • Nombre total de secteurs (cette valeur peut être obtenue à partir du secteur de démarrage)
  • Longueur de la FAT (cette valeur peut être obtenue à partir du secteur de démarrage
  • 1er cluster du répertoire racine (cette valeur peut être obtenue à partir du secteur de démarrage) s'applique seulement à la FAT32, pour le FAT12 ou 16 entrez 0
  • Nombre d'entrées du répertoire racine (cette valeur peut être obtenue à partir du secteur de démarrage) s'applique seulement aux FAT12 et 16, pour la FAT32 entrez 0

Exemple:

1GB-Jaz w/Fat16 as physical drive=32,16,1,32,2088928,255,0,512

La création de Modèles nécessite une certaine expérience et un bon éditeur de disque comme Runtime's DiskExplorer.


Scanning the drive

Examiner le Lecteur

La fenêtre "Examiner le lecteur" affichera les informations concernant le processus de récupération.

Vous pouvez voir:

  • le processus en cours
  • la source de la récupération avec la plage de secteurs à examiner
  • le nombre de dossiers et fichiers déjà identifiés
  • le nombre de secteurs de démarrage détectés
  • le secteur en cours d'examen
  • la durée restante de l'examen et une barre de progression indiquant le pourcentage du lecteur déjà examiné.

Appuyez sur Echap ou cliquez sur Stop si vous souhaitez abandonner ce processus. Si vous abandonnez ce processus, il vous est proposé de revenir à l'Étape 1 ou de poursuivre la récupération par un examen partiel. Il n'est pas conseillé de poursuivre la récupération par une examen partiel car GetDataBack produit un meilleur résultat si la totalité du disque a été examinée.


Step 2

Étape 2 - Sélectionner un Système de Fichiers

A la fin de l'examen, les systèmes de fichiers que GetDataBack a détecté sont affichés à gauche de la fenêtre.

Vous verrez l'entrée recommandée (celle considérée par le logiciel comme étant le système de fichiers que vous souhaitez récupérer) en haut, et en-dessous, dans la plupart des cas, une liste des entrées de systèmes de fichiers les plus plausibles.

Essayez d'abord la toute première entrée (recommandée) et revenez à l'Étape 2 pour essayer d'autres entrées de système de fichiers seulement

  • si le système de fichiers ne correspond pas en taille et géométrie au partionnement d'origine de votre lecteur, ou
  • si vous ne voyez pas vos données apparaître à l'Étape 3 du logiciel, ou
  • si les fichiers ne veulent pas s'ouvrir correctement, ou
  • si vous devez récupérer plus d'une partition sur le même lecteur.

Ne soyez pas perdu si vous voyez toute une arborescence de systèmes de fichiers! GetDataBack mène un examen très minutieux de votre lecteur, et particulièrement lorsque vous avez examiné un lecteur volumineux avec plusieurs partitions, ou un lecteur qui a été re-partitionné; le logiciel peut alors détecter les débuts de plusieurs systèmes de fichiers.

Par défaut, le système de fichiers le plus précis est affiché en haut de la liste. L'ordre de tri de la liste est déterminé par la correspondance des données de chaque système de fichiers. Plus la position est élevée, plus la récupérabilitée des fichiers sera probable.

Une autre valeur à examiner est la qualité de certains systèmes de fichiers. Vous pouvez interpréter cette valeur comme étant le nombre de fichiers couverts par cette structure de système de fichiers.

  • un point vert indique habituellement un bon système de fichiers avec un potentiel de résultat de récupération de qualité élevée,
  • un système de fichiers avec un point jaune peut également produire des résultats très satisfaisants (surtout si aucun système de fichier n'apparaît avec un point vert),
  • un système de fichiers avec un point rouge n'est pas très prometteur, sauf si vous récupérez à partir d'un lecteur presque vierge.

Mais regardez-y de plus près! Quel système de fichiers de la liste correspond le mieux - en terme de taille de partition, de taille de cluster et de type de système de fichiers - au système de fichiers que vous souhaitez récupérer? Choisissez celui-ci.

Les détails du système de fichiers à droite de l'écran peuvent vous fournir d'autres informations concernant sa qualité.

Maintenant, sélectionnez le système de fichiers que vous souhaitez afficher dans l'arborescence de récupération et cliquez sur Suivant.

GetDataBack va alors créer l'arborescence des répertoires et fichiers récupérés. En fonction de la taille de votre lecteur, ça peut prendre du temps, mais le processus sera plus rapide que l'examen. N'arrêtez pas ce processus à moins d'y être obligé.

Cliquer sur Précédent à l'Étape 2 vous fera revenir à l'Étape 1. Vous êtes alors obligé de recommencer l'examen complet lorsque vous reprenez la récupération à partir de l'Étape 1 sauf si vous enregistrez l'examen au cours de l'Étape 2.

Voir aussi : Détails du Système de Fichiers, Liste de Vérifications


File System Details

Détails d'un Système de Fichiers

Les fenêtres de droite de l'Étape 2 vous fournissent des informations supplémentaires concernant la structure et la qualité des systèmes de fichiers détectés.

Les détails d'un système de fichiers sont organisés comme suit:

  • Nom: Le type de système de fichiers (FAT12, 16 or 32).
  • Cluster0: La position du cluster 0 dans le système de fichiers.
  • Taille de Cluster : Le nombre de secteurs dans un cluster. Les valeurs possibles sont:
    pour la FAT12: 1, 2, 4, 8,
    pour la FAT16: taille du volume/nombre d'entrées FAT possibles max. (65535) arrondi à la valeur suivante,
    pour la FAT32: 8 pour 512Mo-8191Mo, 16 pour 8192Mo-16383Mo, 32 pour 16384Mo-32767Mo, 64 pour >32768Mo.
  • Nombre total de secteurs: Le nombre total de secteurs dans le système de fichiers.
  • FAT1: Le cas échéant: le secteur de démarrage de la FAT1, (la qualité de la FAT, définie par la plage du système de fichiers sélectionnée que couvre la FAT),
  • FAT2: Le cas échéant: le secteur de démarrage de la FAT2, (la qualité de la FAT, définie par la plage du système de fichiers sélectionnée que couvre la FAT),
  • Longueur de la FAT: Le cas échéant: la longueur de la FAT en secteurs.
  • 1er cluster racine: Le cas échéant: le cluster de démarrage du répertoire racine (seulement disponible pour le système de fichiers FAT32).
  • Début du répertoire racine: Le cas échéant: le premier secteur du répertoire racine.
  • Entrées de racine #: Le nombre max. possible d'entrées du répertoire racine dans le système de fichiers (FAT12 et 16 seulement).
  • Nombre total de clusters: Le nombre total de clusters dans le système de fichiers.
  • Min de clusters utilisés: La plage de clusters min. où des données ont été détectées par l'examen.
  • Max de cluster utilisés: La plage de clusters max. où des données ont été détectées par l'examen.
  • Données correspondantes: Nombre de débuts de MFT correspondants aux débuts de fichiers. Ce nombre détermine l'ordre de la liste des systèmes de fichiers à l'Étape 2. Plus cette valeur est élevée, plus grand est le nombre de fichiers probablement récupérables.
  • Infos de débogage: B indique le secteur de démarrage détecté, B0 par exemple indique qu'au moins un secteur de démarrage a été détecté. D indique les répertoires détectés, le nombre suivant indique le nombre de structures de répertoires détectées.

Si une de ces valeurs vous semble totalement déraisonnable, cela indique que la qualité du système de fichiers concerné n'est pas très bonne et que vous devriez examiner les autres systèmes de fichiers de la liste (s'il en existe d'autres).

Qualité du Système de Fichiers: La petite illustration en forme de code barre en bas à droite peut vous en indiquer encore plus sur la qualité de chaque système de fichiers:

Sont affichés:

  • Débuts de répertoires: Les zones de clusters sur lesquels pointent les répertoires détectés.
  • Débuts de fichiers: Les zones de clusters identifiées comme débuts d'un fichier.
  • Débuts de la FAT1: Les zones de clusters sur lesquelles pointe un début de chaîne en FAT1 .
  • Débuts de la FAT2: Les zones de clusters sur lesquelles pointe un début de chaîne en FAT2.

Plus les marques de ces rangées sont en adéquation, "meilleur" est le système de fichiers. Le pourcentage de correspondance entre les débuts de fichiers et les débuts de MFT est indiqué sous ces rangées. Ne soyez pas déçu si ces valeurs n'approchent pas les 100%. Ça ne sera jamais le cas, et ceci du fait que GetDataBack mène un examen très minutieux du lecteur et détecte toujours quelques types de données orphelines qui pourraient être associées à un début de fichier ou de MFT.

Le pourcentage se définit de la façon suivante:

100 * Matching_File_Starts / Dir_Starts

où

Matching_File_Starts est le nombre de secteurs identifiés comme un début de fichier ET un secteur sur lequel pointe une entrée de répertoire,
Dir_Starts est le nombre de secteurs sur lesquels pointe une entrée de répertoire.

Il existe toujours des débuts de fichiers qui ne peuvent être identifiés, c'est la raison pour laquelle cette valeur ne pourra jamais atteindre 100%. Même une valeur faible comme 30% peut générer une récupération de données parfaite.

Voir aussi : Étape 2, Liste des Vérifications


Step 3

Étape 3 - Arborescence de Récupération

A gauche de l'écran, vous verrez l'arborescence de récupération présentant les répertoires et les dossiers récupérés, ainsi qu'un dossier "fichiers perdus" créé par le programme et contenant les fichiers sans information de répertoire.

Quand vous ouvrez un dossier du côté gauche, les fichiers de ce dossier s'affichent du côté droit - comme vous en avez l'habitude avec l'Explorateur Windows

Copier

Maintenant, marquez les fichiers ou répertoires que vous souhaitez copier. Cliquez sur le bouton Copier et une fenêtre s'affichera pour vous permettre de choisir la destination de copie des fichiers. Cette destination peut être un autre disque dur, un lecteur réseau local, un lecteur Zip ou Jaz, ou un lecteur de disquette. Ne copiez jamais les fichiers sur le lecteur ou la partition dont vous avez récupéré les données.

Vous pouvez copier l'arborescence complète des répertoires en sélectionnant l'entrée [FAT] à gauche. Si vous souhaitez copier les répertoires ou fichiers sélectionnés, vous pouvez les choisir dans la fenêtre de droite. Dans la fenêtre de droite, vous pouvez maintenir enfoncée la touche CTRL pour choisir plusieurs fichiers ou répertoires.

Entrées des Doublons: Si vous copiez des entrées de doublons de fichiers (précédemment activé dans les Options), il vous sera demandé de remplacer, d'ignorer ou de renommer ces fichiers. Si vous choisissez "ignorer" ou "remplacer", vous pouvez vous retrouver avec des versions de fichiers qui ne sont pas nécessairement celles que vous souhaitez récupérer. Choisissez plutôt "renommer" et faite ultérieurement le tri pour définir les versions les plus récentes. Vous pouvez aussi désactiver "fichiers doublons" dans le menu Options.

Bien que vous puissiez voir tous les fichiers récupérés, vous ne pouvez utilisez que la visionneuse, la fonction rechercher et la fonction information de fichier avec la version non enregistrée. Copier les fichiers sur un média d'enregistrement nécessite l'enregistrement du logiciel. L'enregistrement est très rapide et très simple. Vous n'êtes pas obligé de réitérer le processus de récupération, il vous suffit d'entrer la clé d'enregistrement lorsque vous êtes à l'Étape 3 et la copie des fichiers sera activée.

Qualité de la Récupération

Ne doutez pas des résultats de la récupération après la copie des fichiers. La plupart du temps, ce que vous voyez dans l'arborescence de récupération représente ce que vous obtiendrez après avoir copié les fichiers. Ce qui signifie que si vos fichiers sont visibles dans l'arborescence de récupération et qu'ils vous semblent corrects, ils le seront vraisemblablement après leur enregistrement.

Cependant, il est conseillé de vérifier plusieurs fichiers. Utilisez les fonctions suivantes de GetDataBack pour vérifier la qualité de la récupération:

  • Visionner le fichier (F3)
  • Ouvrir le fichier avec son application native
  • Investiguer les informations de fichier pour le fichier

Il se peut que vous ayez des dossiers de l'arborescence de récupération qui présentent cet aspect: (1229BD). Cela signifie que l'entrée du répertoire racine pour ce répertoire a été perdue et que le nom du répertoire n'a pas pu être retrouvé. Les sous-répertoires (au cas où) et les fichiers du répertoire devraient malgré tout apparaître dans l'ordre.

C'est surtout dans le dossier "fichiers perdus" que vous trouverez des fichier de type: #345HD33.doc Ce qui est du au fait que ces fichiers ont été récupérés sans aucune information de répertoire. Ainsi, le nom d'origine du fichier n'a pas pu être restauré. L'extension du fichier devrait cependant être correcte et vous fournir au moins certaines informations le concernant.

Si vous rencontrez des problèmes pour ouvrir les fichiers récupérés, consultez notre liste de vérifications .

Enregistrer une récupération

Pour enregistrer votre récupération pour une utilisation ultérieure, cliquez sur Fichier->Enregistrer la Récupération et choisissez un nom de fichier. N'enregistrez jamais ce fichier sur le lecteur ou la partition dont vous avez récupéré les données

Cette fonction n'enregistre pas les fichiers récupérés. Elle enregistre la structure de l'arborescence de récupération seule. Pour enregistrer les fichiers récupérés, voir la rubrique Copier .

Trier

Triez les fichiers affichés à droite par taille, nom, attributs, date de création et ainsi de suite, en cliquant sur l'en-tête de colonne correspondante.

Ouvrir

Ouvrez les fichiers en double-cliquant dessus, en cliquant sur le bouton Ouvrir ou en appuyant sur la touche Enter. Quand c'est possible, le fichier sera ouvert dans son application native. Sinon, vous pourrez choisir une application pour son affichage.

Cliquez sur le bouton Ouvrir avec ou appuyez sur Ctrl-Enter pour choisir l'application d'ouverture du fichier.

Voir

Utiliser la visionneuse pour avoir un premier aperçu des fichiers récupérés. Sélectionnez le fichier à examiner et cliquez sur le bouton Voir ou appuyez sur la touche F3. La visionneuse peut afficher le contenu de fichiers de différents types de fichiers (.txt, .doc, .bmp). Si le type de fichier n'est pas pris en charge, son contenu sera affiché au format hexadécimal.

Renommer

Si les noms de fichiers adéquats n'apparaissent pas (comme dans le cas, par exemple, d'une destruction des informations du répertoire racine), la propriété renommer vous permettra de renommer ces fichiers avant de les copier. Sélectionnez le fichier ou dossier à renommer et appuyez sur la touche F2. Bien entendu, vous pouvez aussi renommer les fichiers après les avoir copiés dans un emplacement sûr.

Chercher

GetDataBack inclut une fonction de recherche. Cliquez sur le bouton Chercher et entrez le terme de la recherche.

Apparence des noms de fichiers - Attributs

Apparence | Signification
filename.ext | fichier ou répertoire normal
filename.ext | lecture seule
filename.ext | système
filename.ext | caché
filename.ext | compressé
filename.ext | supprimé

Fichiers supprimés

Les fichiers supprimés récupérés apparaissent dans le répertoire où ils étaient situés à l'origine. Ils sont marqués sous la forme de nom de fichier barré. Si vous recherchez des fichiers à partir d'une corbeille vide, voyez dans le dossier RECYCLE. Notez que les fichiers de la corbeille n'ont plus leur nom de fichier d'origine. Cependant, ils présentent encore leur extension originale.

Informations du fichier

Si vous souhaitez vous plonger plus avant dans votre récupération, examinez les informations du fichier. Sélectionnez le fichier qui vous intéresse et cliquez sur le bouton info du fichier ou appuyez sur CTRL-I.

Runtime's DiskExplorer

Sélectionnez un fichier ou dossier et lancez Runtime's DiskExplorer. Ce programme vous fournira un accès de bas niveau à l'entrée du répertoire du fichier ou dossier sélectionné.

Un clic sur Précédent de l'Étape 3 vous fera reculer à l'Étape 2. Il vous faudra réitérer la création de l'arborescence de récupération si vous reprenez la récupération à partir de l'Étape 2, sauf si vous enregistrez la récupération à l'Étape 3.


File

Informations du Fichier

Affichez les informations détaillées d'un fichier ou dossier apparaissant dans l'arborescence de récupération en sélectionnant ce fichier ou dossier et en cliquant sur Récupération->Montrer les infos ou sur le bouton info.

Les informations fournies sont les suivantes:

  • Nom: Le nom d'affichage du fichier ou dossier.
  • Nom court: Le nom court du fichier ou du dossier.
  • Nom long: Le nom long du fichier ou du dossier.
  • Type: Le type (dossier ou fichier).
  • Attributs DOS: Les attributs (a = archive , r = lecture seule, h = caché, s = système, l = nom du volume, d = dossier, c = compressé).
  • Taille: Pour les fichiers = la taille du fichier en octets, pour les répertoires = le nombre de répertoires et fichiers dans ce répertoire, la taille du répertoire.
  • Premier cluster: Le premier cluster du fichier ou dossier.
  • Dernière modification: La date/heure de la dernière modification du fichier.
  • Création: La date/heure de la création du fichier ou dossier.
  • Dernier accès: La date du dernier accès au fichier.
  • Allocation par: Infos de débogage interne.
  • Détecté au cluster: Le cluster où l'entrée du fichier ou dossier a été détectée.
  • ID: Info de débogage interne.
  • Clusters utilisés: Le ou les clusters où les données du fichier ou dossier sont situées. Le chiffre entre parenthèses indique le nombre de clusters continus utilisés. Par exemple: 00E6(3), 00EA(6) signifie que les données ont été allouées en utilisant le cluster 00E6 et les deux clusters suivants, et le cluster 00EA et les cinq clusters suivants.
  • Secteurs utilisés: Le ou les secteurs où les données du fichier ou dossier sont situées. Le chiffre entre parenthèses indique le nombre de secteurs continus utilisés. Par exemple 1102(4), 1166(4) signifie que les données ont été allouées en utilisant le secteur 1102 et les trois secteurs suivants, et le secteur 1166 et les trois secteurs suivants.

Voir aussi : Runtime's DiskExplorer pour FAT


View File

Voir le fichier

La fonction Voir le Fichier peut afficher beaucoup de fichiers texte (.txt, .doc, .rtf, .wri), de fichiers graphiques (.htm, .jpg, .bmp, .ico, .wmf). Les formats binaires et inconnus seront affichés dans une visionneuse hexadécimale.

Sélectionnez le fichier à voir dans l'arborescence de récupération et cliquez sur Récupération->Voir du Menu Principal.

Voir aussi : Étape 3

Introduction Menu Glossaire


Save and Load Recovery

Enregistrer ou charger une récupération

Remarque: N'enregistrez jamais les fichiers sur le lecteur à récupérer!

Enregistrer et Charger un Examen

Lorsque l'examen du lecteur est terminé, vous pouvez enregistrer cet examen à l'Étape 2 pour une utilisation ultérieure. Cliquez simplement sur Fichier->Enregistrer la Récupération et choisissez une destination. Le fichier résultant aura pour extension .ST2.

Pour charger un examen, exécutez l'Étape 1 et sélectionnez le lecteur comme vous l'aviez fait lors de l'exécution précédente, mais cette fois cliquez sur le bouton "Charger" en bas à gauche de l'écran. En pratiquant ainsi, vous n'aurez pas à renouveler la totalité de l'examen. Ce qui peut s'avérer utile si vous n'êtes pas satisfait des résultats de la récupération et vous souhaitez choisir, par exemple, un autre système de fichiers à partir de la liste de l'Étape 2.

Après avoir cliqué sur Charger, sélectionnez la première option si vous souhaitez charger l'examen d'un lecteur et reconstruire la liste des systèmes de fichiers. Cliquez sur OK et sélectionnez le fichiers de résultats de l'Étape 1 ~GDBSAVE.ST1. Ce fichier est créé par le programme dans le répertoire temporaire par défaut et contient l'examen le plus récent. Vous ne pouvez pas enregistrer les résultats de l'Étape 1 directement à partir de GetDataBack, mais vous pouvez toujours renommer ce fichier afin de l'enregistrer pour utilisation ultérieure.

Sélectionnez la seconde option si vous souhaitez charger une liste de systèmes de fichiers et passer directement à l'Étape 2. Cliquez sur Ok et choisissez le bon fichier .ST2.

Enregistrer et Charger une Récupération

Lorsque l'arborescence de récupération est créée, vous pouvez enregistrer votre récupération pour une future utilisation à l'Étape 3. Cliquez simplement sur Fichier->Enregistrer la Récupération et choisissez une destination. Le fichier résultant aura pour extension .ST3.

Pour charger une récupération exécutez l'Étape 1 comme vous l'aviez fait lors de l'exécution précédente, cliquez sur le bouton "Charger" de l'Étape 1, choisissez la troisième option, cliquez sur Ok et sélectionnez le fichier .ST3.


Options

Le menu Options présente deux onglets, Récupération et Environnement.

Dans l'onglet Environnement vous pouvez définir

  • le répertoire d'enregistrement, par défaut qui est le répertoire dans lequel seront copiés les fichiers récupérés,
  • le répertoire temporaire par défaut qui est le répertoire dans lequel les fichiers nécessaires à la récupération, le fichier d'examen et le fichier journal seront enregistrés,
  • un fichier nommé fichier journal, si vous souhaitez que le logiciel en crée un,
  • l'emplacement de Runtime's DiskExplorer, si vous l'avez téléchargé et que vous souhaitez l'appeler au cours du processus de récupération.

Ne spécifiez jamais un répertoire situé sur le lecteur que vous souhaitez récupérer!

Dans l'onglet Récupération vous verrez les options qui ont été pré-réglées (recommandées) par la sélection que vous avez effectuée en fonction du scénario de récupération de vos données de l'écran d'introduction. Vous pouvez aussi définir/modifier manuellement les options suivantes.

Si vous activez "Autoriser les doublons" , le programme acceptera plusieurs fichiers portant le même nom de fichier dans un répertoire. Ces noms de fichiers peuvent appartenir à des versions différentes d'un même fichier. Si cette option n'est pas activée, GetDataBack utilisera l'entrée la plus récente. Pour être effective, cette option doit être définie au cours ou avant l'Étape 2.

Activez "Récupérer les fichiers supprimés" si vous souhaitez inclure les fichiers et répertoires supprimés à la récupération. Remarque : Si vous activez cette option, mais que vous désactivez l'option "Autoriser les doublons", GetDataBack choisira l'entrée la plus récente - peu importe si elle a été supprimée ou non - s'il rencontre des doublons. Pour être effective, cette option doit être définie au cours ou avant l'Étape 2.

Activez "Récupérer les fichiers perdus" si vous pensez que vous avez des fichiers sans information de répertoire sur votre disque. N'activez pas cette option par défaut, surtout si vous récupérez un lecteur volumineux ou repartitionné car vous pourriez obtenir une grande quantité de détritus de fichiers dont vous n'avez probablement pas besoin. Pour être effective, cette option doit être définie au cours ou avant l'Étape 1.

L'utilisation de la fonction "Recherche poussée" ralentira le processus de récupération, et il est préférable de ne l'activer que si le système de fichiers souhaité n'apparaît pas à l'Étape 2 - surtout pour un média avec très peu de données ou d'informations de répertoires - comme une disquette. Activer cette fonction produira davantage d'entrées à l'Étape 2.

Pour garantir une qualité de résultats de récupération élevée, GetDataBack a été conçu par afficher des informations de type répertoires, mais pas la plupart du temps. Ainsi, activez "Autoriser les mauvais répertoires" si vous avez le sentiment que des fichiers ou répertoires sont manquants dans l'arborescence de récupération ou si vous souhaitez que le programme interprète même les informations de répertoires moins prometteurs. Pour être effective, cette option doit être réglée pendant ou avant l'Étape 1.

Si vous activez "Ignorer la Fat" , GetDataBack allouera les fichiers sans utiliser une éventuelle FAT détectée. Ce qui peut être utile si la FAT détectée ne reflète pas le système que vous tentez de récupérer. Il est préférable de n'utiliser aucune FAT que d'utiliser une FAT contenant des erreurs d'informations. Activez cette option seulement si vous n'êtes pas satisfait des résultats de l'arborescence de récupération (Étape 3). Pour être effective, cette option doit être réglée pendant ou avant l'Étape 1.

De plus, vous pouvez préciser la façon dont le logiciel manipulera les secteurs défectueux - s'il en rencontre au cours de l'examen. Les secteurs défectueux sont des zones de votre lecteur qui sont physiquement endommagées et qui ne peuvent plus être lues ou interprétées par moyen logiciel. Les secteurs sont lus par blocs de 16 secteurs. Si cette opération échoue, cela peut être du à la présence d'un seul secteur défectueux ou de plusieurs secteurs défectueux.

Vous disposez des choix suivants:
Ignorer le bloc - les 16 secteurs sont considérés comme défectueux. Aucune tentative n'est effectuée pour récupérer les secteurs éventuellement sains.
Ré-essayer chaque secteur - le programme essaie de lire à nouveau les secteurs un par un. Ce qui donne une chance de récupérer les secteurs sains possibles au voisinage d'un secteur défectueux. Cependant, cela peut prendre beaucoup de temps, surtout s'il n'existe aucun secteur sain.

Le champ "Fichiers exclus" vous permet de définir les fichiers à exclure de la récupération. Normalement, vous devriez laisser ce champ vierge. Seules des circonstances particulières, comme des problèmes de mémoire, justifient l'exclusion d'un certain type de fichiers. Si, par exemple, vous souhaitez exclure les fichiers TMP et BAK, vous devrez spécifier:

*.tmp;*.bak

Réglez cette option pendant ou avant l'Étape 2.

Cliquer sur Rétablir les valeurs par défaut réinitialisera les réglages recommandés pour le scénario que vous avez spécifié dans l'écran d'Introduction.


Search

Rechercher des fichiers

GetDataBack propose une fonction de recherche très pratique. Pour chercher des fichiers ou dossiers, cliquez sur Outils->Chercher des fichiers.

Le champ Masque de fichier nécessite un masque de fichier du type *.* ou *.doc.

Trois catégories de filtres différents sont disponibles:

  • Date: Spécifie une date de début et de fin et les seuls fichiers ou dossiers présentant une date de modification dans cette plage apparaîtront.
  • Taille: Spécifie une plage de taille et seuls les fichiers correspondants apparaîtront.
  • Type: Spécifie si vous souhaitez rechercher les fichiers supprimés, non supprimés ou les deux. Remarque: vous devez avoir inclus les fichiers supprimés dans les Options avant la création de l'arborescence de récupération.

Le champ Profondeur de recherche détermine à quel niveau GetDataBack effectuera sa recherche à l'intérieur de la structure des répertoires. Une valeur à 8 signifie que la recherche incluera jusqu'à 8 sous-répertoires.

Cliquer sur Démarrer lancera la recherche dans l'arborescence de récupération en fonction de vos réglages.

Vous pouvez Stopper la recherche à tout moment.

A la fin de la recherche, vous pouvez examiner les fichiers et dossiers trouvés dans la fenêtre inférieure. Vous pouvez faire pratiquement les mêmes choses que dans l'arborescence de récupération: voir, ouvrir, obtenir des infos, trier, copier etc.

Le bouton Sync vous mène à l'emplacement du fichier dans l'arborescence de récupération.

Le bouton Nouveau efface les résultats en cours.


Bad sector

Manipulation des Secteurs Défectueux

Une erreur s'est produite au cours de l'opération de lecture d'un bloc de secteurs défectueux.

Les secteurs sont lus par blocs de 16 secteurs. Si cette opération échoue, cela peut être du à un seul secteur défectueux ou à plusieurs secteurs défectueux. En fonction du réglage des options le programme aura le choix entre ces deux comportement:

Ignorer le bloc de secteurs

Les 16 secteurs sont considérés comme défectueux. Aucun essai de récupération de secteurs sains possibles ne sera tentée.

Re-tenter d'accéder aux secteurs simples

Le programme tente à nouveau de lire les secteurs un par un. Ce qui peut permettre de récupérer les secteurs sains possibles dans le voisinage d'un secteur défectueux. Cependant, la durée du processus peut être longue, surtout s'il n'existe aucun secteur sain.

Voir aussi : Options


Runtime

Runtime's DiskExplorer

Runtime's DiskExplorer pour FAT est un puissant éditeur de disque, qui vous permet de

  • parcourir votre lecteur en utilisant un système de flèches de direction avant-arrière, pour vous permettre d'atteindre directement la table de partition, le secteur de démarrage, la FAT ou les entrées de la FAT, en atteignant un certain secteur, etc..,
  • basculer entre plusieurs affichages, comme en hexadécimal, texte, répertoire, FAT, table de partition et secteur de démarrage,
  • cherche du texte, des secteurs de démarrage, des tables de partition et des sous-répertiores dans votre lecteur,
  • investiguer le secteur de démarrage du volume en examinant les informations du volume,
  • éditer votre lecteur en utilisant les modes d'écriture/lecture directs (non recommandé) ou le mode d'écriture virtuelle,
  • afficher et même récupérer des fichiers supprimés,
  • créer un volume virtuel lorsque le secteur de démarrage est perdu ou corrompu,
  • mener votre propre récupération de données en tirant avantage de toutes ces fonctions.

Pour appeler Runtime's DiskExplorer pour FAT directement à partir de GetDataBack, téléchargez le programme à partir de notre site web http://www.runtime.org. Installez-le; mais ne l'installez jamais sur le lecteur que vous souhaitez récupérer. Cliquez ensuite sur Outils->Options et indiquez l'emplacement de DiskExplorer.

Appeler DiskExplorer à l'Étape 1 affichera le secteur de démarrage de votre disque maître. Dès que vous sélectionnez un lecteur ou une partition à l'Étape 1 et que vous exécutez DiskExplorer, il se positionne au début du lecteur sélectionné. A l'Étape 2 , DiskExplorer affichera le début de la FAT et à l'Étape 3 l'entrée FAT du fichier ou dossier sélectionné.

L'Enregistrement de GetDataBack ne servira pas de clé d'enregistrement pour Runtime's DiskExplorer, ce produit doit être acheté séparément.

Pour en savoir plus sur Runtime's DiskExplorer, consultez l'aide du programme ou notre site web.


Lost files

Fichiers Perdus

GetDataBack peut récupérer des fichiers même si leur information MFT est perdue. Ce qui est possible à condition que le programme puisse reconnaître les fichiers perdus par leur signature de fichier et leur extension de fichier.

GetDataBack peut déjà reconnaître quelques types de fichiers comme les fichiers DOC, BMP, RIFF, ZIP et les fichiers Help.

Si vous devez récupérer un fichier perdu dont le format de fichier est différent, définissez ce format de fichier dans le fichier GDB.INI. L'emplacement du fichier GDB.INI est indiqué dans Aide->Infos de Version.

Allez à la section LostFiles du fichier GDB.INI et entrez les paramètres de fichier dans l'ordre suivant (séparés par une virgule):

  • Nom du fichier (choix libre)
  • Extension du fichier
  • Longueur de la signature du fichier (entre 2 et 8 octets de longueur)
  • Signature du fichier (en hexadécimal, située au début du fichier)
  • Type (réservé aux futures versions, entrez 1)
  • Taille du fichier (si cette information n'est pas disponible dans l'en-tête du fichier, indiquez une longueur suffisante pour couvrir la taille des fichiers à récupérer)

Exemple: fichiers Help

Les fichiers Help débutent par la signature $3F,$5F,$03,$00.
Les fichiers Help perdus détectés auront pour extension HLP dans l'arborescence de récupération
La taille sera déterminée par le mot double détecté à la position 12 du premier secteur [12,4]

Help-File= HLP,4, $3F,$5F,$03,$00, 1, [12,4]

Pour en savoir plus, consultez la rubrique GDB.INI.

La définition des fichiers nécessite une certaine expérience, quelques recherches et un bon éditeur de disque comme Runtime's DiskExplorer.


Log file

Fichier Journal

Le fichier journal vous permet de revoir ce qui s'est passé avec votre lecteur au cours du processus de récupération. Chaque étape suivie par le programme est enregistrée dans le fichier journal: l'examen de recherche des lecteurs disponibles, la sélection de la source, la sélection du système de fichiers et de la plage de secteurs, l'examen du lecteur, la sélection du système de fichiers détecté et la création de l'arborescence de récupération.

Le fichier établit des informations concernant la géométrie du lecteur et/ou de la partition sélectionnée, la qualité des systèmes de fichiers détectés par le programme, le nombre de secteurs et les 8 premiers octets des fichiers trouvés, le nom des fichiers associés aux fichiers détectés, l'emplacement du début des répertoires, et le processus de copie.

Pour une récupération volumineuse, le fichier journal peut occuper beaucoup d'espace disque. Si vous décidez de conserver le fichier journal d'une récupération, choisissez un nom de fichier dans les Options au niveau de l'Écran d'Introduction.

Vous pouvez créer une version abrégée de ce fichier journal à l'aide de la fonction instantané.

Voir aussi : Instantané, Assistance Technique


Troubleshooting

Dépannage

Voici les message d'avertissement et d'erreur les plus courants que vous pouvez rencontrer:

Accès refusé

COMCTRL32 obsolète

Impossible de verrouiller le lecteur

DRV16 introuvable

Erreur E/S

Manipulation d'un secteur défectueux

Si vous recevez une erreur d'exécution, envoyez un instantané système à support@runtime.org.

Voir aussi : F.A.Q., Assistance Technique, Effectuer une Récupération de Données, Liste de Vérifications


Access Denied

Erreur: Accès refusé

Ce message s'affiche si vous

  • tentez d'ouvrir un fichier déjà en cours d'utilisation exclusive par un autre processus
  • ou d'ouvrir un fichier en mode lecture/écriture protégé contre l'écriture.

Voir aussi : Fichiers image


Outdated COMCTRL32

COMCTRL32.DLL Obsolète

Votre version de Windows utilise une version obsolète de 'COMCTL32.DLL'. Ce composant est une extension du système d'exploitation Windows et est normalement fourni avec MS Internet Explorer.

Vous aurez probablement des problèmes avec les contrôles visuels de ce programme (vous ne verrez pas les boutons). Mais vous pourrez tout de même exécuter ce logiciel.

Il est conseillé de télécharger la dernière version à l'adresse http://www.microsoft.com/msdownload/ieplatform/ie/comctrlx86.asp ou d'installer une version récente de MS Internet Explorer.


Drive Locking Failed

Attention: Impossible de Verrouiller le Lecteur

Verrouiller un lecteur est une opération de bas niveau pour empêcher plusieurs processus d'accéder à un lecteur physique ou logique en même temps. Vous devriez vérifier qu'aucun autre processus n'accède au lecteur. Si vous Ignorez cette alerte, votre processus continuera probablement, mais pourra entraîner des dommages aux données du lecteur. Ainsi, ignorer n'est pas recommandé.

Voir aussi : Lecteurs


DRV16.DLL not found

Attention: DRV16.DLL introuvable

Ce message est affiché au démarrage si le programme fonctionne sous le système d'exploitation Windows95/98/ME et ne trouve pas le fichier DRV16.DLL.

Ce composant fournit l'accès au lecteur physique et est nécessaire à ce programme. Vous devriez quitter ce programme et réinstaller ce logiciel.

Voir aussi : Lecteurs Physiques


Read Error

Erreur: Erreur E/S

Ce message s'affiche si le programme rencontre une erreur de lecture à partir d'un lecteur. Cette erreur n'est pas récupérable, mais vous pouvez l'ignorer.

Vous disposez des choix suivants:

Cliquer sur Oui: l'erreur est ignorée et l'opération se poursuit.

Cliquez sur Oui pour tout: l'erreur est ignorée et l'opération se poursuit. Les futurs messages d'erreur seront supprimés et également ignorés; vous ne serez plus interrogé par ces messages. Cette condition est annulée à la prochaine demande régulière pour une entrée utilisateur.

La stratégie utilisée lors de la manipulation des secteurs défectueux est définie dans les Options.

Voir aussi : Manipulation des Secteurs Défectueux, Options


F.A.Q.

GetDataBack pour Windows 95/98/ME/NT/2000/XP pour NTFS & Fat

Q. La fragmentation du disque peut-elle affecter le résultat de la récupération?

Q. Puis-je investiguer la qualité de mes fichiers récupérés avant d'acheter le logiciel?

Q. Puis-je utiliser GetDataBack pour récupérer des données à partir d'un CD, CDR ou DVD?

Q. Puis-je utiliser GetDataBack pour récupérer des données si mon disque dur n'est pas reconnu par le BIOS de mon ordinateur?

Q. Au cours d'un examen avec GetDataBack, j'obtiens une erreur disque, qu'est-ce que cela signifie?

Q. Comment puis-je optimiser la qualité de ma récupération?

Q. Je ne retrouve pas certains fichiers dans la récupération, comment puis-je les obtenir?

Q. Je ne peux pas ouvrir les fichiers récupérés. Pourquoi?

Q. Je ne connais pas le système de fichiers que mon lecteur utilisait avant la panne. Que puis-je faire?

Q. Est-il prudent d'exécuter GetDataBack sur mon disque dur en panne?

Q. Comment puis-je récupérer les données du lecteur d'un ordinateur Portable ou d'un Notebook?.

Q. GetDataBack peut-il fonctionner sur un lecteur supérieur à 8,2 giga-octets?

Q. Comment puis-je récupérer les fichiers que j'ai supprimés avec l'Explorateur Windows?

Q. La fragmentation du disque peut-elle affecter le résultat de la récupération?

R. GetDataBack examine votre disque dur pour trouver une des FAT (Table d'Allocation des Fichiers). Si aucune FAT n'est trouvée, GetDataBack tentera la récupération sans cette information. Dans ce cas, la possibilité de réunir les parties fragmentées à partir de toutes les régions du lecteur sont réduites.

Haut

Q. Puis-je investiguer la qualité de mes fichiers récupérés avant d'acheter le logiciel?

R. Oui, GetDataBack contient une visionneuse intégrée qui vous permet d'investiguer la qualité de vos fichiers et d'ouvrir ceux-ci avec leur application d'origine avant d'enregistrer le programme.

Haut

Q. Puis-je utiliser GetDataBack pour récupérer des données à partir d'un CD, CDR ou DVD?

R. Non, GetDataBack récupère les données à partir de disques durs, de disquettes, de lecteurs Jaz et Zip, de lecteurs USB et Firewire, des cartes Smart Media et Compact Flash, mais il n'est pas conçu pour restaurer les données à partir de CD, CDR et DVD.

Haut

Q. Puis-je utiliser GetDataBack pour récupérer des données si mon disque dur n'est pas reconnu par le BIOS de mon ordinateur?

R. Non, si le BIOS ne reconnaît pas le disque dur, notre logiciel ne pourra pas effectuer une récupération. Vérifiez le branchement, le réglage du cavalier et le réglage des contrôleurs. Si le disque dur n'est toujours pas reconnu, essayez de le brancher sur un autre ordinateur et voyez s'il est enfin reconnu.

Haut

Q. Au cours d'un examen avec GetDataBack, j'obtiens une erreur disque, qu'est-ce que cela signifie?

R. GetDataBack représente une solution aux problèmes logiciels, il ne pourra pas vous aider pour une panne matérielle. Une erreur disque est le signe d'un problème matériel. Nous vous conseillons de cesser de travailler sur un lecteur corrompu tant que vous n'avez pas créé une image disque (chaque tentative pour accéder aux données peut aggraver la corruption !). Après avoir créé une image avec succès, vous pouvez utiliser le fichier image comme source pour GetDataBack.

Haut

Q. Comment puis-je optimiser la qualité de ma récupération?

R. Qu'avez-vous choisi à l'Etape 1? Nous vous conseillons de choisir le lecteur physique pour votre récupération.
A l'Etape 2 vérifiez que vous avez bien choisi le système de fichiers qui contient les informations les plus adéquates pour traiter la récupération. Vous pouvez comparer la qualité du système de fichiers en examinant les détails dans la fenêtre de droite. Un autre indicateur de bonne qualité d'un système de fichiers est la valeur du pourcentage à gauche du graphique inférieur. Avant d'enregistrer le programme, testez suffisamment de fichiers pour être certain d'être satisfait des résultats de la récupération.
Essayez d'activer "Autoriser les doublons" dans les options. Ce qui peut faire apparaître différentes versions de certains fichiers.

Voir aussi notre Liste de Vérifications détaillée.

Haut

Q. Je ne retrouve pas certains fichiers dans la récupération, comment puis-je les obtenir?

R. Vérifiez d'abord la recommandation dans Comment puis-je optimiser la qualité de la récupération?.

Essayez l'option "Autoriser les doublons". Ce qui peut faire apparaître différentes versions de certains fichiers.

Essayez la fonction "Récupérer les fichiers perdus".

Voir aussi notre Liste de Vérifications détaillée.

Haut

Q. Je ne peux pas ouvrir les fichiers récupérés. Pourquoi?

R. Il existe trois causes possibles à l'impossibilité d'ouvrir les fichiers récupérés:

  1. GetDataBack examine votre disque dur pour trouver l'une des FAT (Table d'Allocation des Fichiers). Si aucune FAT n'est détectée, GetDataBack tentera la récupération sans ces informations. Si les fichiers sont fragmentés, les chances de réunir ces portions devient faible. Cependant, seule une partie du fichier récupéré est habituellement affectée par ce probème. Un autre problème relatif à la FAT peut se produire si GetDataBack détecte une FAT qui n'est pas la FAT du système de fichiers. Dans ce cas, GetDataBack utilise des informations d'allocation erronées.

  2. Vos fichiers ont été remplacés par d'autres données. Dans ce cas, il n'y a aucun moyen de récupérer les données.

  3. Vous avez choisi une mauvaise entrée de système de fichiers à l'Etape 2 de la récupération. Vérifiez que vous avez choisi le système de fichiers qui contient les informations les plus adéquates pour effectuer la récupération. Vous pouvez comparer la qualité du système de fichiers en examinant les détails dans la fenêtre adéquate. Un autre indicateur de bonne qualité d'un système de fichiers est la valeur du pourcentage à gauche du graphique inférieur.

Recommandations:

En ce qui concerne le point 1, vous devriez vérifier les débuts des fichiers défectueux avec une visionneuse hexadécimale (vous pouvez utiliser la visionneuse intégrée à GetDataBack). Comparez ces débuts de fichiers aux débuts de certains fichiers du même type parmi les fichiers récupérables. Les débuts de fichiers devarient être "similaires". Si c'est la cas, vous avez un echance qu'ils soient mis bout à bout manuellement à l'aide d'un éditeur de disque comme Runtime's DiskExplorer. L'option infos de fichier de GetDataBack vous indique les clusters qu'il utilise pour la récupération de ce fichier particulier.

Si GetDataBack utilise une FAT incorrecte, activez l'option "Ignorer la Fat" dans le boîte de dialogue Options et refaites un examen.

Vérifiez le point 3. Re exécutez GetDataBack et traitez l'Etape 2 . Essayez d'autres entrées qui s'approchent en taille et position da la partition à récupérer. Nous serions heureux de vous aider à déterminer l'entrée à choisir (voir: Suppor Techniquet).

Voir aussi notre Liste de Vérifications détaillée.

Haut

Q. Je ne connais pas le système de fichiers que mon lecteur utilisait avant la panne. Que puis-je faire?

R. Si vous ne connaissez pas le système de fichiers que votre lecteur utilisait avant la panne, vous pouvez utiliser nos versions de démonstration de GetDataBack pour explorer votre lecteur. Tout d'abord, il vous faut télécharger les démos sur un ordinateur Windows fonctionnel et installer le logiciel, puis brancher le lecteur défectueux comme disque dur secondaire et vérifier que le BIOS reconnaît le lecteur. Vous pourrez alors utiliser les démos Fat et NTFS pour explorer votre lecteur. Vous ne pourrez rien détruire tant que le lecteur n'est pas endommagé physiquement, car GetDataBack est un logiciel en lecture seule.
Après avoir suivi les instructions, vous obtiendrez une arborescence de récupération contenant vos fichiers et dossier, avec la bonne version du logiciel. Vous pourrez alors évaluer la qualité de la récupération en cliquant sur 'récupération->ouvrir' du menu principal. Si vos fichiers sembles corrects, vous pourrez les copier sur un autre lecteur, en lieu sûr (version complète seulement).
Une petite astuce si vous êtes novice en ce qui concerne les différentes versions de Windows:
Win 3.11, Win 95, Win 98, Win ME utilisent le système de fichiers FAT.
Win NT, Win 2000, XP acceptent deux systèmes de fichiers : NTFS ou FAT.

Haut

Q. Est-il prudent d'exécuter GetDataBack sur mon disque dur en panne?

R. Oui, tant que votre lecteur ne présente pas de problème physique, vous pouvez utiliser GetDataBack en toute sécurité car le programme ne modifiera rien sur le lecteur défectueux puisqu'il s'agit d'un logiciel en lecture seule. Installez le logiciel sur un ordinateur Windows fonctionnel et branchez le disque dur contenant les fichiers perdus comme disque dur secondaire de cet ordinateur. Vérifiez que ce disque dur secondaire est reconnu par le BIOS. Exécutez alors GetDataBack et, à l'Etape 1 sélectionnez votre lecteur défectueux (habituellement le HD129). Cliquez sur 'Suivant'. Le programme va alors examiner votre lecteur. En fonction de la taille de celui-ci, le processus prendra un certain temps. Dès que l'examen est terminé, vous verrez une liste des systèmes de fichiers possibles détectés par le programme. Normalement, vous devriez sélectionner le premier (recommandé) système de fichiers de la liste. Cliquez sur 'Suivant'. Le programme va alors créer l'arborescence des fichiers récupérés. Peu de temps après vous verrez une arborescence des fichiers et dossiers récupérés. Ainsi, vous pourrez voir si GetDataBack a détecté les fichiers. Si c'est le cas, vous pouvez évaluer la qualité des fichiers récupérés. Il vous suffit de choisir un fichier qui vous intéresse et de cliquer sur ' Récupération->Voir' ou ' Récupération->Ouvrir' dans le menu principal. Si les fichiers semblent corrects, il le seront vraisemblablement après les avoir copiés en lieu sûr sur un autre lecteur.

Haut

Q. Comment puis-je récupérer les données du lecteur d'un ordinateur Portable ou d'un Notebook?.

R. Une option consiste à débrancher le lecteur et à le brancher sur la nappe IDE d'un ordinateur de Bureau via un adaptateur Portable-IDE et d'exécuter GetDataBack à partir de l'ordinateur de Bureau. L'autre consiste à créer un disque amorçable WinPE/BartPE et d'exécuter le logiciel de récupération à partir du CD-ROM amorçable. Vous trouverez les instructions pour créer un tel disque d'amorçage et lui intégrer le module requis pour GetDataBack sur notre site web http://www.runtime.org/peb.htm. Pensez tout de même que vous aurez besoin d'un espace disque suffisant pour y copier les fichiers récupérés.

Haut

Q. GetDataBack peut-il fonctionner sur un lecteur supérieur à 8,2 giga-octets?

R. Oui, GetDataBack fonctionne sur n'importe quelle taille de disque dur, mais les lecteurs volumineux prendront du temps à être examinés et récupérés.

Haut

Q. Comment puis-je récupérer les fichiers que j'ai supprimés avec l'Explorateur Windows?

R. Tout d'abord, activez la fonction "Récupérer les fichiers supprimés" dans la boîte de dialogue des Options. Exécutez ensuite GetDataBack comme à l'habitude jusqu'à la création de l'Arborescence de Récupération. Les fichiers "Supprimés définitivement" sont détectés dans leur dossier d'origine (s'il est toujours disponible). Vous trouverez les fichiers de la "corbeille vide" dans le répertoire RECYCLE. Notez que ces fichiers ont perdu leur nom d'origine, mais que leur extension d'origine est toujours présente.
Vous pouvez aussi utiliser avantageusement la fonction de Recherche.

Haut

Voir aussi : Support Technique, Effectuer une Récupération de Données, Liste de Vérifications


Support

Assistance Technique

Si vous avez besoin d'aide, vous pouvez nous contacter de la façon suivante:

USA

Téléphone | 1-808-329-2202
Fax | 1-818-475-1741
Email | support@runtime.org
Site web | http://www.runtime.org

Europe (Allemagne)

Téléphone | +49-30-280 8008
Fax | +49-30-690 88 444
Email | support_europe@runtime.org
Site web | http://www.runtime.org

Si vous avez des questions concernant l'utilisation de ce logiciel, appelez-nous ou envoyez-nous un email.

C'est une bonne idée d'inclure un instantané de la récupération à votre demande d'assistance.

Voir aussi : F.A.Q., Effectuer une Récupération de Données, Liste de Vérifications, Instantané, Fichier journal


Check List

Liste de Vérifications

Utilisez cette liste de vérification détaillée seulement si vous ne pouvez pas ouvrir vos fichiers récupérés avant ou après leur copie (fichiers corrompus). Elle est conçue pour vérifier et discuter des différents choix que vous avez effectués au cours du processus de récupération.

Vous êtes supposé avoir pris connaissance de la rubrique Effectuer une Récupération de Données et en avoir suivi les instructions. Vous êtes également supposé avoir lu les descriptions et explications des rubriques concernant l'Écran d'Introduction, l'Étape 1, l'Étape 2 et l'Étape 3.

Si les résultats de la récupération ne sont pas satisfaisants, vérifiez les points suivants:

  1. Toujours utiliser un "Lecteur physique" à l'Étape 1. Utilisez les "Lecteurs Logiques" seulement si, par exemple, votre lecteur n'apparaît pas comme un "lecteur physique".

  2. Vérifiez que la capacité du "lecteur physique secondaire" (ou du lecteur à récupérer) affiché à l'Étape 1 corresponde à la capacité réelle de ce lecteur. Si ça n'est pas le cas, il y a sans doute un problème avec les réglages de votre BIOS.

  3. Toute première entrée ou sous-entrée de partition :

    1. Si le lecteur présentait une partition utilisant tout le lecteur, sélectionnez la toute première entrée ("lecteur physique secondaire") à l'Étape 1. Ne modifiez pas le réglage de la plage dans l'onglet Examen Partiel à l'Étape 1.

    2. Si le lecteur présentait plusieurs partitions, choisissez une sous-entrée de la partition correspondante à l'Étape 1 SI ET SEULEMENT SI les entrées de partition sont affichées ET qu'elles reflètent le partitionnement d'origine à récupérer.

      Si vous aviez placé une nouvelle structure de partition sur le lecteur, ces information sont inutiles et vous devriez choisir la toute première entrée.

      C'est seulement si vous avez plus d'une partition (comme dans l'exemple de l'Étape 1), et que vous SAVEZ que c'est la première partition de 10Go qui doit être récupérée, que cela a un sens de modifier les réglages de la plages dans Examen Partiel de l'Étape 1 (dans cet exemple, réglez la plage sur 0-22000000). Mais souvenez-vous que vous pouvez toujours utiliser la toute première entrée, et que le processus peut alors prendre un certain temps.

      REMARQUE: LA PLAGE SELECTIONNEE DOIT ETRE UNE SURESTIMATION DE LA PARTITION A RECUPERER ! (c'est la raison pour laquelle nous choisissons 22 millions au lieu de 20 millions dans cet exemple. Ce qui nous garantit que la partition de 10Go sera complètement contenue dans la plage des 11Go).

  4. A l'Étape 2 vous devez choisir l'entrée qui correspond LE MIEUX à la partition que vous souhaitez récupérer. Ces entrées ne sont pas nécessairement des systèmes de fichiers réels, elles décrivent plutôt des systèmes de fichiers POSSIBLES. Les entrées du début ont davantage de chances d'être correctes par rapport aux entrées des lignes inférieures. MAIS, CETTE ESTIMATION A ETE FAITE A PARTIR DE GETDATABACK ET N'EST PAS TOUJOURS EXACTE. Si GDB ne peut pas définir l'entrée correcte de façon sûre, vous n'obtiendrez pas d'Étape 2 (tout du moins dans les cas où une partition est présente sur le lecteur !).

    Vous DEVEZ faire le bon choix ici, sinon l'arborescence de récupération n'affichera que des informations inutilisables. Une entrée est soit bonne, soit mauvaise pour une certaine partition à récupérer.

    Habituellement, vous utiliserez la première entrée (recommandé). Nous avons décrit une procédure de sélection ci-dessous pour les cas où la première entrée serait erronée (voir le cas 6).

  5. A l'Étape 3 vérifiez bien que les fichiers sont corrects. Utilisez la visionneuse interne (F3) ou ouvrez les fichiers dans leur application associée (double-clic). Le premier objectif de cette vérification est de contrôler la sélection à l'Étape 2. Utilisez des fichiers faciles à contrôler, comme par exemple les fichiers texte, JPG, EXE, ou DLL. Les fichiers EXE et DLL sont des fichiers faciles à reconnaître par la signature "MZ" au début de leur nom. IMPORTANT POUR NTFS: les fichiers à vérifier DOIVENT être supérieurs à 2Ko.

  6. Interprétation de la vérification des fichiers: Si plusieurs vérifications sont positives, la sélection à l'Étape 2 était correcte. Si aucune vérification n'est positive, la sélection à l'Étape 2 était mauvaise et vous devez revenir à cette Étape pour choisir une autre entrée. Si aucune entrée de l'Étape 2 ne convient au test, revenez à l'Étape 1 et activez "Recherche Excessive" dans les Options. Ce qui ajoutera à l'Étape 2 d'autres entrées à tester.

  7. Comment évaluer les entrées à l'Étape 2?

    Une liste d'entrées a pour format :

    <FILESYSTEM> at sector XXX, cluster size YYY (ZZZZ MB)

    Exemple:

    FAT32 au secteur 20000, taille de cluster 64 (20000Mo)

    Vérifiez ceci:

  8. Vérifiez si le type de système de fichiers (FAT32 dans l'exemple ci-dessus) est correct. Le système de fichiers FAT apparaît sous FAT12, FAT16 ou FAT32. Il doit apparaître dans la bonne catégorie. Règle: les Partitions > à 2Go sont toujours en FAT32. Les Partitions > à 12Mo ne sont jamais en FAT12. Vous forcer la recherche du type de système de fichiers à l'Étape 1. LE TYPE DE SYSTEME DE FICHIERS DOIT ETRE CORRECT.

  9. Vérifiez l'emplacement (au secteur 20000 dans l'exemple ci-dessus). Dans GDB pour FAT ce chiffre ne correspond pas à l'emplacement précis. Il s'agit de l'emplacement où le cluster 0 débute. Vous pouvez considérer comme une approximation le début du système de fichiers FAT. 10 Mo est un nombre proche de 0 si vous considérez la taille totale du lecteur (40000 Mo) ou de la partition (20000 Mo). Si l'emplacement ne correspond pas à l'emplacement mémorisé de la partition selon une précision inférieure à 5% (relative à la taille du lecteur) il ne s'agit pas d'une entrée correcte.

  10. La taille de cluster ne vous aidera peut -être pas car personne ne connaît la taille des clusters d'une partition une fois formatée (voir le paragraphe 6d).

  11. La taille de la partition (20000 Mo ci-dessus). Ce nombre devrait approcher la taille mémorisée de la partition perdue à 10% près. Si ça n'est pas le cas, l'entrée n'est pas correcte.

Vous pouvez obtenir d'autres informations par l'intermédiaire des "Détails du système de fichiers" dans la fenêtre de droite de l'Étape 2:

Les Détails du Système de Fichiers dans GDB pour FAT

    • Nom: Le type de système de fichiers (FAT12, 16 ou 32).

    • Cluster0: La position du cluster 0 dans le système de fichiers.

    • Taille de cluster: le nombre de secteurs dans un cluster. Les valeurs possibles sont:

      pour FAT12: 1, 2, 4, 8,

      pour FAT16: taille du volume/nombre d'entrée max. de FAT possibles (65535) arrondi à la prochaine valeur possible,

      Pour FAT32: 8 pour 512Mo-8191Mo, 16 pour 8192Mo-16383Mo, 32 pour 16384Mo-32767Mo, 64 for >32768Mo.

    • Nombre total de secteurs: Le nombre total de secteurs dans le système de fichiers.

    • FAT1: Le cas échéant: le début du secteur de la FAT1, (la qualité de la FAT, définie par la plage du système de fichiers sélectionné couverte par la FAT),

    • FAT2: Le cas échéant: le début de la FAT2, (la qualité de la FAT, définie par la plage du système de fichiers sélectionné couverte par la FAT),

    • Longueur de la FAT: Le cas échéant, la longueur de la FAT en secteurs.

    • 1er cluster racine: Le cas échéant, le cluster de début du répertoire racine (disponible seulement pour le système de fichiers FAT32).

    • Début du rép racine: Le cas échéant, le premier secteur du répertoire racine.

    • Entrées racine # : Le nombre max. possible d'entrées du répertoire racine du système de fichiers (FAT12 et 16 seulement).

    • Nombre total de clusters: Le nombre total de clusters dans le système de fichiers.

    • Min de clusters utilisés: La plage min. de clusters contenant les données détectées à l'examen.

    • Max de clusters utilisés: La plage max. de clusters contenant les données détectées à l'examen.

    • Correspondances des données: Nombre total de correspondances entre débuts de répertoires et débuts de fichiers. Ce nombre détermine l'ordre de la liste des systèmes de fichiers à l'Étape 2. Plus la valeur est élevée, plus grande est la valeur de la probabilité de récupération des fichiers.

    • Infos de débogage: B indique le secteur de démarrage détecté, B1 indique, par exemple, qu'un secteur de démarrage a été détecté. D indique les répertoires détectés, le chiffre suivant indique le nombre de structures de répertoires détectées.

    Vérifiez ceci:

    • la valeur de la taille du cluster en fonction du tableau ci-dessus.
    • la Correspondance des données: Cette valeur vous indique le nombre min. de probabilité de récupération des fichiers. Il existe des fichiers qui peuvent être confirmés par des entrées de répertoires pointant sur eux et par le contenu d'un emplacement actuel sur le lecteur.
    • Les "Infos de Débogage". Ces infos vous indiquent COMMENT GetDataBack en vient à proposer ces entrées. Trois méthodes différentes sont utilisées:

      • B1 ou B2 - pour un ou deux secteurs de démarrage

      • Dnnnn - pour une structure de répertoire consistant en nnnn sous-répertoires

      • Cnnnn - pour correspondance entre les signatures du début des fichiers et les entrées de fichiers détectées

      Les entrées avec un C ne sont disponibles que si vous utilisez la Recherche Excessive.

      Les entrées D et C peuvent être combinées en une entrée si elles décrivent le même système de fichiers (ex.: D2112C8933). Les entrées B ne sont pas combinées. C'est la raison pour laquelle vous voyez souvent des doublons dans les deux premières lignes.

      Les entrées B sont habituellement les meilleures. Cependant, elles peuvent être trompeuses surtout quand un lecteur a été re-formaté. Elles devraient toujours être confirmées par l'existence d'une entrée D avec une valeur élevée. Ex.: D2111 décrit un système de fichiers contenant 2111 sous-répertoires. Si vous avez à choisir entre deux entrées équivalentes, une B et une D, choisissez la B.

      Une entrée D avec une valeur élevée représente l'entrée la plus importante car elle contient vraiment beaucoup de dossiers.

      Une entrée C - disponible seulement en activant "Recherche Excessive" - aide surtout dans le cas où les informations de répertoires sont minimes et dans le cas d'informations de secteur de démarrage absentes ou inutiles. Confirmer ou exclure les entrées B et D peut aussi aider.

    • Le "Code barre" en bas à droite peut vous donner d'autres informations concernant certaines entrées. Plus les masques de ces zones sont en correspondance, meilleur est le système de fichiers (CEPENDANT, il suffit finalement de répondre par OUI ou NON pour choisir ce système de fichiers):

      L'affichage est le suivant:

      • Débuts de Rép: Zones de clusters sur lesquels pointent les entrées de répertoires détectées.

      • Débuts de fichier: Zones de clusters identifiées comme étant un début de fichier.

      • Début de la FAT1: Zones de clusters sur lesquels pointe un début de chaîne dans la FAT1

      • Débuts de la FAT2: Zones de clusters sur lesquels pointe un début de chaîne dans la FAT2

      Le pourcentage de correspondance entre les débuts de fichiers et les débuts de répertoires est indiqué avec ces lignes. Ne vous inquiétez pas si ces valeur n'approchent pas les 100%. Ça n'est jamais le cas, car GetDataBack mène un examen très minutieux du lecteur et détecte toujours certains types de données orphelines qui pourraient être associées à un début de fichier ou de répertoire.

      Le pourcentage est défini comme suit:

      100 * Matching_File_Starts / Dir_Starts

      où

      Matching_File_Starts représente le nombre de secteurs identifiés comme un début de fichier ET sur lesquels pointe une entrée de répertoire.

      Dir_Starts représente le nombre de secteurs sur lesquels pointe une entrée de répertoire.

      Il existe toujours des débuts de fichiers qui ne sont pas identifiables, ce qui fait que cette valeur n'atteindra pratiquement jamais 100%. Même une valeur faible comme 30% peut générer une récupération de données parfaite.

  • Autres moyens d'améliorer la qualité d'une récupération:

    • Activez "Autoriser les doublons" avant ou pendant l'Étape 2 . Ce qui peut faire apparaître différentes versions portant le même nom de fichier, et peut-être une version qui autrement aurait été supprimée.

    • Activez "Récupérer les fichiers supprimés" SEULEMENT si vous souhaitez récupérer les fichiers supprimés avec l'Explorateur Windows ou en vidant la Corbeille. Cette option doit être activée pendant ou avant l'Étape 2. Si vous activez cette option, vous devez aussi activer "Autoriser les doublons".

    • Fragmentation: Si vous activez "Ignorer la Fat" , GetDataBack allouera les fichiers sans utiliser la FAT éventuellement détectée. Ce qui peut être utile si la FAT détectée ne reflète pas le système de fichiers que vous souhaitez récupérer. Il est préférable de n'utiliser aucune FAT que d'utiliser une FAT contenant des informations erronées. Activez cette options seulement si vous n'êtes pas satisfait avec certains fichiers de l'arborescence de récupération. Examinez "Allocation" dans "infos du fichier" pour y détecter le fichier corrompu dans l'arborescence de récupération. S'il n'est pas continu, activer cette option générera une autre version d'un tel fichier. Pour être effective, cette option doit être définie pendant ou avant l'Étape 1.

    • Voir aussi : F.A.Q., Support Technique, Effectuer une Récupération de Données


Snapshot

Instantané

L'instantané résume le processus de récupération pour le support technique. Les réglages et choix importants sont enregistrés dans l'instantané. Il représente la forme abrégée du fichier journal, et ne fera que quelques Ko.

Pour créer un instantané, traitez l'Étape 2 ou l'Étape 3 de la récupération et cliquez sur Aide->Instantané pour le support client. Il vous sera demandé un nom de fichier et un emplacement pour l'enregistrer (attention: n'indiquez pas d'emplacement sur le lecteur que vous souhaitez récupérer). C'est une bonne idée d'inclure l'instantané au message que vous adressez au support technique.

Voir aussi : Fichier journal, Assistance Technique


Show Data Structures

Afficher la Structures des Données

Les informations suivantes, concernant la structure des données du lecteur ou de la partition, sont fournies dans l'arborescence de récupération:

  • Lecteur: Le lecteur/périphérique sur lequel la récupération a été effectuée.
  • Infos Windows: Le lecteur/partition affiché dans l'arborescence de récupération.
  • Lecteur entier: Indique si oui ou non le lecteur entier a été examiné.
  • Du secteur: Secteur de démarrage du lecteur/partition affiché dans l'arborescence de récupération.
  • Au secteur: Le secteur de fin du lecteur/partition affiché dans l'arborescence de récupération.
  • Système de fichiers: Le système de fichiers du lecteur récupéré.
  • Desc. Dét. du Syst. de Fichiers: Description détaillée du système de fichiers.
  • Recherche poussée: Indique si la recherche poussée du système de fichiers été sélectionnée à l'Étape 1.

Toutes les autres information concernent le débogage et ne sont pas essentielles pour l'utilisateur.