Introduction

Einführung

GetDataBack © 2001-2010 by Runtime Software LLC

75-5744 Alii Dr., Suite #256, Kailua Kona, HI 96740, USA
Tel.: (USA): 1-808-329-2202, Fax: 1-818-475-1741
Tel.: (Deutschland): +49-30-280 8008
Email: info@runtime.org , Web: http://www.runtime.org

GetDataBack hilft Ihnen Ihre Daten zu retten, wenn die Partitionstabelle, der Boot-Record, die FAT/ MFT oder das Hauptverzeichnis beschädigt oder verloren sind, wenn die Festplatte von einem Virus heimgesucht wurde, die Platte formatiert oder mit fdisk beschädigt wurde oder von einem Stromausfall betroffen war.

GetDataBack kann auch dann noch Ihre Daten wiederherstellen, wenn die Platte nicht mehr vom Betriebssystem erkannt wird oder nicht nur das Hauptverzeichnis, sondern alle Verzeichnisinformationen verloren sind.

GetDataBack arbeitet mit fortschrittlichen Algorithmen, die sicherstellen, daß alle Verzeichnisse und Unterverzeichnisse richtig zusammengesetzt werden, und daß auch lange Dateinamen korrekt rekonstruiert werden.

GetDataBack ist sicher. Das Programm ist read-only, das heißt, es wird nie ein Schreibzugriff auf die Festplatte vorgenommen, von der die Daten gerettet werden sollen. Installieren Sie aber das Programm niemals auf dem Laufwerk, von dem die Daten gerettet werden sollen.

Die Software erlaubt es dem normalen Benutzer seine eigene Datenrettung vorzunehmen, indem sie ihn durch drei einfach zu verstehende Schritte leitet. Dem fortgeschrittenen Benutzer stehen weitere Möglichkeiten zur Verfügung, in den Datenrettungsprozess einzugreifen und die Ergebnisse zu verbessern, wie z.B. durch Untersuchung des Scan-Logs, der Dateisystemdetails, der Datei- und Verzeichnisi nformation, durch die Auswahl des zu scannenden Sektorenbereichs, der exzessiven Suche nach Dateisystemen oder der Suche nach verlorenen Dateien, durch Aufrufen von Runtime' s DiskExplorer.

GetDataBack rettet Daten von

  • Festplatten
  • USB- und Firewire-Platten
  • Partitionen
  • Floppy-Laufwerken
  • Laufwerks-Images
  • Zip/Jaz Laufwerken
  • Smart-Media-Karten, Compact-Flash-Karten
  • Remoten Laufwerken über ein serielles Kabel oder TCP/IP
  • RAID-Arrays mit Hilfe virtueller Images

Diese Version von GetDataBack rettet NT Dateisysteme, wie sie von Windows NT and Windows XP verwendet werden.

GetDataBack läuft unter den folgenden Betriebssystemen: Windows 95/98/ME, Windows NT, 2000, XP.

Sofern Sie eine FAT-Partition wiederherstellen möchten, benutzen Sie bitte GetDataBack for FAT, erhältlich auf http://www.runtime.org/gdb.htm.

Wenn Sie ein gebrochenes RAID retten möchten, sollten sie zunächst unseren RAID Reconstructor benutzen.

Einführungsbildschirm

Im ersten Bildschirm haben Sie die Möglichkeit, der Software genauere Angaben über die Ursache des Datenverlustes auf den Weg zu geben. So können Sie die optimalen Optionen für Ihre Datenrettung setzen. Wählen Sie zwischen folgenden Szenarios:

  • Weiß nicht, benutze Standardeinstellungen.

    Benutzen Sie diese Option, wenn Sie nicht sicher sind, wodurch der Datenverlust verursacht wurde, oder wenn keine der u.a. Situationen zutrifft.
    Die Standardeinstellungen (rette gelöschte Dateien, erlaube doppelte Dateinamen) bleiben unverändert.
    Wählen Sie diese Option auch, wenn Sie die Optionen selbst setzen möchten.
  • Führe einen Schnell-Scan aus (plötzlicher Partitionsverlust, FDisk)

    Wählen Sie diesen Eintrag, wenn Ihre Partition oder Ihr Laufwerk plötzlich nicht mehr verfügbar waren, z.B. aufgrund eines Hardware- oder Stromversorgungsproblems. Diese Wahl is ebenfalls sinnvoll nach einem FDisk (aber nicht nach einem Format). Der Schnell-Scan ist sehr schnell und wird den Laufwerkscan innerhalb einer Minute beenden. Falls der Schnell-Scan Ihre Dateien nicht findet, wiederholen Sie den Scan bitte mit der Auswahl "Systematischer Dateisystemschaden" (siehe unten).
  • Systematischer Dateisystemschaden, z.B. Format oder FDisk.

    Wählen Sie diese Einstellung, wenn Sie auf Ihre Daten nicht mehr zugreifen können, weil

    - das Laufwerk falsch oder versehentlich fomatiert, schnellformatiert oder fdisked wurde, aber keine Daten danach darauf geschrieben wurden,
    - auf das Laufwerk plötzlich nicht mehr zugegriffen werden kann, z.B. nach einem Hardware-Problem oder einem Stromausfall,
    - die Festplatte einige schlechte Sektoren aufweist.

    Alle Optionen werden deaktiviert, um eine möglichst saubere Datenrettung zu gewährleisten.
  • Nachhaltiger Dateisystemschaden, z.B. ein neues Betriebssystem wurde überinstalliert.

    Dieser Punkt sollte gewählt werden, wenn

    - nach dem Datenverlust jede Menge Daten auf das Laufwerk geschrieben wurden, z.B. durch die Wiederinstallation des Betriebssystems,
    - das Laufwerk teilweise überschrieben wurde,
    - das Laufwerk von Klon-Software überschrieben wurde.

    Die Standardoptionen werden aktiviert und es wird außerdem ein Marker in der Log-Datei und im Schnappschuss gesetzt, der es unseren Technikern erleichtert, das Problem einzukreisen, falls Sie später unseren technischen Support kontaktieren.
  • Ich möchte gelöschte Dateien retten.

    Selektieren Sie diesen Punkt, wenn Sie versehentlich gelöschte Dateien oder Verzeichnisse retten möchten und das Dateisystem ansonsten unbeschädigt ist. Sie stellen so sicher, dass die Optionen zum Retten gelöschter Dateien und zur Einbeziehung doppelter Dateinamen gesetzt sind.

Sie können ausserdem weitere Einstellungen manuell im Optionsmenü oder in Schritt 1 unter "Siehe gewählte Optionen" einstellen.

Sie sollten darauf verzichten, "für alle Fälle" jede verfügbare Option anzuklicken. Belassen Sie es besser bei den empfohlenen Einstellungen. In der Regel führt das Setzen jeder Option - vor allem derjeniger zum Retten verlorener Dateien und für die exzessive Suche - nicht zu einer Verbesserung der Datenrettungsresultate, sondern verlangsamt nur den gesamten Prozess.

Do's & Don'ts beim Durchführen einer Datenrettung

Der wichtigste Grundsatz zuerst: Schreiben Sie keinerlei Daten auf die Platte, von der Sie die Daten retten wollen! Installieren Sie keine Programme, benutzen Sie die Festplatte nicht zum Surfen im Internet, booten Sie noch nicht einmal von der Platte.

Schließen Sie die Platte stattdessen an einen funktionierenden Windows-Rechner als zweite Platte (slave) an, und installieren Sie GetDataBack auf der Master-Platte dieses Computers, und lassen Sie die Software von dort aus laufen. Lesen Sie bitten den Artikel über die richtige Vornahme einer Datenrettung.

Wenn Sie Grund zu der Annahme haben, dass Ihre Festplatte ein physikalisches Problem hat oder wenn Sie während des Scans mit GetDataBack Lesefehler erhalten, erwägen Sie zunächst ein Image derselben zu erstellen.

Falls Ihre Platte ernsthaften physikalischen Schaden aufweist, empfehlen wir Ihnen ausdrücklich, weitere Do-it-yourself-Datenrettungsversuche zu unterlassen und die Platte an ein auf Datenrettung spezialisiertes Labor zu schicken.

Das Scannen eines externen Laufwerkes kann sehr zeitaufwendig sein, besonders über USB1. Wenn möglich, sollten Sie dieses Laufwerk aus seinem Gehäuse entfernen und direkt an das IDE-Kabel Ihres Computers anschliessen. Recherchieren Sie im Internet, wie dies gemacht wird.

Sollten Sie Fragen zu dieser Software haben, finden Sie weitere Hilfe in der F.A.Q., oder aber kontaktieren Sie unseren Support.

Siehe auch: Vornahme einer Datenrettung, F.A.Q., Support, Check-Liste


Installation

Installieren Sie GetDataBack niemals auf dem Laufwerk, von dem Sie Daten retten möchten. Es wird dringend empfohlen, wie folgt zu verfahren:

Installieren Sie das Programm vielmehr auf einem ANDEREN, problemlos arbeitenden, Computer. Wenn Sie Auswahl haben, wählen Sie denjenigen Computer, welcher am meisten RAM installiert hat und am schnellsten ist. Schließen Sie die Platte, von der Sie die Daten retten möchten, als Slave an diesen Computer an. Stellen Sie dabei sicher, dass die Platte richtig gejumpert ist und vom BIOS erkannt wird.

Nachdem Sie dann GetDataBack auf den "guten" Computer heruntergeladen haben, rufen Sie die setup.exe auf. Das Installationsprogramm wird Sie dann durch den Installationsprozess führen.

NT/XP-Benutzer: Sie müssen Administratorrechte haben, um dieses Programm laufen zu lassen.

Sprache: Sie können die Programmsprache auswählen (im Augenblick verfügbar: Englisch oder Deutsch). Drücken Sie dazu Werkzeuge->Wähle Sprache, und wählen Sie die gewünschte Sprache. Wenn Sie "Standard" auswählen wird die Sprache entsprechend Ihren lokalen Windows-Einstellungen bestimmt.

Siehe auch: Vornahme einer Datenrettung


System Requirements

Systemvoraussetzungen

  • Pentium Prozessor
  • 32-128 MB RAM (abhängig von der Größe des zu rettenden Laufwerkes)
  • Windows 95/98/ME, Windows NT, 2000, XP

Um die besten Resultate zu erzielen, empfiehlt es sich den schnellsten, über am meisten RAM verfügenden, Computer zu benutzen, der Ihnen zur Verfügung steht und die Platte, von der Sie die Daten retten möchten, an diesen anzuschließen.

Siehe auch: Installation, Vornahme einer Datenrettung


GDB

GDBNT.INI

Diese Datei enthält einige Definitionen für GetDataBacks Datenrettungsmechanismus:

  • Die lost files Sektion enthält Definitionen für das Rettung verlorener Dateien Feature.


Version Info

Versionsinfo

Dieses Fenster gibt Auskunft über Versions-Nr. und Daten der folgenden Programmkomponenten:

  • Produkt-Name ist der Name der Software.
  • Version ist die gegenwärtige Versions-Nr.
  • Programm-Name ist der Name der EXE-Datei.
  • Programm Datei-Datum ist das Datum der EXE-Datei.
  • DRV16 Ort ist das Verzeichnis, in dem DRV16 gespeichert ist. Diese Datei ist der Treiber zum Zugriff auf Festplatten und wird für Windows 95/98/ME benötigt.
  • DRV16-Version ist die Versions-Nr. des Festplattentreibers.
  • DRV16-Datum ist das Datum des Festplattentreibers.
  • Hilfedatei ist der Name dieser Hilfedatei.
  • Installations-Verz. ist das Verzeichnis, in dem diese Software installiert ist.
  • INI-Datei ist der Name der INI-Datei dieser Software.


Menu structure

Menü-Struktur

Datei |  |
 | Datenrettung laden | lädt einen vorherigen Scan oder Datenrettungsbaum
 | Datenrettung speichern | speichert einen Scan oder Datenrettungsbaum
 | Beenden | beendet dieses Programm
Datenrettung |  |
 | Kopieren... | kopiert gerettete Dateien oder Verzeichnisse an einen sicheren Ort
 | Öffnen | öffnet eine Datei mit deren zugewiesener Applikation
 | Öffnen mit... | lässt eine Applikation auswählen, mit der eine Datei geöffnet werden soll
 | Zeige Info... | zeigt Informationen über die Datenrettungs-Details einer Datei
 | Ansicht | zeigt eine Datei mit dem eingebauten Dateibetrachter
 | Umbenennen | benenne Datei oder Verzeichnis um
Werkzeuge |  |
 | Suche Dateien... | sucht nach Dateien im Datenrettungsbaum
 | Weitersuchen | führt letzte Suche fort
 | DiskExplorer aufrufen | ruft Runtime's DiskExplorer für die gegenwärtig selektierte Struktur auf
 | Erzeuge Image-Datei... | klont das/die gegenwärtig selektierte Laufwerk/Partition
 | Optionen... | lässt Datenrettungseinstellungen verändern
 | Wähle Sprache | ändert die Sprache dieser Software
Hilfe |  |
 | Inhalt | ruft die integrierte Hilfe auf
 | Lizenzierung | lässt den Lizenzschlüssel eingeben, um alle Funktionen dieser Software freizuschalten
 | Über | zeigt Copyright-, Lizenz- und Versionsinformationen
 | Versionsinfo | zeigt weitere Versions-Informationen
 | Zeige Datenstrukturen | zeigt von GetDataBack benutzte Datenstrukturen an (interne Nutzung)
 | Schnappschuss für Support | Erstellt einen Schnappschuss der Datenrettung für Support-Zwecke


Registration

Lizenzierung

Durch die Lizenzierung der Software werden Sie in die Lage versetzt, Ihre geretteten Dateien und Verzeichnisse auf einen sicheren Ort zu kopieren. Wenn Sie online auf unserer Webseite http://www.runtime.org einen Lizenzschüssel erwerben, bekommen Sie diesen sofort, sowohl auf einer Bestätigungsseite, als auch per Email.

Sollten Sie es vorziehen, nicht online zu bestellen, können Sie uns gern anrufen (1-808-329-2202 (USA) oder +49-30-280 8008 (Deutschland), oder aber Ihre Bestellung per Fax schicken (1-818-475 1741 (USA) oder +49-30-690 88 444 (Deutschland).

Eingabe des Lizenzschlüssels

Achten Sie bei der Eingabe des Lizenzschlüssels bitte darauf, sowohl Registrierungsnamen als auch Lizenzschlüssel genauso einzugeben, wie sie in der Lizenz-Email, die Sie im Anschluss an die Bestellung erhalten haben, gezeigt werden. Name und Schlüssel sind miteinander verbunden, und nur die Eingabe beider schaltet GetDataBack frei. Es wird empfohlen, die Informationen aus der Lizenz-Email mit Kopieren und Einfügen zu übertragen.


License Agreement

Lizenzbedingungen und Haftungsausschluss

Im Folgenden sind die Bedingungen beschrieben, unter denen Runtime Softwares Software verkauft und supported wird und benutzt werden darf. Indem Sie Runtime Softwares Software benutzen oder lizenzieren, stimmen Sie diesen Bedingungen zu.
Diese Vereinbarung kann durch in einzelnen Programmen enthaltene gesonderte Bedingungen erweitert oder ersetzt werden.

Weder der Autor noch Runtime Software übernimmt Verantwortung für jedwede Kosten, Beschädigungen oder Verluste, die durch die Benutzung dieser Software entstehen, unabhängig davon, wie diese verursacht wurden.
Alle hier benutzten registrierten Marken sind Eigentum ihrer jeweiligen Registranten. Dieser Verweis tritt anstelle einer gesonderten Liste der Marken und deren Eigentümern.

Wenn Sie Software von Runtime Software lizenzieren, wird davon ausgegangen, dass Sie die Shareware-Version der Software getestet haben und für Zwecke sowie für Ihre Hardwareanforderungen geeignet befunden haben. Es besteht daher kein Anspruch auf Rückgabe der Lizenz, wenn Sie nach dem Kauf Ihre Meinung ändern.

Kein Teil der Dokumentation für diese Software oder irgendwelche die Software begleitende Dateien mit Ausnahme der Archivdatei für die Software dürfen im Ganzen oder in Teilen in irgendeinem Medium oder anderer Verbreitungsform ohne ausdrückliche schriftliche Genehmigung durch Runtime Software reproduziert werden. Die ausführbare Datei der Software darf in keiner Weise modifiziert oder gepatched werden, incl. aber nicht beschränkt auf Dekompilierung, Auseinandernahme oder anderweitiges Reverse-Engeneering des Programms.

Mit der Lizenzierung einer Kopie der Software erwerben Sie eine personifizierte Einzelnutzer-Lizenz zur zeitlich unbegrenzten Nutzung, gemäss diesen Nutzungsbedingungen. Mit einer personifizierten Einzelnutzer-Lizenz sind Sie der einzige Benutzer der Lizenz, welche auf einem Computer installiert ist, der Ihnen gehört oder von Ihnen kontrolliert wird. Wenn Sie die Software auf mehreren Geräten zugleich installiert haben möchten, müssen Sie zusätzliche Lizenzen erwerben. Wenn Sie die Software von mehreren Benutzern benutzen lassen möchten, müssen Sie zusätzliche Lizenzen erwerben. Eine Einzelnutzer-Lizenz erlaubt es Ihnen nicht, die lizenzierte Software über ein Netzwerk zum Zugriff für mehrere Nutzer zur Verfügung zu stellen, sie in irgendeiner Form zu vertreiben oder sie zusammen mit einem anderen Produkt zur Verfügung zu stellen, ohne vorher die ausdrückliche schriftliche Genehmigung von Runtime Software einzuholen. Die Lizenz ist nicht übertragbar ohne schriftliche Genehmigung von Runtime Software. Sollten Sie Fragen zur Software-Lizenz haben, setzen Sie Sich bitte mit uns in Verbindung.

Falls Sie diese Software heruntergeladen haben oder sie auf einer CD erhalten haben, ist es Ihnen gestattet, die limitierte Version der Software kostenlos zu benutzen, um die Vollversion der Software zu benutzen, müssen Sie die Software umgehend lizenzieren.

Es ist Ihnen gestattet, die Software zu vertreiben (auf CD-ROMs, Büchern, Katalogen, Internet etc.) so lange Sie jede einzelne der folgenden Bedingungen beachten:

1. Sie vertreiben nur exakte, unveränderte Kopien der originalen, unlizenzierten Shareware-Version der Software incl. der Lizenzbedingungen und des Haftungsausschlusses.
2. Sie fordern keine Geldzahlung oder sonstige Kompensation für irgendeine Kopie der Software - wie auch immer diese hergestellt wurde - ohne vorherige Genehmigung durch Runtime Software.
3. Sie beinhalten den Satz "Copyright by Runtime Software" in jeder Kopie der Software.


Glossary

Begriffserklärung

Attribute

Attribute beziehen sich üblicherweise auf die DOS-Attribute Archiv, Nur-Lesen, Verzeichnis, Versteckt, System, Laufwerk. Siehe auch: Schritt 3.
In NTFS sind Attribute Strukturen, die eine Datei vollständig beschreiben (siehe: NT Attribute).

Boot Record

Ein Boot Record ist ein spezieller Sektor, der das auf diesen Sektor folgende Dateisystem beschreibt.

Klonen eines Laufwerkes

Das Verfahren, ein exaktes Sektor-für-Sektor I mage eines Laufwerkes zu erstellen. Die Erstellung eines Images ist angezeigt, wenn Sie eine Datenrettung auf einer Platte vornehmen müssen, die physikalische Schäden, wie z.B. schlechte Sektoren, hat. Mit einem Image lässt sich dann arbeiten, wie mit der Originalplatte.

Cluster

Ein Cluster ist die kleinste Einheit, die vom Dateisystem adressiert werden kann. Ein Cluster ist immer das Vielfache eines Sektors. Typische Clustergrössen sind 1, 2, 4, 8, 16, 32, 64, 128 Sektoren.

Datenrettung

Der Prozess, Dateien von einer Platte wiederherzustellen, auf die nicht mehr vom Betriebssystem aus zugegriffen werden kann.

Gelöschte Datei

Eine Datei wird in einem FAT-Dateisystem gelöscht, indem das erste Zeichen ihres Verzeichniseintrages mit xE5 überschrieben wird und die FAT-Einträge des von ihr benutzten Clusters freigegeben werden. In NTFS wird eine Datei gelöscht, indem der Verweis auf diese Datei in der MFT als unbenutzt markiert wird. Wählen Sie "Retten gelöschter Dateien" in den Optionen, wenn Sie wünschen, dass auch gelöschte Dateien wiederhergestellt werden. Siehe auch: Gelöschte Dateien.

Verzeichnis

In einem FAT-Dateisystem ist ein Verzeichnis eine Liste von Verzeichniseinträgen. In NTFS ist ein Verzeichnis eine Liste von Index-Einträgen.

FAT-Dateisystem

Bezeichnung eines Dateisystems, das eine "file allocation table" (Datei-Allokierungs-Tabelle) benutzt. Eingeführt mit DOS und verwendet in allen Windows-Versionen. Wenn Sie eine FAT-Partition wiederherstellen möchten, benutzen Sie bitte GetDataBack for FAT, herunterladbar von http://www.runtime.org/gdb.htm.

Dateieintrag (MFT-Eintrag)

Ein Dateieintrag in NTFS ist ein Eintrag in der MFT.

Dateisystem

Das Dateisystem (wie FAT oder NTFS) ist die Art und Weise, wie eine Datei auf der Platte gespeichert wird, nicht zu verwechseln mit dem Betriebssystem (wie Windows95 oder WindowsNT).

Hexadezimal

Das Hexadezimalsystem basiert auf der Zahl 16, anders als das Dezimalsystem, welches auf der Zahl 10 aufbaut. Die ergänzenden Zahlen sind A, B, C, D, E und F. Beispiel: Hex AA = Dez 170. (10*16 + 10*1).

Image-Datei

Eine Image-Datei ist bezeichnet eine Sektor-für-Sektor-Kopie eines Laufwerkes. Es kann als Datenquelle für GetDataBack benutzt werden.

Index-Allokierung

Als Index-Allokierung sind die äußeren Daten des non-resident $A0-Attributes, welches eine Liste von Dateinamen enthält, die ein Verzeichnis ausmachen.

LFN

NTFS benutzt Attribute für die Speicherung der LFN (long file name oder langen Dateinamen).

Logisches Laufwerk

Logische Laufwerke sind Laufwerke wie A:, B:, C:, ... Auf sie wird mit Hilfe der entsprechenden Betriebssystem-Steuerungsprogramme zugegriffen.

Verlorene Datei

Verlorene Dateien sind Dateien, für die keinerlei Verzeichnisinformationen mehr vorhanden sind.

Media Descriptor

Markierungs-Byte im Boot Record, welches die Art des Laufwerkes beschreibt. Für Festplatten ist dies normalerweise xF8.

MFT (Master File Table)

Die MFT ist eine Datenbank, die Informationen über jede Datei und jedes Verzeichnis auf einem NTFS-Laufwerk enthält. Ein Eintrag wird als MFT-Eintrag oder Dateieintrag bezeichnet.

MFT-Nummer

Die MFT-Nummer gibt die Lage des Dateieintrages innerhalb der MFT an.

Non-resident Attribute

siehe: NT Attribute

NTFS

In Windows NT eingeführtes Dateisystem, welches von Windows NT, Windows 2000 und Windows XP benutzt wird.

NT Attribute

Die NT Attribute beschreiben jeden Aspekt einer Datei in NTFS, als da wären Dateinamen, Zeitmarkierungen, Dateigrößen, Datei-Allokierungen etc.:

Nummer | Name | Beschreibung
$10 | Standard information | enthält Zeitmarkierungen und DOS-Attribute
$30 | File name | enthält den Dateinamen für verschiedene name spaces (normalerweise NTs Unicode Dateinamen und den DOS-kompatiblen DOS-Dateinamen)
$80 | Data | falls der Eintrag eine Datei darstellt, enthält dieses Attribut die Daten der Datei
$90 | Index root | falls der Eintrag ein Verzeichnis darstellt, beschreibt dieses Attribut die Wurzel eines Binärbaumes, in welchem die Verzeichniseinträge sich befinden
$A0 | Index allocation | falls der Eintrag ein Verzeichnis darstellt, enthält dieses Attribut eine Liste der Dateinamen

NT Attribute können resident oder non-resident sein. Residente Attribute sind im MFT-Eintrag gespeichert. Non-residente Attribute sind außerhalb gespeichert, unter Verwendung von Lauflisten.

Partition

Als Partition bezeichnet man einen zusammenhängenden Bereich auf einem physikalischen Laufwerk. Diese wird üblicherweise vom Betriebssystem als logisches Laufwerk interpretiert.

Partitionseintrag

Ein Partitionseintrag beschreibt Typ, Lage und Größe einer Partition.

Partitionstabelle

Die Partitionstabelle befindet sich in Sektor 0 eines Laufwerkes und besteht aus einer Liste von Partitionseinträgen. Falls das Laufwerk "erweiterte Partitionen" enthält, ist eine verknüpfte Liste mehrerer auf dem Laufwerk befindlicher Partitionstabellen vorhanden.

Physikalisches Laufwerk

Physikalische Laufwerke sind anfassbare Medien, wie z.B. Festplatte oder Disketten. Zugriff auf diese geschieht durch BIOS-Funktion auf Low-Level-Ebene.

Datenrettungsbaum

Explorer-ähnliche Ansicht, die alle geretteten Dateien und Verzeichnisse darstellt. Siehe Schritt 3, Laden und Speichern einer Datenrettung.

Residente Attribute

siehe: NT Attributes

Root-Verzeichnis

In NTFS wird das Root-Verzeichnis durch den Index-Puffer von MFT-Eintrag #5 beschrieben.

Scan

Als Scan bezeichnet man den Vorgang, Sektor für Sektor eines Laufwerkes zu untersuchen. Siehe Scan, Laden und Speichern einer Datenrettung.

Sektor

Ein Sektor ist die kleinste Einheit, auf die auf einem Laufwerk zugegriffen werden kann. Die Größe eines Sektors ist immer 512 Bytes. Mehrere Sektoren sind zusammengefasst zu einem "Cluster".

Sektoren pro Cluster

Dieser Ausdruck beschreibt die Cluster-Grösse, die vom Dateisystem benutzt wird - Voraussetzung dafür, eine Cluster-Nr. in eine physikalische Sektor-Nr. zu übersetzen.

Schablone

Eine Schablone ist eine Dateisystems-Definition, die für unbekannte Dateisystem-Strukturen, wie z.B. Disketten, Zip-Laufwerke etc. benutzt werden kann.

Laufliste

Als Laufliste wird eine Liste von Clustern bezeichnet, die für ein NT Attribute benutzt wird. Sollten die Attribute zu groß sein, um in den MFT-Eintrag zu passen, werden einige non-resident, was bedeutet, dass der Wertteil desjenigen Attributes außerhalb dieses Eintrages zu suchen ist. In diesem Fall wird die sich außerhalb befindliche Datenallokierung durch eine Laufliste beschrieben.


Prepare a Recovery

Vornahme einer Datenrettung

Im Folgenden wird eine typische Datenrettung beschrieben:

  1. Installieren Sie GetDataBack auf einem problemfreien Windows-Computer - ohne bereits die Platte, von der Sie die Daten retten möchten, an diesen angeschlossen zu haben. Stellen Sie dabei sicher, dass Sie genügend Speicherplatz auf dem "guten" Laufwerk zur Verfügung haben, um später die geretteten Dateien dorthin zu kopieren. Sollten Sie Zugang zu einem LAN haben, können Sie die geretteten Daten auch dort abspeichern. Der Computer, von dem aus Sie GetDataBack laufen lassen, kann eines der folgenden Betriebssysteme haben: Windows95/98/ME, Windows NT, W2K, Windows XP.

  2. Nachdem Sie GetDataBack installiert haben, fahren Sie den Computer herunter und schließen Sie die Platte, von der Sie Dateien retten müssen ("schlechte Platte") als 2. Festplatte an. Beachten Sie bitte, dass Sie die Jumperung der Festplatte u.U. umstellen müssen. Vergewissern Sie sich, dass die Platte beim Hochfahren des Computers richtig vom BIOS erkannt wird.

  3. Starten Sie jetzt GetDataBack und vergewissern Sie sich, dass HD128: die "gute Platte" und HD129: die "schlechte Platte" ist. Durchlaufen Sie Schritt 1 bis 3 des Datenrettungsprozesses für die "schlechte Platte" HD129:. Folgen Sie bitte den Anweisungen in den einzelnen Schritten.

  4. Sobald Schritt 3 abgeschlossen ist und Sie soweit sind, die geretteten Dateien auf die "gute Platte" herüber zu kopieren, müssten Sie nun einen Lizenzschlüssel für die Software erwerben, sofern Sie dies nicht bereits getan haben. Beenden Sie nicht GetDataBack, um einen Lizenzschlüssel zu erwerben oder denselben in die Software einzugeben, geben Sie einfach den Lizenzschlüssel in Schritt 3 in der Software ein fahren Sie mit dem Kopieren der Dateien fort. Es ist eine gute Idee, mit den für Sie wichtigsten Dateien zu beginnen.

  5. Nachdem Sie alle gewünschten Dateien auf die "gute Platte" gesichert haben, fahren Sie jetzt den Computer herunter und entfernen die "schlechte Platte". Bewahren Sie diese an einem sicheren Ort auf.

  6. Es wird nun empfohlen, ein ganz neues System aufzubauen. Verwenden Sie dazu nicht wieder die "schlechte Platte". Installieren Sie das Betriebssystem und die Programme von deren jeweiligen Installations-CD-ROMs. Importieren Sie schließlich die geretteten Dateien auf das neue Laufwerk.

  7. Verifizieren Sie, dass Sie alle Dateien zurückbekommen haben, die Sie benötigen. Recyceln Sie die "schlechte Platte" nicht, bevor Sie ganz sicher sind, dass Sie alle Dateien haben, die Sie brauchen. Es empfiehlt sich, 4 Wochen zu warten, bevor Sie die "schlechte Platte" anderweitig verwenden oder wegwerfen. Sollte die "schlechte Platte" irgendwelche mechanischen Probleme gehabt haben, sollten Sie sie keinesfalls wiederverwenden.

Sollten Sie irgendwelche mechanischen Probleme, wie u.a. schlechte Sektoren oder ungewöhnliche Geräusche, an dem Laufwerk bemerken, sollten Sie die Datenrettung unverzüglich abbrechen und erst ein Laufwerks-I mage erstellen. Wenn es Ihnen gelingt, dies erfolgreich erzeugen, können Sie die Datenrettung für dieses Image laufen lassen, in gleicher Weise wie für das Originallaufwerk. Ein mechanisch beschädigtes Laufwerk kann von einer Sekunde auf die andere komplett ausfallen. Daher muss es Ihr Hauptziel sein, so schnell wie möglich alle Rohdaten von einem solchen Laufwerk zu ziehen. Hinzu kommt, dass die Erstellung eines Images das Laufwerk weniger beansprucht, als der eigentliche Datenrettungsprozess, da jeder Sektor nur einmal gelesen wird. Professionelle Datenrettungsfirmen erstellen immer zuerst ein Image des Laufwerkes, bevor sie versuchen, Dateien wiederherzustellen.

Falls Sie aus irgendeinem Grunde vom oben beschriebenen Vorgehen abweichen, stellen Sie jedenfalls sicher, dass

  • Sie niemals GetDataBack auf der "schlechten Platte" installieren,
  • niemals die "schlechte Platte" als das Boot-up System-Laufwerk (C:) benutzen,
  • keine temporären Dateien oder Verzeichnisse auf der "schlechten Platte" angelegt werden,
  • Sie niemals die geretteten Dateien auf die "schlechte Platte" kopieren,
  • immer erst ein Image erstellen, wenn die "schlechte Platte" mechanische Probleme aufweist.

GetDataBack bietet Ihnen mehrere Optionen: Sie können entweder die Daten von der Original-Festplatte, von einer Image-Datei oder sogar von einem remoten Laufwerk mittels eines seriellen Kabels oder einer TCP/IP-Verbindung retten. Es besteht außerdem die Möglichkeit einer Datenrettung über das Internet oder mittels einer WinPE/BartPE-Boot-CD.

Siehe auch: F.A.Q., Support, Check-Liste


Step1

Schritt 1: Wähle Laufwerk

In Schritt 1 werden alle Laufwerke und Geräte in Ihrem System angezeigt, auf die zugegriffen werden kann. Auf der linken Seite werden dabei die Einträge aufgeführt, aus denen Sie dann eines auswählen müssen. Darunter erhalten Sie zusätzliche Informationen über die auf der linken Seite ausgewählte Datenquelle (z.B. die Geometrie und die Anzahl der Sektoren).

Welcher Eintrag sollte gewählt werden?

Da in vielen Fällen die Originalpartitionierung nicht mehr vorhanden oder nicht mehr konsistent ist, ist es in der Regel das beste, das gesamte physikalische Laufwerk auszuwählen.

Sie sollten physikalischen Laufwerken gegenüber logischen Laufwerken den Vorzug geben, da logische Laufwerke bereits vom Betriebssystem interpretiert sind. In vielen Fällen werden Sie noch nicht einmal logische Laufwerke, die evt. die zu rettenden Daten enthalten, sehen. Physikalische Laufwerke bieten den unbeeinflusstesten Low-Level Zugriff auf die Rohdaten des Laufwerkes.

Wenn es Ihnen nur um das Wiederherstellen gelöschter Dateien geht, können Sie - anstelle der gesamten Platte - die Partition auswählen, auf der sich die Dateien vormals befunden haben, jedoch nur dann, wenn die Ursprungspartitionierung noch intakt ist.

Physikalische Laufwerke

Alle verfügbaren physikalischen Laufwerke werden mit den zugehörigen Partitionen darunter aufgelistet. Die physikalischen Laufwerke sind nach ihren BIOS Nr. benannt: FD0 ist das 1. Diskettenlaufwerk, FD1 ist das 2. Diskettenlaufwerk, HD128: ist die 1. Festplatte, HD129: ist die 2. Festplatte etc.

Logische Laufwerke

Alle logischen Laufwerke werden mit ihren jeweilig zugewiesenen Laufwerksbuchstaben angezeigt (A:, B:, C:, ...).

Image-Dateien und remote Laufwerke

Sie haben ebenso die Möglichkeit, eine Image-Datei oder ein remotes Laufwerk zu laden, indem Sie die entsprechenden Schalter im unteren Teil des Fensters drücken.

Falls die Image-Datei ein Image eines physikalischen Laufwerkes ist, werden alle dazugehörigen Partitionen ebenfalls gezeigt, und Sie können diese behandeln wie ein physikalisches Laufwerk.

Remote Laufwerke sind physikalische Laufwerke auf einem anderen Computer, auf die über ein serielles Kabel oder über TCP/IP zugegriffen wird. Sie werden behandelt wie physikalische Laufwerke.

Virtuelle Images

Sie werden vermutlich ein virtuelles Image laden, wenn Sie ein gebrochenes RAID-Array retten möchten. Virtuelle Images sind einfache Textdateien, die das RAID beschreiben. Wenn Sie die Einzelheiten Ihres RAID's kennen, können Sie diese Datei selber erstellen. Normalerweise laden Sie ein virtuelles Image, das zuvor mit Hilfe von Runtime's RAID Reconstructor erstellt wurde.

Wählen Sie nun das Laufwerk oder die Partition aus, die Sie wiederherstellen möchten, und drücken Sie Weiter.

Datenrettung mehrer Partitionen eines Laufwerkes

Wenn Sie mehrere verschiedene Partitionen, die sich auf demselben Laufwerk befunden haben, retten müssen, lesen Sie bitte den folgenden Abschnitt:

Da GetDataBack die Datenrettung auf Partitions-Ebene vollzieht, gilt folgender Grundsatz:

Wählen Sie einen Eintrag, der die zu rettende Partition vollständig enthält. Der gewählte Eintrag darf nicht die Untermenge, sondern muss vielmehr die Obermenge dieser Partition sein. Es kann auch ein Eintrag gewählt werden, der wesentlich größer ist, als die o.g. Partition, dies kann allerdings zur Folge haben, dass die Datenrettung erheblich länger dauert und verwirrende Einträge in Schritt 2 angezeigt werden.

Beispiele:

Sie wollen retten: Wählen Sie diesen Eintrag:
2. Festplatte, welche eine Partition enthält 2. Festplatte (HD129:)
1. Partition der 2. Festplatte (40GB), welche 4 Partitionen mit jeweils 10GB enthält. Der Baum sieht folgendermaßen aus:

(1) 2. Festplatte 40000MB (HD129:)
(2) + 1. Partition (NTFS) 10000MB
(3) + 2. Partition (DOS Extended) 30000MB
(4) + 1. Partition (NTFS) 10000MB
(5) + 2. Partition (DOS Extended) 10000MB
(6) + 1. Partition (NTFS) 10000MB
(7) + 2. Partition (DOS Extended) 10000MB
(8) + 1. Partition (NTFS) 10000MB

Wählen Sie Eintrag (2).

Wenn Sie weitere Partitionen retten möchten, wählen Sie Eintrag (4) für die 2. Partition, Eintrag (6) für die 3. Partition und Eintrag (8) für die 4. Partition.

Sie können auch Eintrag (1) wählen, dann werden alle 4 Partitionen in Schritt 2 angezeigt. Es wird allerdings empfohlen, nach Möglichkeit jede Partition separat zu retten.

Beispiel wie oben, aber der Baum sieht folgendermaßen aus:

(1) 2. Festplatte 40000MB (HD129:)

Hier ist offensichtlich die Partitionstabelle beschädigt. Daher müssen Sie Eintrag (1) wählen, und alle 4 Partitionen werden dann in Schritt 2 angezeigt.

Sie können in Schritt 1 manuell einen Sektorenbereich einstellen, um den gewählten Bereich an die tatsächliche Größe der Partition anzunähern.

Normalerweise würden Sie die NTFS-Partition als Quelle auswählen. Nur wenn die richtige Partition (mit ungefähr der richtigen Grösse und Position) nicht angezeigt wird, sollten Sie die DOS-Extended-Partition oder das gesamte Laufwerk auswählen.

Partieller Scan

Klappen Sie die Box Partieller Scan auf der rechten Seite des Bildschirmes, wenn Sie den zu scannenden Sektorbereich einschränken möchten.

Bitte ändern Sie diesen Sektorbereich nur dann, wenn Sie genau wissen, was Sie tun.

Normalerweise ist der voreingestellte Sektorbereich korrekt, und es gibt keinen Grund, diesen zu verändern.

Wird dieser Bereich auf denjenigen eingeschränkt, in dem sich das Dateisystem befunden hat, wird die Datenrettung schneller durchlaufen und die Resultate werden möglicherweise akurater sein.

Ändern Sie den Sektorbereich aber nur dann, wenn

- entweder die Partition, die Sie wiederherstellen möchten in Schritt 1 nicht korrekt angezeigt wird und Sie daher das gesamte Laufwerk auswählen mussten,
- oder wenn der voreingestellte Sektorenbereich nicht richtig erscheint und Sie wissen, wo die Partition in etwa gelegen hat.

Sie änderen den Scanbereich, indem Sie den Punkt Scanne Teil des Laufwerkes wählen und den Start- und Endsektor der Partition oder des Laufwerkes eingeben. Wenn Sie den genauen Partitionsbereich nicht wissen, geben Sie eher einen weiteren als einen schmaleren Bereich ein. Der definierte Bereich muss das zu rettende Laufwerk komplett enthalten.

Siehe gewählte Optionen

Hier können Sie die momentan gewählten Optionen sehen und ändern.

Laden

Drücken Sie auf Laden in der unteren linken Ecke des Bildschirms, wenn Sie anstelle einer Festplatte oder Partition einen während eines vorherigen Durchlaufs gespeicherten Scan oder Datenrettungsbaum laden möchten.

Siehe auch: Laufwerke


Drives

Laufwerke

Neben physikalischen und logischen Laufwerken, Disketten, Jaz- und Zip-Laufwerken akzeptiert GetDataBack Image-Dateien und virtuelle Images als Datenquellen für die Durchführung einer Datenrettung. Fünf verschiedene Datenquellen kommen in Betracht:

  • Physikalische Laufwerke
  • Logische Laufwerke
  • Image-Dateien
  • Remote Laufwerke
  • Virtuelle Images

Siehe auch: Schritt 1


Physical drives

Physikalische Laufwerke

Als physikalische Laufwerke bezeichnet man anfassbare Medien, z.B. wie Festplatten und Disketten. Diese haben spezifische Namen:

FD0 | 1. Diskettenlaufwerk
FD1 | 2. Diskettenlaufwerk
HD128 | 1. Festplatte
HD129 | 2. Festplatte

Diese Laufwerke können Partitionen haben, die Sie auswählen können. Wenn Sie eine Partition auswählen, ist nur derjenige Teil des Laufwerkes ("Fenster"), welches die Partition ausmacht, für GetDataBack sichtbar. Wann immer möglich, sollten Sie eine solche Partition als diejenige Einheit wählen, auf der GetDataBack den Scan durchführt. Wenn keine Partitionseinträge vorhanden sind, wählen Sie den Eintrag mit dem [image] -Symbol.

Siehe auch: Laufwerke, Schritt 1


Logical Drives

Logische Laufwerke

Logische Laufwerke sind Laufwerke, die dem Betriebssystem als A:, B:, C: etc. bekannt sind.

Sie können direkt ein logisches Laufwerk auswählen, um dieses zu inspizieren. Alternativ dazu haben Sie die Möglichkeit ein logisches Laufwerk zu untersuchen, indem Sie die entsprechende Partition eines physikalischen Laufwerkes auswählen.

Siehe auch: Laufwerke


Image Files

Image-Dateien

Image-Dateien sind Dateien, die Roh-Images von Laufwerken enthalten. Von ihnen können in gleicher Weise Daten gerettet werden, wie von einem physikalischen oder logischen Laufwerk. Um eine Image-Datei als Laufwerk zu öffnen, wählen Sie Image-Dateien (lade mehr) in Schritt 1.

Selbst auf einem Laufwerk angelegte Partitionen werden dargestellt, wenn sie in einer Image-Datei enthalten sind.

Klonen eines gesamten Laufwerkes

Eine Image-Datei erstellen Sie, indem Sie den Befehl Werkzeuge->Erzeuge Image-Datei verwenden. Sie haben dann die Möglichkeit, diese Image-Datei anstelle des Originallaufwerkes für die Datenrettung zu benutzen. Solche Image-Dateien lassen sich ebenfalls mit anderen Softwareprodukten, wie z.B. Runtime's DiskExplorer, anlegen.

Multi-Dateien

Image-Dateien können bestehen aus:

  • Einer Datei (z.B. 'drive128.img')

  • Mehreren Dateien (z.B. 'drive128.img', 'drive128.001', 'drive128.002', ...)

Die Image-Datei über mehrere Dateien anzulegen kann dann sinnvoll sein, wenn ein Image eines Laufwerkes erstellt wird, welches größer als die max. Dateigröße ist (in Abhängigkeit vom Betriebssystem, 2GB oder 4GB). Die Fragmente eines Multi-Datei-Images haben ungefähr die Größe von 656MB. Eine kleinere Größe zeigt das Ende des Datei-Satzes an.

Kompression

Sie haben sogar die Möglichkeit, komprimierte Image-Dateien zu erzeugen (z.B. 'drive128.imc'), indem Sie als Dateiendungstyp für die zu erzeugende Image-Datei 'Komprimierte Image-Dateien (*.imc)' angeben. Dieses Feature erlaubt es, Image-Dateien zu erstellen, die wesentlich kleiner sind als das ursprüngliche Laufwerk.

Komprimierte Image-Dateien können ebenfalls als Multi-Datei-Image angelegt werden.

Siehe auch: Laufwerke, Datei öffnen und Datei erstellen


File Open and File Create

Datei öffnen und Datei erstellen

Dieser Dialog erfordert die Angabe eines Dateinamens, um eine Datei zu öffnen oder zu erstellen.

Wählen Sie einen der folgenden Datei-Typen:

  • Image-Dateien (IMG) sind Roh-Kopien von Laufwerken.
  • Komprimierte Image-Dateien (IMC) sind komprimierte Roh-Kopien von Laufwerken.
  • Virtuelle Images (VIM) (nur-lesen) sind Skripte, die ein Arrangement verschiedener anderer Laufwerksarten beschreiben. Dies ist hilfreich für die Rettung von RAID-Laufwerken.

Image-Dateien und komprimierte Image-Dateien werden in zwei verschiedenen Versionen angeboten:

  • Mehrere Dateien gewählt speichert die Daten in mehreren Dateien, von denen jede 656MB groß ist. Hierdurch wird das Image leichter zu handhaben und mögliche Beschränkungen hinsichtlich Dateigrößen werden umgangen.
  • Eine Datei gewählt speichert die Daten in einer einzigen Datei.

Siehe auch: Laufwerke


Virtuelle Images

Virtuelle Images sind kurze Textdateien, die zu ladende Daten beschreiben. Sie können diese nutzen, um mehrere Datenquellen "zusammenzukleben". Das ist besonders nützlich, wenn ein RAID-Array gerettet werden soll. Runtime's RAID Reconstructor, zum Beispiel, erstellt ein virtuelles Image, welches hier benutzt werden kann.

Virtuelle Images haben immer die Dateiendung "vim".

Sie können auch eigene virtuelle Images erstellen. Ein virtuelles Image ist eine XML-Datei mit nur ein wenigen Kommandos ("Tags"). Eine beliebige Anzahl von Datenquellen kann zusammengefügt werden, solange die Gesamtkapazität nicht 2 TB überschreitet.

<virtualimage>

Dieses ist der Wurzel-Tag, der alle anderen Tags umschließt.

Beispiel:

<virtualimage>
:
:(other tags)
:
</virtualimage>

<sector>

Dieser Tag setzt die Sektornummer auf einen neuen Wert. Etwaige Lücken werden mit Null-Sektoren gefüllt.

Beispiel:

<virtualimage>
:
  <sector>1000</sector>
:
</virtualimage>

<drive>

Dieser Tag beschreibt ein Laufwerk, das in dem virtuellen Image benutzt werden soll. Sie können auch einen bestimmten Bereich innerhalb dieses Laufwerkes spezifizieren.

Beispiel:

<virtualimage>
  <drive>HD128:</drive>
</virtualimage>

Dieses Beispiel eines kompletten virtuellen Images benutzt Ihre 1. Festplatte (HD128:) Der Laufwerksname muss immer mit einem Doppelpunkt abgeschlossen werden.

Ein weiteres Beispiel:

<virtualimage>
  <drive>HD128:0-999</drive>
  <drive>c:\images\myimage.img:1000-</drive>
</virtualimage>

Dieses Beispiel weist die ersten 1000 Sektoren von HD128 dem virtuellen Image zu. Ab Sektor 1000 des virtuellen Images werden die Sektoren 1000 und aufwärts der Imagedatei "c:\images\myimage.img" benutzt. Die Bereiche werden von zwei mit einem Bindestrich getrennten Zahlen bestimmt. Wenn Sie die zweite Zahl weglassen, erstreckt sich der Bereich bis zum Ende des jeweiligen Laufwerkes.

Mögliche Laufwerknamen:

HD128:, HD129:, etc | 1., 2. physikalisches Laufwerk etc.
FD0:, FD1: | 1., 2. Diskettenlaufwerk
C:, D:, etc. | Logische Laufwerke C:, D:, etc.
myfile.img, myfile.imc | Imagedateien
NULL: | Virtuelles Laufwerk, liefert Nullsektoren, muss von einem Bereich gefolgt werden.

<loop>

Der <loop>-Tag ("Schleife") eignet sich zum Definieren von RAID-Arrays.

Beispiel:

Definition eines RAID-5 mit 3 Platten, einer Blockgröße von 128, sowie "Rückwärts-Rotation":

<virtualimage>
  <loop>
    <drive>c:\img\raid5\r1.img:</drive>
    <drive>c:\img\raid5\r2.img:</drive>
    <drive>c:\img\raid5\r3.img:</drive>
    <cycle blocksize="128">
      <stripe>1,2</stripe>
      <stripe>1,3</stripe>
      <stripe>2,3</stripe>
    </cycle>
  </loop>
</virtualimage>

Nach dem einführenden <loop>-Tag spezifizieren Sie die Laufwerke, die in dem RAID benutzt werden. Bezüglich der Syntax des <drive>-Tags lesen Sie bitte obige Spezfikation.

In dem <cycle>-Tag (Zyklus) definieren Sie die Streifen (stripes), die das RAID ausmachen. Jeder Streifen ist eine Folge von Daten, welche von den zuvor definierten Laufwerken stammen. Definieren Sie die Blockgröße als ein Attribut des <cycle>Tags. Obiges Beispiel kann man so lesen:

  1. Nehme 128 Sektoren vom 1. Laufwerk (Sektoren 0-127).

  2. Nehme 128 Sektoren vom 2. Laufwerk (Sektoren 0-127).

  3. Nehme 128 Sektoren vom 1. Laufwerk (Sektoren 128-255).

  4. Nehme 128 Sektoren vom 3. Laufwerk (Sektoren 128-255).

  5. Nehme 128 Sektoren vom 2. Laufwerk (Sektoren 256-383).

  6. Nehme 128 Sektoren vom 3. Laufwerk (Sektoren 256-383).

Das setzt sich fort bis das Ende eines Laufwerkes erreicht wird. Die kleinste Platte bestimmt hierbei die Größe der Schleife. Wenn das kleinste Laufwerk 10000 Sektoren groß ist, dann beträgt die Gesamtgröße 20000 Sektoren, aufgerundet bis zum nächsten vollen Zyklus, das sind 20736. Sie können die Schleifengröße auf zwei Arten verändern:

1) Geben Sie an, wie oft die Schleife wiederholt werden soll. Fügen Sie dafür dem <loop>-Tag ein Attribut mit dem Namen "repeat" hinzu, z.B.: <loop repeat="27">. Wenn Sie im RAID-Beispiel den Zyklus 27 mal wiederholen, bekommen Sie 6*128*27= 20736 Sektoren.

2) Geben Sie einen Bereich an. Fügen Sie dafür das Attribut "range" dem <loop>-Tag hinzu, z.B..: <loop range="10-20">.

Das "repeat"-Attribut überschreibt die implizite Größe, die von den Laufwerkgrößen bestimmt ist. Das "range"-Attribut überschreibt das "repeat"-Attribut.

Sie können sogar unvollständige RAID-5-Arrays definieren. Falls im obigen Beispiel das 3. Laufwerk fehlt, kann das Array auch so beschrieben werden:

<virtualimage>
  <loop>
    <drive>c:\img\raid5\r1.img:</drive>
    <drive>c:\img\raid5\r2.img:</drive>
    <cycle blocksize="128">
      <stripe>1,2</stripe>
      <stripe>1,1x2</stripe>
      <stripe>2,1x2</stripe>
    </cycle>
  </loop>
</virtualimage>

Der Ausdruck 1x2 errechnet den fehlenden Sektor, der ursprünglich auf der 3. Platte war.

Siehe auch: Laufwerke


Remote Drive Access

Remote Laufwerke

Dieses Feature ermöglicht Ihnen, GetDataBack auf einem Computer ("remote/entfernt") laufen zu lassen und von diesem aus auf Laufwerke, die sich auf einem Computer ("host/Gastgeber") befinden, zuzugreifen.

Auf dem "remoten" Computer läuft dabei GetDataBack, während auf dem "host" Computer HDHost läuft. HDHost ist kostenlos herunterladbar von http://www.runtime.org.

Rufen Sie auf der Host-Seite die HDHOST.EXE auf, und konfigurieren Sie die gewünschte Verbindung. Sobald Sie damit fertig sind, drücken Sie bitte Warte auf Verbindung.

Auf GetDataBack-Seite drücken Sie dann den Schalter Remote Laufwerke in Schritt 1. Nun wird ein neues Fenster aufgehen, in dem Sie aufgefordert werden, die Art der Verbindung zu wählen und zu konfigurieren. Wenn Sie das gemacht haben, drücken Sie Verbinden, und ein weiteres Fenster wird aufgehen, in welchem die verfügbaren physikalischen Laufwerke auf dem Host-Computer angezeigt werden. Wählen Sie dort eines aus. Sie werden im Anschluss wieder in den Laufwerksauswahl-Bildschirm zurückgeführt. Drücken Sie hier Ok, und das remote Laufwerk wird geladen.

Sie können zwei verschiedene Arten von Verbindungen aufbauen:

  • Serielle Kommunikation über RS232 (Com Port)
  • TCP/IP Kommunikation über eine Netzwerkkarte (NIC)

Serielle Kommunikation ist relativ langsam, daher ist TCP/IP grundsätzlich vorzuziehen. Allerdings ist es einfacher, eine serielle Kommunikation aufzubauen, und jeder Computer ist mit einem seriellen Port ausgestattet.

Serielle Kommunikation

Für serielle Kommunikation benötigen Sie ein Null-Modem-Kabel, welches beide Computer über den COM Port miteinander verbindet. Wählen Sie auf beiden Seiten die Nummer des Portes aus, an den das o.g. Kabel angeschlossen ist. Beide Seiten müssen dabei die selbe Baud-Rate benutzen.

TCP/IP Kommunikation

Für TCP/IP Kommunikation in einem LAN benötigen Sie eine Netzwerkkarte (NIC).

Wählen Sie als Verbindung die IP, die Ihrer Netzwerkkarte zugeordnet ist. Sollte diesem Computer nicht durch einen DHCP-Server eine IP-Adresse zugeteilt sein, müssen Sie ihm u.U. eine statische IP-Adresse in der Windows Netzwerk-Konfiguration zuteilen. Eine typische Adresse für diesen Computer wäre 192.168.1.51 und 192.168.1.50 für den Host-Computer.

Nehmen Sie als IP des Host die IP der Host-Verbindung. Sie müssen u.U. wiederum eine statische IP-Adresse (z.B. 192.168.1.50) für den Host-Computer in der Windows Netzwerk-Konfiguration festlegen.

Tipps:

  • Falls Sie Probleme haben, eine Verbindung herzustellen, versuchen Sie zwischen Host- und Remote-Computer zu PINGEN. Gehen Sie dazu in die Eingabeaufforderung des Remote-Computers und geben Sie ping 192.168.1.50 ein. Versuchen Sie es auf Host-Seite mit ping 192.168.1.51 (ausgehend davon, dass 192.168.1.50 die IP des Hosts und 192.168.1.51 die des Remote-Computers ist). Das PINGEN muss auf beiden Seiten erfolgreich sein.
  • Schalten Sie alle Firewalls aus.

Siehe auch: Laufwerke


Scanning the drive

Scannen des Laufwerkes

Das Fenster "Scannen des Laufwerkes" gibt Ihnen Informationen über den Datenrettungsprozess.

Sie sehen hier:

  • den gegenwärtigen Prozess
  • die Datenquelle für die Datenrettung, incl. des zu scannenden Sektorbereichs
  • die Anzahl der bereits identifizierten Verzeichnisse und Dateien
  • die Anzahl der gefundenen Boot Records
  • die Sektor-Nr. des gerade untersuchten Sektors
  • die verbleibende Zeit, die für den Scan noch benötigt wird, und eine Fortschrittsanzeige, die angibt, wieviel Prozent des Laufwerkes bereits gescannt wurde.

Drücken Sie Abbrechen oder Stop, falls Sie diesen Vorgang abbrechen möchten. Wenn Sie den Vorgang abbrechen, wird Ihnen angeboten, zurück zu Schritt 1 zu gehen oder die Datenrettung mit einem unvollständigen Scan fortzusetzen. Es ist nicht empfehlenswert, die Datenrettung mit einem unvollständigen Scan fortzusetzen, weil GetDataBack die besten Ergebnisse erst nach einer vollständigen Untersuchung der gesamten Festplatte liefert.


Step2

Schritt 2: Wähle Dateisystem

Nachdem der Scan durchgelaufen ist, werden die von GetDataBack gefundenen Dateisysteme auf der linken Seite des Fensters dargestellt.

Lassen Sie sich nicht dadurch verwirren, dass evt. unerwartet viele Dateisysteme angezeigt werden. GetDataBack nimmt einen sehr gründlichen Scan des Laufwerkes vor. Insbesondere wenn ein großes Laufwerk mit mehreren Partitionen oder ein Laufwerk, welches repartitioniert wurde, gescannt wurde, kann es vorkommen, dass die Software mehrere mögliche Dateisystem-Anfänge findet.

Standardmäßig wird das akkurateste Dateisystem als erster Eintrag in der Liste aufgeführt. Die Sortierreihenfolge dieser Liste wird von den Datenübereinstimmungen jedes Dateisystems bestimmt. Je höher die Position, desto mehr rettbare Dateien sind zu erwarten.

Sie sollten also normalerweise den obersten Eintrag auswählen. Nur wenn

  • das hierdurch repräsentierte Dateisystem hinsichtlich Grösse oder Geometrie gar nicht der ursprünglichen Partitionierung entspricht,
  • oder Sie Ihre Daten in Schritt 3 nicht sehen,
  • oder die im Datenrettungsbaum gelisteten Dateien sich nicht korrekt öffnen lassen,
  • oder Sie mehr als eine Partition auf derselben Platte retten müssen,

sollten Sie von Schritt 3 zu Schritt 2 zurückgehen und weitere Einträge aus der Dateisystemliste auswählen.

Eine weitere interessante Zahl ist die Qualität eines Dateisystems. Dieser Wert kann als Anzahl von Dateien innerhalb des Dateisystem verstanden werden, die von der jeweiligen Struktur erfasst werden.

  • Ein grüner Punkt weist normalerweise auf ein gutes Dateisystem, mit einem hohen Potential an hochqualitativen Datenrettungsresultaten, hin,
  • Dateisystem mit einem gelben Punkt können ebenfalls sehr befriedigende Resultate erbringen (besonders dann, wenn kein Eintrag mit einem grünen Punkt vorhanden ist),
  • Dateisysteme mit einem roten Punkt sind nicht vielversprechend, es sei denn, Sie retten Daten von einer beinahe leeren Festplatte.

Werfen Sie aber einen genauen Blick auf die Einträge! Welches Dateisystem kommt hinsichtlich Partitionsgröße, Cluster-Grösse und Dateisystemtyp dem zu rettenden Dateisystem am nächsten? Wählen Sie dieses aus.

Die Dateisystemdetails auf der rechten Seite des Bildschirms liefern zusätzliche Informationen über die Qualität des Dateisystems.

Wählen Sie nun das Dateisystem, welches im Datenrettungsbaum angezeigt werden soll, und drücken Sie Weiter.

GetDataBack erstellt nun den Baum aus geretteten Dateien und Verzeichnissen. Je nach Größe des Laufwerkes kann dies wiederum etwas Zeit in Anspruch nehmen, jedoch lange nicht so viel wie der Scan. Unterbrechen Sie diesen Prozess nur wenn unbedingt notwendig.

Sollten Sie in Schritt 2 Zurück drücken, werden Sie zu Schritt 1 zurückgebracht. Wenn Sie dann von Schritt 1 aus die Datenrettung fortführen möchten, müssten Sie den gesamten Scan wiederholen, es sei denn, Sie speichern den Scan während Sie in Schritt 2 sind.

Siehe auch: Dateisystem-Details, Check-Liste


File System Details

Dateisystemdetails

Im rechten Fenster in Schritt 2 finden Sie zusätzliche Informationen über die Struktur und die Qualität der gefundenen Dateisysteme:

Die Dateisystem-Details sind wie folgt strukturiert:

  • Name: Der Dateisystem-Typ.

  • Cluster0: Die Lage von Cluster 0 im Dateisystem.

  • Cluster-Größe: Die Anzahl der Sektoren in einem Cluster. Mögliche Werte sind hier 1-128 Sektoren, übliche Werte sind 1-8.
  • Sektoren total: Die Gesamtzahl der Sektoren im Dateisystem.
  • 1. Mft-Cluster: Die Cluster-Nr. des Anfangs der Master File Table.
  • 1. MFtmirror Cluster: Die Cluster-Nr. des Anfangs der gespiegelten Master File Table.
  • Index-Puffer-Größe: Die Größe eines Index-Puffers. Ein Index-Puffer ist ein Bereich, in dem Verzeichnisinformationen gespeichert werden.
  • 1. Root-Cluster: Falls vorhanden: der Start-Cluster des Rootverzeichnisses (nur vorhanden für FAT32 Dateisysteme).
  • Cluster total: Die Gesamtzahl der Cluster in diesem Dateisystem.

  • Min Cluster benutzt: Der Mindest-Cluster-Bereich in dem Daten durch den Scan gefunden wurden.

  • Max Cluster benutzt: Der max. Cluster-Bereich in dem Daten durch den Scan gefunden wurden.

  • Datenübereinstimmungen: Die Anzahl der Übereinstimmungen von "Datei-Starts" mit "Mft-Starts". Diese Zahl legt die Sortierreihenfolge der Dateisystem-Liste in Schritt 2 fest. Je höher ihr Wert, desto höher ist die Anzahl der vermutlich rettbaren Dateien.

  • Debug-Info: B steht für gefundenen Boot Record, B1 z.B. bedeutet, dass ein Boot Record gefunden wurde. M steht für gefundene MFTs, die folgende Zahl gibt die Anzahl der gefundenen MFT-Strukturen an.

Sollte einer dieser Werte überhaupt keinen Sinn machen, so könnte dies ein Hinweis darauf sein, dass die Qualität dieses Dateisystems nicht besonders gut ist. Es lohnt sich dann, einen Blick auf die anderen Dateisysteme in der Liste zu werfen, sofern weitere vorhanden sind.

Qualität des Dateisystems: Die kleine Bar-Code-artige Grafik in der rechten unteren Ecke kann weitere Hilfestellung bei der Auswahl des richtigen Dateisystems leisten:

Dargestellt sind:

  • Mft-Starts: Die Cluster-Bereiche in denen MFT-Eintragsanfänge gefunden wurden.
  • Datei-Starts: Die Cluster-Bereiche in denen Dateianfänge gefunden wurden.

Der Prozentsatz von übereinstimmenden Dateianfängen zu MFT-Anfängen ist rechts dieser Reihen angezeigt. Seien Sie aber nicht entmutigt, wenn dieser Wert nicht einmal annähernd 100% ist. Der Prozentsatz erreicht tatsächlich nie 100%. Dies ist dem Umstand geschuldet, dass GetDataBack einen sehr umfangreichen Scan des Laufwerkes vornimmt und in dessen Verlauf immer irgendwelche verwaisten Daten findet, die mit einem Datei- oder MFT-Anfang assoziiert werden könnten.

Der Prozentsatz ist definiert als:

100 * Matching_File_Starts / Mft_Starts

wobei

Matching_File_Starts die Anzahl der Sektoren ist, die als ein Dateianfang und als Sektor auf die ein MFT-Eintrag zeigt, identifiziert sind,

Dir_Starts die Anzahl der Sektoren ist, auf die ein MFT-Eintrag zeigt.

Es sind hierbei immer Dateianfänge vorhanden, die nicht identifiziert werden können, deshalb wird der Wert von 100% fast nie erreicht. Vielmehr kann sogar trotz eines niedrigen Wertes von 30% eine perfekte Datenrettung erreicht werden.

Siehe auch: Schritt 2, Check-Liste


Step3

Schritt 3: Datenrettungsbaum

Auf der linken Bildschirmseite sehen Sie den Datenrettungsbaum, bestehend aus den geretteten Dateien und Verzeichnissen und einem Order "verlorene Dateien", der vom Programm angelegt wurde und Dateien ohne jegliche Verzeichnisinformation enthält.

Wenn Sie einen Ordner auf der linken Seite öffnen, werden die darin enthaltenen Dateien auf der rechten Bildschirmseite dargestellt, ähnlich wie Sie es vom Windows Explorer kennen.

Kopieren

Markieren Sie jetzt die Dateien, die Sie kopieren möchten. Sie können natürlich auch ganze Verzeichnisse kopieren, indem Sie diese auf der linken Bildschirmseite markieren, oder das komplette Laufwerk kopieren, indem Sie links den obersten Eintrag (FAT12, 16 oder 32) selektieren. Drücken Sie den Schalter "Kopieren", dann geht ein Fenster auf, in dem Sie bestimmen können, wohin die Dateien oder Verzeichnisse kopiert werden sollen. Es kann hier entweder eine andere Festplatte, ein lokales Netzwerk, ein Zip- oder Jaz-Laufwerk oder eine Diskette gewählt werden. Kopieren Sie die Dateien niemals auf das Laufwerk oder die Partition, von der Sie gerade die Daten gerettet haben!

Während Sie in der unlizenzierten Version von GetDataBack all Ihre geretteten Dateien sehen können, den Datei-Betrachter, die Such-Funktion und das Datei-Information-Feature benutzen können, bedarf es der lizenzierten Version, um die Dateien auf ein sicheres Medium zu kopieren. Die Lizenzierung der Software ist schnell und einfach. Sie müssen den Datenrettungsprozess nicht wiederholen. Erwerben Sie einfach einen Lizenzschlüssel auf unserer Webseite, geben Sie diesen in Schritt 3 der Datenrettung ein, und die Kopierfunktion wird freigeschaltet.

Qualität der Datenrettung

Es besteht wenig Anlass, darüber verunsichert zu sein, wie die Resultate der Datenrettung nach dem Kopieren der Dateien sein mögen. In den meisten Fällen erhalten Sie diejenigen Dateien, die Sie im Datenrettungsbaum sehen, nach dem Kopieren in brauchbarem Zustand. Das heißt, wenn Sie Ihre Dateien im Datenrettungsbaum sehen und diese in Ordnung scheinen, werden sie es höchstwahrscheinlich nach dem Kopieren auch sein.

Es ist jedoch empfohlen, mehrere Dateien vor dem Kopieren - und vor dem Erwerb eines Lizenzschlüssels - zu überprüfen. Nutzen Sie die folgenden Features von GetDataBack, um die Qualität der Datenrettung zu verifizieren:

  • Betrachten Sie die Datei (F3)
  • Öffnen Sie die Datei mit deren zugewiesener Applikation
  • Untersuchen Sie die Dateiinformation für die Datei

Es kann vorkommen, dass Sie im Datenrettungsbaum Ordner sehen, die ähnlich wie dieser aussehen: (1229BD). Dies bedeutet, dass der Root-Verzeichniseintrag für dieses Verzeichnis verloren gegangen ist und der Verzeichnisname daher nicht ermittelt werden konnte. Die Unterverzeichnisse (falls vorhanden) und die Dateien in diesem Verzeichnis sollten dennoch vorhanden sein.

Insbesondere im Ordner "Verlorene Dateien" werden Sie Dateien finden, die folgendermaßen aussehen: #345HD33.doc Dies ist dem Unstand geschuldet, dass diese Dateien ohne jede Verzeichnisinformation wiederhergestellt wurden. Aus diesem Grunde konnte der ursprüngliche Dateiname nicht rekonstruiert werden. Die Dateiendung sollte aber korrekt sein und Ihnen so wenigstens einige Information über die Datei liefern.

Falls Sie Probleme haben, die geretteten Dateien zu öffnen, lesen Sie bitte die C heck-Liste .

Datenrettung speichern

Um eine Datenrettung für spätere Verwendung zu s peichern, drücken Sie bitte Datei->Datenrettung speichern und wählen einen Dateinamen. Speichern Sie diese Datei niemals auf dem Laufwerk oder der Partition, von der Sie die Daten gerettet haben.

Diese Feature speichert nicht die geretteten Dateien. Es speichert nur die Struktur des Datenrettungsbaumes. Um die geretteten Dateien zu speichern, sehen Sie bitte: Kopieren .

Sortieren

Um die Dateien auf der rechten Seite nach Grösse, Namen, Attributen, Erstellungsdatum etc. zu sortieren, drücken Sie bitte auf die entsprechende Spaltenüberschrift.

Öffnen

Öffnen Sie Dateien, indem Sie die Datei doppel-klicken, den Schalter "Öffnen" betätigen oder Eingabe drücken. Wenn immer möglich, wird die Datei dann in ihrer zugewiesenen Applikation geöffnet. Anderenfalls können Sie die Applikation wählen, mit der die Datei geöffnet werden soll.

Drücken Sie den "Öffnen mit"-Schalter oder Strg-Eingabe, um die Applikation zu wählen, mit der eine Datei geöffnet werden soll.

Betrachten

Benutzen Sie den Datei-Betrachter, um einen ersten Blick auf die geretteten Dateien zu werfen. Markieren Sie dazu eine Datei, die Sie untersuchen möchten, und drücken Sie den Schalter Ansicht oder F3. Der Dateibetrachter ist in der Lage den Dateiinhalt für eine Vielzahl von Dateitypen (.txt, .doc, .bmp) darzustellen. Wenn der Dateityp nicht unterstützt wird, wird der Dateiinhalt in Hexadezimal-Format angezeigt.

Umbenennen

Sollte der richtige Dateiname nicht wiederhergestellt worden sein, (z.B., weil die Root-Verzeichnisinformation zerstört war), können Sie diese Dateien umbenennen, bevor Sie sie kopieren. Wählen Sie dazu die Datei/das Verzeichnis aus, welches Sie umbenennen möchten und drücken dann F2. Sie können selbstverständlich die Dateien auch erst nach dem Kopieren umbenennen.

Suchen

GetDataBack beinhaltet eine Datei-Such-Funktion. Betätigen Sie den Such-Schalter, und geben Sie den Suchbegriff ein.

Aussehen der Dateinamen - Attribute

Aussehen | Bedeutung
Dateiname.ext | normale(s) Datei oder Verzeichnis
Dateiname.ext | nur-lesen
Dateiname.ext | System
Dateiname.ext | versteckt
Dateiname.ext | komprimiert
Dateiname.ext | gelöscht

Gelöschte Dateien

Gerettete gelöschte Dateien können in demjenigen Verzeichnis gefunden werden, in dem sie sich ursprünglich befanden. Sie sind durch einen durchgestrichenen Dateinamen gekennzeichnet. Wenn Sie nach Dateien suchen, die aus dem Papierkorb geleert wurden, schauen Sie im RECYCLE-Ordner nach. Seien Sie Sich dessen bewusst, dass Dateien, die aus dem Papierkorb geleert wurden, nicht mehr ihre Original-Dateinamen tragen, aber immer noch über die ursprüngliche Dateiendung verfügen.

Datei-Information

Sollten Sie sich weitergehend mit Ihrer Datenrettung befassen wollen, können Sie einen Blick auf die Datei-Information werfen. Markieren Sie dazu eine Datei, an der Sie interessiert sind, und drücken Sie den Info-Schalter oder Strg-I.

Runtime's DiskExplorer

Markieren Sie eine Datei/ein Verzeichnis, und rufen Sie Runtime's DiskExplorer auf. Diese Programm gibt Ihnen low-level Zugriff auf den Verzeichniseintrag der gewählten Datei/des gewählten Verzeichnisses.

Wenn Sie in Schritt 3 Zurück drücken, werden Sie zu Schritt 2 zurückgeführt. Wenn Sie dann die Datenrettung von Schritt 2 aus weiterführen, müssten Sie dann die Erstellung des Datenrettungsbaumes noch einmal vollziehen, es sei denn, Sie haben die Datenrettung gespeichert während Sie sich in Schritt 3 befanden.


File

Dateiinformation

Um detaillierte Informationen über eine bestimmte Datei oder ein Verzeichnis im Datenrettungsbaum zu erhalten, markieren Sie bitte diese Datei/dieses Verzeichnis und drücken Datenrettung->Zeige Info oder den Infoknopf.

Die hier erklärten Informationen werden dargestellt:

  • Unicode-Name: Der Anzeigename der Datei/des Verzeichnisses.
  • DOS-Name: Der kurze Name der Datei/des Verzeichnisses.
  • Typ: Der Typ (Verzeichnis oder Datei).
  • DOS Attribute: Die Attribute (a = archiv, r = nur-lesen, h = versteckt, s = System, l = Laufwerksname, d = Verzeichnis, c = komprimiert).
  • Größe: Für Dateien= die Größe der Datei in Bytes, für Verzeichnisse= die Anzahl der Verzeichnisse und Dateien in diesem Verzeichnis, die Größe des Verzeichnisses.
  • Zuletzt geändert: Datum/Zeit der letzten Änderung dieser Datei/dieses Verzeichnisses.
  • Erstellt: Datum/Zeit der Erstellung dieser Datei/dieses Verzeichnisses.
  • Zuletzt zugegriffen: Datum, an dem diese Datei zuletzt aufgerufen wurde.
  • Allokierung durch: Interne Debug-Info.
  • Mft-Eintrags-Nr.: Die Lage des Eintrags in der Master File Table.
  • Eltern-Mft-Eintrags-Nr..: Die Lage des Verzeichnisses der Datei in der MFT.
  • Mft-Ort: Die Sektor-Nr., wo der MFT-Eintrag, der diese Datei beschreibt, gefunden wurde.
  • Erster Cluster: Der erste Cluster dieser Datei/dieses Verzeichnisses.
  • Erster Sektor: Der erste Sektor dieser Datei/dieses Verzeichnisses.

Siehe auch: Runtime's DiskExplorer


View File

Dateiansicht

Der Dateibetrachter ist in der Lage, verschiedentliche Textdateien (.txt, .doc, .rtf, .wri) und viele Grafikdateien (.htm, .jpg, .bmp, .ico, .wmf) darzustellen. Binäre und unbekannte Formate werden in einem Hex-Betrachter angezeigt.

Markieren Sie die Datei, die Sie betrachten möchten im Datenrettungsbaum und drücken Sie Datenrettung->Ansicht im Hauptmenü.

Siehe auch: Schritt 3


Save and Load Recovery

Speichern und Laden einer Datenrettung

Wichtig: Speichern Sie niemals irgendwelche Dateien auf dem Laufwerk, welches Sie im Begriff sind zu retten!

Speichern und Laden eines Scans

Nachdem der Scan des Laufwerkes durchgelaufen ist, haben Sie die Möglichkeit, diesen Scan in Schritt 2 für spätere Wiederbenutzung zu speichern. Drücken Sie dazu nur Datei->Datenrettung speichern, und geben Sie den Ort an, an dem die Datei gespeichert werden soll. Die daraus resultierende Datei wird die Dateiendung .ST2 tragen.

Um einen Scan zu laden, gehen Sie wieder zu Schritt 1 von, wählen dieselbe Festplatte, wie im vorherigen Durchlauf aus und drücken dann aber den Knopf Laden. Auf diese Art und Weise müssen Sie den zeitintensiven Scan nicht nochmals vornehmen. Obiges Vorgehen ist dann sinnvoll, wenn Sie mit den Datenrettungsresultaten im Datenrettungsbaum nicht zufrieden sind und z.B. in Schritt 2 ein anderes Dateisystem auswählen möchten.

Wählen Sie im resultierenden Fenster die erste Option, um einen Laufwerksscan zu laden und die Dateisystemliste erneut aufzubauen. Drücken Sie Ok, und wählen Sie die Schritt 1-Resultatedatei ~GDBSAVE.ST1 aus. Diese Datei wird vom Programm im Standard temp. Verzeichnis angelegt und enthält den zuletzt durchgeführten Scan. Sie können die Resultate von Schritt 1 zwar nicht direkt von GetDataBack aus abspeichern, es besteht aber natürlich die Möglichkeit, diese Datei umzubenennen, um sie später erneut zu verwenden.

Wählen Sie die zweite Option in o.g. Fenster, wenn sie stattdessen eine Dateisystemliste laden und direkt zu Schritt 2 gehen möchten. Drücken Sie Ok, und wählen Sie die richtige .ST2-Datei aus.

Speichern und Laden einer Datenrettung

Nachdem der Datenrettungsbaum aufgebaut ist, können Sie die Resultate für spätere Verwendung in Schritt 3 speichern. Drücken Sie dazu einfach Datei->Datenrettung speichern, und geben Sie den Ort an, an dem die Datei gespeichert werden soll. Die daraus resultierende Datei wird die Dateiendung .ST3 tragen.

Um eine Datenrettung zu laden gehen Sie bitte wieder zu Schritt 1, aber drücken Sie dann den Schalter "Laden" in Schritt 1, wählen die 3. Option aus, drücken Ok und wählen die .ST3-Datei.


Options

Optionen

In den Optionen können Sie folgendes festlegen:

  • das standardmäßige Speicherverzeichnis, also das Verzeichnis, in das die geretteten Dateien kopiert werden sollen,
  • das standardmäßige temporäre Verzeichnis, also das Verzeichnis, in dem die für die Datenrettung notwendigen Dateien, die S can-Datei und die Logdatei gespeichert werden sollen,
  • den Ort, an dem Runtime's DiskExplorer gespeichert ist, falls Sie diesen heruntergeladen haben und ihn während des Datenrettungsprozesses aufrufen möchten.

Wichtig: Geben Sie niemals ein Verzeichnis auf demjenigen Laufwerk an, von dem Sie die Daten retten möchten!

Klicken Sie "Retten gelöschter Dateien" an, wenn Sie wünschen, dass auch gelöschte Dateien im Datenrettungsbaum enthalten sind.
Hinweis: Falls Sie diese Option, aber nicht die Option "Erlaube doppelte Dateinamen" anklicken, wird GetDataBack -wenn es auf doppelte Dateinamen stößt- den aktuellsten Eintrag aufnehmen, unabhängig davon, ob dieser gelöscht ist oder nicht. Um wirksam zu werden, muss diese Option in Schritt 2 oder früher angestellt werden.

Aktivierung der Option "Erlaube doppelte Dateinamen" hat zur Folge, dass das Programm mehr als eine Datei mit dem selben Dateinamen innerhalb eines Verzeichnisses akzeptiert. Diese Dateinamen können verschiedene Versionen der selben Datei reflektieren. Wenn diese Option nicht gecheckt ist, wird GetDataBack den aktuellsten Eintrag nehmen. Um wirksam zu werden, muss diese Option in Schritt 2 oder früher angestellt werden.

Wählen Sie "Retten verlorener Dateien", wenn Sie damit rechnen, Dateien ohne jegliche Verzeichnisinformationen auf Ihrem Laufwerk zu haben. Standardmäßig sollten Sie diese Option nicht anklicken, da dies - besonders, wenn die Datenrettung für ein großes oder repartitioniertes Laufwerk durchgeführt wird - in einer großen, meist nicht benötigten, Menge Datenmüll resultiert. Um wirksam zu werden, muss diese Option in Schritt 1 oder früher angestellt werden.

Wenn Sie das Feature "Exzessive Suche" anwählen, wird dies den Datenrettungsprozess verlangsamen. Klicken Sie es also nur dann an, wenn das gesuchte Dateisystem nicht in Schritt 2 aufgeführt wird, vor allem auf Medien mit sehr wenig Datei- oder Verzeichnisinformationen, wie z.B. Disketten. Durch die exzessive Suche werden mehr mögliche Dateisysteme in Schritt 2 angezeigt.

Zusätzlich können Sie festlegen, wie die Software sich im Falle schlechter Sektoren verhalten soll - falls es während des Scans auf solche trifft. Schlechte Sektoren sind Bereiche auf der Festplatte, die physikalisch beschädigt sind und daher nicht mehr mit Softwaremitteln gelesen oder interpretiert werden können. Sektoren werden in Blöcken von 16 Sektoren gelesen. Wenn dieser Vorgang scheitert, kann das an einem oder mehreren schlechten Sektoren liegen.

Sie haben die folgende Auswahl:

Überspringe ganzen Block - alle 16 Sektoren werden als schlecht erachtet. Es wird kein Versuch unternommen, möglicherweise gute Sektoren in diesem Block zu lesen.
Versuche jeden Sektor - das Programm wird versuchen, jeden Sektor einzeln zu lesen. Dadurch besteht die Chance, möglicherweise gute Sektoren in der Umgebung schlechter Sektoren aufzufinden. Dieser Vorgang kann jedoch sehr zeitintensiv sein, vor allem wenn doch keine guten Sektoren vorhanden sind.

Das Feld "Ausgeschlossene Dateien" erlaubt es, die angegebenen Dateien von der Datenrettung auszunehmen. Normalerweise sollte dieses Feld leer bleiben. Nur besondere Umstände, etwa Speicherprobleme, rechtfertigen den Ausschluss bestimmter Dateien.. Wenn Sie beispielsweise TMP- oder BAK-Dateien ausschließen wollen, geben Sie bitte ein:

*.tmp;*.bak

Um wirksam zu sein, setzen Sie diese Option in Schritt 2 oder früher.

Das "Benutze nur gültige MFT"-Feature reduziert die Dateieinträge auf diejenigen, welche in einer gültigen MFT enthalten sind. Aus diese Weise werden Sie ungewollte Geisterdateien los. Das ist nützlich, wenn sich "Virtual Machines" oder Backupdateien auf einer Platte befinden, welche mit GetDataBack's Datenrettungsalgorithmen interferieren. Damit das auch funktioniert, muss natürlich auch eine gültige MFT existieren. Setzen Sie diese Option, wenn sich viele unerwünschte Dateien im Datenrettungsbaum befinden. Wenn Sie Dateien vermissen, stellen Sie sicher, dass diese Option ausgeschaltet ist. Um wirksam zu sein, setzen Sie diese Option in Schritt 2 oder früher.

Die Option "Schnell-Scan" bewirkt einen schnellen Scan der gewählten Partition oder des gewählten Laufwerkes. Schalten Sie diese Option ein, wenn Ihre Partition plötzlich nicht mehr verfügbar war, z.B. aufgrund eines Hardware- oder Stromversorgungsproblems. Sie macht ebenfalls Sinn nach einem FDisk (aber nicht nach Format). Der Schnell-Scan ist sehr schnell und wird den Laufwerkscan innerhalb einer Minute beenden. Falls der Schnell-Scan Ihre Dateien nicht findet, schalten Sie ihn bitte wieder aus und wiederholen Sie den Scan. Um wirksam zu sein, setzen Sie diese Option in Schritt 1.

Drücken Sie Zurücksetzen, um zu den für das im Eingangsbildschirm spezifizierte Szenario empfohlenen Einstellungen zurückzukehren.


Search

Suche

GetDataBack stellt Ihnen eine komfortable Suchfunktion zur Verfügung. Um nach Dateien oder Verzeichnissen zu suchen, gehen Sie zu Werkzeuge->Suche Dateien.

Das Feld Datei-Maske erwartet eine Dateinamen-Maske, wie z.B. *.* oder *.doc.

Es sind drei verschiedene Arten von Filtern verfügbar:

  • Datum: Legen Sie ein Anfangs- und ein Enddatum fest, und nur Dateien oder Verzeichnisse, die innerhalb dieser Zeitspanne geändert wurden, werden angezeigt.
  • Größe: Spezifizieren Sie einen Größenbereich, und nur Dateien innerhalb dieses Bereiches werden gezeigt.
  • Typ: Bestimmen Sie, ob ausschließlich nach gelöschten Dateien, ausschließlich nach nicht gelöschten Dateien oder nach beiden gesucht werden soll. Hinweis: Sie müssen in den Optionen festgelegt haben, dass auch gelöschte Dateien im Datenrettungsbaum enthalten sein sollen, bevor dieser aufgebaut wird.

Die Suchtiefe bestimmt, wie tief GetDataBack innerhalb der Verzeichnisstruktur suchen wird. Ein Wert von 8 bedeutet, es wird in bis zu 8 Unterverzeichnissen suchen.

Wenn Sie dann Start drücken, wird der gesamte Datenrettungsbaum entsprechend Ihren Einstellungen durchsucht.

Sie können die Suche jederzeit mit Stop abbrechen.

Sobald die Suche durchgelaufen ist, können Sie dann die gefundenen Dateien und Verzeichnisse im unteren Fenster untersuchen. Dazu können Sie im Prinzip all das tun, was Sie auch im Datenrettungsbaum können, nämlich Dateien ansehen, öffnen, sortieren, kopieren oder das Info aufrufen, etc.

Der Schalter Sync bringt Sie zu der Lage der Datei im Datenrettungsbaum.

Der Schalter Neu leert das Fenster von den gegenwärtigen Resultaten.


Runtime

Runtime's DiskExplorer

Runtime's DiskExplorer for NTFS ist ein leistungsstarker Festplatten-Editor, der es ermöglicht,

  • unter Benutzung Browser-ähnlicher Vorwärts- und Rückwärtspfeile durch die Platte zu navigieren und dabei u.a. direkt zur Partitionstabelle, zum Boot Record, zur MFT oder zu MFT-Einträgen zu gehen, oder aber direkt auf einen bestimmten Sektor zu springen,
  • zwischen verschiedenen Ansichten, wie z.B. Hex-, Text-, Verzeichnis-, Dateieintrags-, Dateieintragsdetail-, Partitionstabellen-, und Boot Record-Ansicht zu wechseln,
  • die Platte nach Text, Boot Records, Partitionstabellen oder Unterverzeichnissen zu durchsuchen,
  • den Boot Record eines Laufwerkes mit Hilfe der Laufwerksinformationen zu untersuchen,
  • die Platte mittels virtuellem Lesezugriff oder direktem Lese/Schreib-Zugriff (nicht empfohlen) zu editieren,
  • sogar gelöschte Dateien anzusehen und wiederherzustellen,
  • falls der Boot Record verloren oder beschädigt ist, ein virtuelles Laufwerk zu erstellen,
  • selber mit Hilfe vorgenannter Features eine Datenrettung erfolgreich vorzunehmen.

Um Runtime's DiskExplorer direkt von GetDataBack aus aufzurufen, laden Sie bitte das Programm von unserer Webseite herunter http://www.runtime.org. Installieren Sie es - wobei Sie niemals das Programm auf dem Laufwerk installieren sollten, von dem Sie die Daten retten möchten. Drücken Sie dann Werkzeuge->Optionen in GetDataBack und geben an, wo Sie DiskExplorer installiert haben.

Wenn Sie DiskExplorer in Schritt 1 von GetDataBack aufrufen, bringt Sie das zum Start-Sektor Ihres Master-Laufwerkes, sobald Sie dort ein eine Festplatte oder Partition auswählen, an den Anfang des ausgewählten Laufwerkes. Starten Sie DiskExplorer in Schritt 2 gelangen Sie zum Anfang der MFT und in Schritt 3 zum MFT-Eintrag der selektierten Datei/Verzeichnisses.

Die Lizenzierung von GetDataBack umfasst keinen Lizenzschlüssel für Runtime's DiskExplorer, eine Lizenz für DiskExplorer muss bei Benutzung über die 30-Tage-Testperiode hinaus für dieses Produkt separat erworben werden.

Weitere Informationen zu Runtime's DiskExplorer erhalten Sie in den Hilfedateien des Programms oder auf unserer W ebseite.


Lost files

Verlorene Dateien

GetDataBack ist in der Lage, selbst Dateien noch zu retten, für die keinerlei Verzeichnisinformation mehr vorhanden sind. Voraussetzung dafür ist allerdings, dass das Programm diese Dateien an ihrer Dateisignatur und Dateiendung erkennen kann.

GetDataBack kann in der vorliegenden Version bereits einige Dateitypen erkennen, wie z.B. DOC-Dateien, BMP-Dateien, RIFF-Dateien, ZIP-Dateien, Help-Dateien.

Sollten Sie eine Datei eines anderen Dateiformats wiederherstellen müssen, müssten Sie das entsprechende Dateiformat in der GDBNT.INI-Datei definieren. In Hilfe->Versions-Info ist angegeben, wo sich die GDBNT.INI befindet.

Gehen Sie zur Sektion Lost Files (verlorene Dateien) in der GDB.INI, und geben Sie die Datei-Parameter in der folgenden Reihenfolge ein (durch Komma getrennt):

  • Name der Datei (freie Wahl)
  • Dateiendung
  • Länge der Datei-Signatur (zwischen 2 und 8 Bytes)
  • Datei-Signatur (in Hex, am Anfang der Datei gelegen)
  • Typ (reserviert für weitere Entwicklung, geben Sie 1 ein)
  • Größe der Datei (falls diese Information im Dateikopf nicht verfügbar ist, geben Sie eine Größe ein, die ausreichend ist, um die Größe der zu rettenden Datei abzudecken)

Beispiel: Help-Dateien

Help-Dateien beginnen mit der Signatur $3F,$5F,$03,$00.
Gefundene "verlorene" Help-Dateien werden im Datenrettungsbaum die Endung HLP haben.
Die Größe der Datei wird von dem Doppelwort an Position 12 im ersten Sektor [12,4] bestimmt.

Help-Datei= HLP,4, $3F,$5F,$03,$00, 1, [12,4]

Weitere Hilfe finden Sie in der GDBNT.INI.

Um Dateien definieren zu können, ist einige Erfahrung, Forschung und ein guter Festplatten-Editor, wie z.B. Runtime's DiskExplorer von Nöten.

Um dieses Feature zu aktivieren, müssen Sie das Kästchen "Retten verlorener Dateien" im Bildschirm Optionen anklicken. Setzen Sie diese Option spätestens in Schritt 1 der Datenrettung.


Log file

Logdatei

Die Logdatei erlaubt es Ihnen, nachzuvollziehen, was GetDataBack während des Datenrettungsprozesses unternommen hat. Jeder einzelne Schritt des Programms ist in der Logdatei dokumentiert: der Scan nach verfügbaren Laufwerken, die Auswahl der Datenquelle, die Auswahl von Dateisystem und Sektoren-Bereich, der Scan des Laufwerkes, die Auswahl des Dateisystems aus der Liste der gefundenen Dateisysteme und die Erstellung des Datenrettungsbaumes.

Diese Datei birgt Informationen über die Geometrie des selektierten Laufwerkes/der Partition, die Qualität der vom Programm entdeckten Dateisysteme, die Sektor-Nr. und die ersten 8 Byte der gefundenen Dateien, die mit verlorenen Dateien verbundenen Dateinamen, die Lage von Verzeichnisanfängen und den Kopiervorgang.

Wird die Datenrettung für ein großes Laufwerk vorgenommen, kann die Log-Datei relativ viel Speicherplatz benötigen. Sollten Sie sich dafür entscheiden, eine Log-Datei der Datenrettung anlegen zu wollen, wählen Sie bitte einen Dateinamen im Eingangsbildschirm.

Sie können das Feature Schnappschuss benutzen, um eine Kurzform dieser Log-Datei zu erstellen.

Schnappschuss, Support


Troubleshooting

Fehlerbehebung

Im Folgenden sehen Sie die Warnungen und Fehler, auf die Sie während der Datenrettung am ehesten stoßen werden:

Zugriff verweigert

COMCTRL32 veraltet

Konnte Laufwerk nicht sperren

DRV16 nicht gefunden

I/O Fehler

Behandlung schlechter Sektoren

Falls Sie einen Runtime-Fehler erhalten, schicken Sie doch bitte einen Screenshot an: support@runtime.org.

Siehe auch: F.A.Q., Support, Vornahme einer Datenrettung, Check-Liste


Access Denied

Fehler: Zugriff verweigert

Diese Meldung erscheint, wenn Sie versuchen

  • eine Datei zu öffnen, die gerade von einem anderen Prozess exklusiv benutzt wird, oder
  • eine Datei, die schreibgeschützt ist, im Lese/Schreib-Zugriff zu öffnen.

Siehe auch: Image-Dateien


Outdated COMCTRL32

Veraltete COMCTRL32.DLL

Ihre Windows Version benutzt eine veraltete Version der 'COMCTL32.DLL'. Diese Komponente ist eine Erweiterung des Windows Betriebssystems und wird normalerweise mit dem MS Internet Explorer mitgeliefert.

Höchstwahrscheinlich haben Sie dadurch Probleme mit den visuellen Elementen dieser Software, wie z.B. damit Schalter in dem Programm dargestellt zu bekommen. Sie sollten aber nichts desto trotz in der Lage sein, die Software laufen zu lassen.

Empfehlenswert wäre, eine neue Version der o.g. DLL von http://www.microsoft.com/msdownload/ieplatform/ie/comctrlx86.asp herunterzuladen oder eine aktuelle Version des MS Internet Explorers zu installieren.


Drive Locking Failed

Warnung: Konnte Laufwerk nicht sperren

Ein Laufwerk zu sperren ist ein Verfahren auf unterer Betriebsystemebene, welches verhindern soll, dass mehrere Prozesse gleichzeitig auf ein physikalisches oder ein logische Laufwerk zugreifen. Sie sollten sicherstellen, dass keine anderen Prozesse auf das Laufwerk zugreifen. Falls Sie die Warnung ignorieren, wird der Prozess möglicherweise weiterlaufen, die Gefahr besteht dann allerdings, dass Daten auf diesem Laufwerk beschädigt werden. Aus diesem Grunde ist es nicht empfohlen, die Warnung zu ignorieren.

Siehe auch: Laufwerke


DRV16.DLL not found

Warnung: DRV16.DLL nicht gefunden

Diese Warnung erscheint beim Programmstart, falls das Programm auf einem Windows95/98/ME System läuft und die Datei DRV16.DLL nicht gefunden werden konnte.

Diese Komponente stellt den physikalischen Laufwerkszugriff zur Verfügung und wird von GetDataBack benötigt. Sie sollten das Programm verlassen und GetDataBack neu installieren.

Siehe auch: Physikalische Laufwerke


Read Error

Fehler: E/A-Fehler

Diese Meldung erscheint, wenn das Programm während des Lesezugriffs auf das Laufwerk auf einen Fehler stößt. Dieser Fehler ist nicht heilbar, Sie können ihn jedoch ignorieren.

Es stehen dann die folgenden Optionen zur Auswahl:

Drücken Sie Ja: der Fehler wird ignoriert und der Prozess läuft weiter.

Drücken Sie Ja zu allen: der Fehler wird ignoriert und der Prozess läuft weiter. Zukünftige Fehler werden unterdrückt und ignoriert, die o.a. Fehlermeldung erscheint nicht wieder. Dieser Zustand wird mit dem nächsten regulären Prompt für eine Benutzereingabe aufgehoben.


Bad sector

Behandlung schlechter Sektoren

Beim Lesen eines Sektorblockes ist ein Fehler aufgetreten.

Sektoren werden in Blöcken von 16 Sektoren gelesen. Wenn dieser Vorgang scheitert, kann dies daran liegen, dass ein oder mehrere schlechte Sektoren vorhanden sind. Entsprechend den Einstellungen in den Optionen, wird das Programm folgendes tun:

Sektorblock überspringen

Alle 16 Sektoren in diesem Block werden dann als schlecht angesehen. Es wird kein Versuch unternommen, möglicherweise gute Sektoren aus diesem Block wiederherzustellen.

Versuch wiederholen, auf einzelne Sektoren zuzugreifen

Das Programm wiederholt den Versuch, die Sektoren einen nach dem anderen zu lesen. Dies ermöglicht, dass evt. gute Sektoren, die sich in Nachbarschaft zu schlechten befinden, doch aufzufinden. Dieser Vorgang kann allerdings sehr zeitintensiv sein, besonders dann, wenn viele schlechte Sektoren vorhanden sind.

Siehe auch: Optionen


F.A.Q.

GetDataBack for Windows 95/98/ME/NT/2000/XP for NTFS & FAT

F. Kann Fragmentierung des Laufwerkes die Resultate der Datenrettung beeinflussen?

F. Kann ich die Qualität meiner geretteten Dateien prüfen, bevor ich einen Lizenzschlüssel für die Software erwerbe?

F. Kann ich GetDataBack benutzen, um Daten von CDs, CDRs and DVDs zu retten?

F. Kann GetDataBack meine Dateien retten, obwohl meine Festplatte nicht mehr vom BIOS erkannt wird?

F. Während der Anwendung von GetDataBack bekomme ich einen Laufwerksfehler, was hat das zu bedeuten?

F. Wie kann ich die Qualität meiner Datenrettung optimieren?

F. Verschiedene Dateien konnten nicht gefunden werden, wie bekomme ich diese doch noch wieder?

F. Die geretteten Dateien lassen sich nicht öffnen. Warum?

F. Ich weiß nicht, welches Dateisystem auf dem Laufwerk war, bevor es abstürzte. Was soll ich tun?

F. Ist es unbedenklich, GetDataBack auf meinem gecrashten Laufwerk laufen zu lassen?

F. Wie gehe ich vor, wenn die Daten von meinem Notebook/Laptop retten möchte?

F. Funktioniert GetDataBack mit Festplatten, die größer als 8,2 Gigabyte sind?

F. Wie rette ich Dateien, die mit dem Windows Explorer gelöscht wurden?

F. Kann Fragmentierung des Laufwerkes die Resultate der Datenrettung beeinflussen?

A. Fragmentierung in NTFS sollte die Ergebnisse der Datenrettung nicht beeinflussen. Die Information über die Allokierung einer Datei wird (anders als bei FAT Dateisystemen, bei denen diese Information in der FAT gespeichert wird), in einem MFT-Eintrag gespeichert. Wenn die Datei im Datenrettungsbaum gezeigt wird, sollte sie auch zu retten sein. Sollte sie aber die erwarteten Daten nicht enthalten, sollten Sie Ihre Auswahl in Schritt 2 überprüfen.

Nach oben

F. Kann ich die Qualität meiner geretteten Dateien prüfen, bevor ich einen Lizenzschlüssel für die Software erwerbe?

A. Ja, GetDataBack verfügt über einen integrierten Dateibetrachter, der es ermöglicht, die Qualität der geretteten Dateien zu überprüfen. Sie können ebenfalls die Dateien mit deren zugewiesener Applikation öffnen, bevor Sie die Software lizenzieren müssen.

Nach oben

F. Kann ich GetDataBack benutzen, um Daten von CDs, CDRs and DVDs zu retten?

A. Nein, GetDataBack rettet Daten von Festplatten, Disketten, Jaz- und Zip-Laufwerken, Smart-Media-Karten, Compact-Flash-Karten, USB- und Firewire-Platten, ist aber nicht zur Datenrettung von CDs, CDRs und DVDs geeignet.

Nach oben

F. Kann GetDataBack meine Dateien retten, obwohl meine Festplatte nicht mehr vom BIOS erkannt wird?

A. Nein, falls das BIOS die Platte nicht mehr erkennt, kann GetDataBack keine Datenrettung auf dieser durchführen. Stellen Sie bitte sicher, dass die Kabelverbindungen, Jumper-Einstellungen und Controller in Ordnung sind. Wird die Platte dann immer noch nicht vom BIOS erkannt, versuchen Sie es an einem anderen Computer, und sehen Sie, ob sie evtl. dort erkannt wird.

Nach oben

F. Während der Anwendung von GetDataBack bekomme ich einen Laufwerksfehler, was hat das zu bedeuten?

A. GetDataBack ist für die Lösung logischer Probleme entwickelt, die Software kann nicht bei Datenrettungsfällen aufgrund versagender Hardware helfen. Ein Laufwerksfehler ist ein Anzeichen für ein Hardwareproblem. Es wird in diesen Fällen dringend empfohlen, keine weiteren Datenrettungsversuche auf dieser Platte zu unternehmen -und auch anderweitig mit der Platte nicht zu arbeiten- bevor Sie nicht ein Laufwerks-Image produziert haben. Sogar nur der Versuch, auf Daten auf diesem Laufwerk zuzugreifen, kann weitere Beschädigung nach sich ziehen! Nachdem Sie erfolgreich ein Image von dem Laufwerk erstellt haben, können Sie dann dieses als Datenquelle, auf dem GetDataBack die Datenrettung durchführt, verwenden.

Nach oben

F. Wie kann ich die Qualität meiner Datenrettung optimieren?

A. Was haben Sie in Schritt 1 des Programms ausgewählt? Es sollte grundsätzlich das physikalische Laufwerk für die Datenrettung gewählt werden..
Wählen Sie in Schritt 2 dasjenige Dateisystem für die Datenrettung aus, welches die akkuratesten Informationen enthält. Die Qualität der einzelnen Dateisysteme können Sie vergleichen, indem Sie sich die Details im rechten Fenster ansehen. Ein weiterer Indikator für ein höherwertiges Dateisystem ist der prozentuale Wert rechts der Grafik in der rechten unteren Ecke. Bevor Sie also die Software lizenzieren, stellen Sie sicher, dass die Datenrettungsresultate befriedigend sind, indem Sie eine ausreichende Anzahl von Dateien vorher überprüfen.

Sehen Sie dazu auch die umfangreiche Check-Liste.

Nach oben

F. Verschiedene Dateien konnten nicht gefunden werden, wie bekomme ich diese doch noch wieder?

A. Lesen Sie bitte zuerst die Empfehlungen in Wie kann ich die Qualität der Datenrettung optimieren?

Versuchen Sie die Option "Erlaube doppelte Dateinamen". Hierdurch werden evt. vorhandene verschiedene Versionen einer Datei im Datenrettungsbaum angezeigt.

Testen Sie, ob die Option "Rette verlorene Dateien" weitere Dateien hervorbringt.

Sehen Sie dazu auch die umfangreiche Check-Liste.

Nach oben

F. Die geretteten Dateien lassen sich nicht öffnen. Warum?

A. Es gibt zwei verschiedene Gründe, warum gerettete Dateien sich nicht öffnen lassen:

  1. Es ist möglich, dass Ihre Dateien von anderen Daten überschrieben wurden. In diesem Fall ist kein Datenrettungsprogramm in der Lage, diese Daten wiederherzustellen.

  2. Ein weiterer Grund, warum sich die Dateien nicht öffnen lassen, kann darin liegen, dass Sie in Schritt 2 den falschen Dateisystemseintrag gewählt haben. Wählen Sie in Schritt 2 dasjenige Dateisystem für die Datenrettung aus, welches die akkuratesten Informationen enthält. Die Qualität der einzelnen Dateisysteme können Sie vergleichen, indem Sie sich die Details im rechten Fenster ansehen. Ein weiterer Indikator für ein höherwertiges Dateisystem ist der prozentuale Wert rechts der Grafik in der rechten unteren Ecke.

Empfehlungen:

Zu 2. Lassen Sie GetDataBack erneut laufen, bis Sie zu Schritt 2 gelangen. Probieren Sie andere Dateisystemseinträge aus, welche hinsichtlich Größe und Lage derjenigen Partition, die Sie retten möchten, in etwa entsprechen. Wir sind jederzeit gern bereit, Sie bei der Auswahl des richtigen Dateisystemeintrages in Schritt 2 zu unterstützen (siehe: Support).

Sehen Sie dazu auch die umfangreiche Check-Liste.

Nach oben

F. Ich weiß nicht, welches Dateisystem auf dem Laufwerk war, bevor es crashte. Was soll ich tun?

A. Wenn Sie nicht wissen, welches Dateisystem sich auf Ihrem Laufwerk vor dem Crash befand, probieren Sie einfach beide Demoversionen von GetDataBack aus. Laden Sie hierzu die Demos auf einen funktionierenden Windows-Computer herunter und installieren Sie sie dort. Schließen Sie im Anschluss die gecrashte Platte als zweite Festplatte an diesen Rechner an, und vergewissern Sie sich, dass das BIOS diese Platte richtig erkennt. Nun können Sie die FAT und NTFS Demos benutzen, um Ihre Platte zu untersuchen. Sofern die Platte keinen physikalischen Schaden hat, ist dies ist gefahrlos und wird keinen weiteren Schaden anrichten, da GetDataBack nur lesend auf die Platte zugreift.
Nachdem Sie o.a. Instruktionen befolgt haben, wird die für Ihr Dateisystem richtige Version von GetDataBack in Schritt 3 einen Datenrettungsbaum ausgeben, der Ihre gesuchten Dateien und Verzeichnisse enthält. Die Qualität der geretteten Dateien können Sie überprüfen, indem Sie eine Datei markieren und dann Datenrettung->Öffnen im Hauptmenü drücken. Stellen Sie fest, dass Ihre Dateien sich problemlos öffnen lassen, können Sie diese dann auf einen sicheren Ort auf einer anderen Platte kopieren (nur möglich in der lizenzierten Version).

Ein kleiner Hinweis für Nutzer, die mit den verschiedenen Windowsversionen weniger vertraut sind:
Win 3.11, Win 95, Win 98, Win Me benutzen ein FAT-basiertes Dateisystem.
Win NT, Win 2000, XP können entweder NTFS oder FAT benutzen.

Nach oben

F. Ist es unbedenklich, GetDataBack auf meinem gecrashten Laufwerk laufen zu lassen?

A. Ja, solange die Platte keinen physikalischen Defekt hat, ist es sicher, GetDataBack zu benutzen. Da das Programm nur lesend zugreift, wird es niemals irgendetwas auf der gecrashten Platte verändern. Installieren Sie die Software auf einem funktionierenden Windows-Computer, und schließen Sie die Platte, die die verloren Daten enthält, als zweite Platte an diesen Computer an. Stellen Sie sicher, dass die zweite Platte vom BIOS richtig erkannt wird. Lassen Sie im Anschluss GetDataBack laufen, und wählen Sie in Schritt 1 Ihre "schlechte" Platte aus (normalerweise ist dies HD129). Drücken Sie ' Weiter '. Das Programm wird nun das Laufwerk scannen. Anhängig von der Größe des Laufwerkes wird dieser Vorgang nun einige Zeit dauern. Sobald der Scan durchgelaufen ist, wird Ihnen eine Liste mit gefundenen möglichen Dateisystemen präsentiert. Normalerweise sollten Sie den ersten Dateisystemeintrag aus der Liste auswählen. Drücken Sie ' Weiter '. Das Programm wird nun den Datenrettungsbaum erstellen. Kurze Zeit später sollten Sie nun den Baum aus geretteten Dateien und Verzeichnissen sehen. An dieser Stelle können Sie feststellen, ob GetDataBack die verlorenen Dateien gefunden hat. Wenn die Dateien gefunden wurden, empfiehlt es sich jetzt die Qualität derselben zu untersuchen. Hierzu wählen Sie einfach eine Datei, die Sie interessiert, aus und drücken ' Datenrettung->Ansicht' oder ' Datenrettung->Öffnen' im Hauptmenü. Wenn die Datei hier in Ordnung ist, wird sie es höchstwahrscheinlich auch dann sein, nachdem Sie sie auf ein sicheres Medium -wie eine andere Festplatte- kopiert haben.

Nach oben

F. Wie gehe ich vor, wenn ich Daten von meinem Notebook/Laptop retten möchte?.

A. Sie können die Festplatte aus dem Gerät entfernen und mittels eines Notebook-IDE-Adaptors an einen Desktop-Computer anschliessen. Installieren Sie in diesem Fall GetDataBack auf dem Desktop-Computer und lassen Sie die Software von dort laufen. Alternativ dazu können Sie eine WinPE/BartPE-Boot-CD erstellen und die Datenrettungssoftware davon laufen lassen. Sie finden eine Anleitung zum Erstellen einer solchen Boot-CD und der benötigten Plug-ins für GetDataBack auf unserer Webseite unter http://www.runtime.org/peb.htm . Bitte bedenken Sie, dass Sie später trotzdem genug Platz auf einer anderen Festplatte brauchen, um die geretteten Dateien zu speichern.

Nach oben

F. Funktioniert GetDataBack mit Festplatten, die größer als 8,2 Gigabyte sind?

A. Ja, GetDataBack läuft auf Festplatten jedweder Größe, bei sehr großen Platten können allerdings der Scan und die Datenrettung etwas länger dauern.

Nach oben

F. Wie rette ich Dateien, die mit dem Windows Explorer gelöscht wurden?

A. Aktivieren Sie zunächst die Option "Retten gelöschter Dateien" im Fenster Optionen. Lassen Sie dann GetDataBack ganz normal laufen, bis es den Datenrettungsbaum aufgebaut hat. "Endgültig gelöschte" Dateien können, sofern sie noch vorhanden sind, in den Verzeichnissen gefunden werden, wo sie ursprünglich gespeichert waren. Dateien aus dem "geleerten Papierkorb" finden sich innerhalb des RECYCLE-Verzeichnisses. Bitte beachten Sie, dass diese Dateien ihren einstigen Dateinamen eingebüsst haben, aber noch ihre ursprüngliche Dateiendung tragen.
Es ist desweiteren eine gute Idee, die Suchfunktion zu benutzen.

Nach oben

Siehe auch: Support, Vornahme einer Datenrettung, Check-Liste


Support

Um technische Unterstützung zu erhalten, können Sie uns jederzeit kontaktieren:

USA

Telefon | 1-808-329-2202
Fax | 1-818-475-1741
Email | support@runtime.org
Webseite | http://www.runtime.org

Europa (Deutschland)

Telefon | +49-30-280 8008
Fax | +49-30-690 88 444
Email | support_europe@runtime.org
Webseite | http://www.runtime.org

Sollten Sie irgendwelche Fragen zur Benutzung dieser Software haben, rufen Sie uns bitte an, oder schreiben Sie uns eine Email.

Es ist eine gute Idee, Ihrer Supportanfrage einen Schnappschuss der Datenrettung beizufügen.

Siehe auch: F.A.Q., Vornahme einer Datenrettung, Check-Liste, Schnappschuss, Log-Datei


Check List

Check-Liste

Benutzen Sie diese umfassende Check-Liste nur in den Fällen, in denen Sie Ihre geretteten Dateien entweder vor oder nach dem Kopieren nicht öffnen können (beschädigte Dateien). Diese Check-Liste dient dazu, zu überprüfen, ob Sie im Verlauf der Datenrettung die richtige Auswahl in den verschiedenen Schritten der Software getroffen haben.

Es wird an dieser Stelle vorausgesetzt, dass Sie das Kapitel Vornahme einer Datenrettung bereits gelesen haben und die darin enthaltenen Hinweise befolgt haben. Sie sollten sich ebenfalls mit den Beschreibungen und Erklärungen in den Kapiteln zu Schritt 1, Schritt 2 und Schritt 3 vertraut gemacht haben.

Wenn die Resultate der Datenrettung nicht zufriedenstellend sind, überprüfen Sie bitte folgendes:

  1. Wählen Sie immer den Eintrag "Physikalische Laufwerke" in Schritt 1. Wählen Sie "Logische Laufwerke" nur wenn unbedingt notwendig, z.B. falls Ihr Laufwerk nicht unter "Physikalische Laufwerke" angezeigt wird.

  2. Überprüfen Sie, dass die Kapazität von z.B. "2. Physikalisches Laufwerk" (oder jenes Laufwerkes, von dem Sie die Daten retten möchten) wie sie in Schritt 1 angezeigt wird, der tatsächlichen Kapazität dieses Laufwerkes entspricht. Falls Sie hier keine Übereinstimmung haben, könnte der Grund in den BIOS-Einstellungen für dieses Laufwerk liegen.

  3. Top-Level-Eintrag vs. Partitions-Untereintrag:

    1. Falls die Festplatte eine Partition hatte, die das gesamte Laufwerk einnahm, wählen Sie den Top-Level-Eintrag (z.B. "2. Physikalisches Laufwerk") in Schritt 1, und ändern Sie nichts an den Bereichseinstellungen in Partieller Scan im Einführungsbildschirm.

    2. Falls die Festplatte mehrere Partitionen hatte, wählen Sie einen entsprechenden Partitions-Untereintrag in Schritt 1, aber NUR dann, wenn die Partitionseinträge angezeigt werden UND diese tatsächlich die Originalpartitionierung wiederspiegeln, die Sie wiederherstellen möchten.

      Sollten Sie jedoch eine neue Partitionsstruktur auf die Festplatte gespielt haben, und damit die vorherige überschrieben haben, ist es nicht sinnvoll einen Partitions-Untereintrag zu wählen. Wählen Sie in diesem Fall den Top-Level-Eintrag aus.

      Nur im letzteren Fall (wenn Sie z.B. die gesamte 40GB Festplatte auswählen und Sie WISSEN, dass es die erste Partition mit 20GB ist, die wiederhergestellt werden soll) macht es Sinn die Bereichseinstellungen in Schritt 1 zu ändern (in diesem Beispiel würde die Bereichseinstellung auf 0-44000000 gesetzt werden). Sie können jedoch immer auch den Top-Level-Eintrag wählen, dieses Vorgehen dauert nur u.U. etwas länger.

      BITTE BEACHTEN: DER EINGESTELLTE BEREICH SOLLTE IMMER GRÖSSER SEIN, ALS DIE PARTITION, DIE SIE RETTEN MÖCHTEN! (Aus diesem Grunde wurden im vorherigen Beispiel 44 anstelle von nur 40 Millionen eingestellt. Dadurch wird sichergestellt, dass die 20GB Partition -die tatsächlich auch 21GB umfasst haben mag- komplett innerhalb des eingestellten Bereiches liegt.

  4. In Schritt 2 nun müssen Sie denjenigen Eintrag wählen, der am BESTEN der Partition entspricht, die Sie retten möchten. Die Einträge, die Sie in Schritt 2 sehen, sind nicht notwendigerweise reale Dateisysteme, sie beschreiben eher MÖGLICHE Dateisysteme. Die weiter oben gelisteten Einträge sind dabei wahrscheinlicher korrekte Einträge als die weiter unten gelisteten. ABER: DIESE EINSCHÄTZUNG WURDE VON GETDATABACK VORGENOMMEN UND IST NICHT IMMER KORREKT. Wäre GetDataBack in der Lage, in jedem Fall den richtigen Eintrag zu identifizieren, wäre Schritt 2 - zumindest in Fällen mit nur einer Partition auf der Festplatte - überflüssig.

    Es ist UNBEDINGT notwendig, dass Sie in Schritt 2 die richtige Auswahl treffen, ansonsten werden Sie im Datenrettungsbaum in Schritt 3 nur unbrauchbare Ergebnisse haben. Ein Eintrag ist für eine zu rettende Partition immer nur richtig oder falsch.

    Normalerweise sollten Sie den ersten Eintrag auswählen. In Absatz 6. wird aber auch der Auswahlprozess beschrieben für die Fälle, in denen der erste Eintrag nicht der richtige ist.

  5. In Schritt 3 sollten Sie nun überprüfen, dass die geretteten Dateien brauchbar sind. Benutzen Sie hierzu den internen Dateibetrachter (F3) oder öffnen Sie die Dateien mit den ihnen zugeordneten Applikationen (doppel-klicken). Der hauptsächliche Zweck für diese Überprüfung ist, die Auswahl des richtigen Eintrags in Schritt 2 zu verifizieren. Nehmen Sie zur Überprüfung Dateien, die leicht zu checken sind, wie z.B. Textdateien, EXE-Dateien oder DLL-Dateien. EXE und DLL-Dateien sind leicht an ihrer vorangestellten "MZ" Signatur zu erkennen. WICHTIG FÜR NTFS: Die zur Überprüfung benutzten Dateien MÜSSEN größer als 2KB sein.

    Interpretation der Dateiüberprüfung: Falls viele überprüfte Dateien sich problemlos öffnen oder ansehen lassen, war die Auswahl in Schritt 2 korrekt. Falls jedoch keine Datei sich richtig öffnen oder ansehen lässt, war die Auswahl in Schritt 2 falsch und Sie müssen zu Schritt 2 zurückkehren und eine andere Auswahl treffen. Sollten Sie mit keinem in Schritt 2 angezeigten Dateisystemeintrag in Schritt 3 Erfolg haben, ist es empfehlenswert zu Schritt 1 zurückzugehen und "Exzessive Suche" in den Optionen anzuklicken. Dies wird zusätzliche Einträge in Schritt 2 erzeugen, die Sie dann testen können.

  6. Wie sollten Einträge in Schritt 2 bewertet werden?

    1. Ein Listeneintrag hat das folgende Format:

      <FILESYSTEM> at sector XXX, cluster size YYY (ZZZZ MB)

      Beispiel:

    NTFS at sector 63, cluster size 8 (20000MB)

    Prüfen Sie folgendes:

    1. Überprüfen Sie den Ort (bei Sektor 63 in obigem Bespiel). In den Fällen, in denen die erste Partition auf einem Laufwerk eine NTFS-Partition ist, fängt diese fast immer bei Sektor 63 an. Die dargestellte Zahl gibt den genauen Partitionsbeginn an. Sollte der angezeigte Ort nicht mit einer Abweichung von höchstens 5% (relativ zur Größe des Laufwerkes) mit dem soweit erinnerten Ort der gesuchten Partition übereinstimmen, ist dieser Dateisystemeintrag nicht korrekt.

    2. Die Angabe zur Cluster-Größe ist gewöhnlich nicht sehr hilfreich, da niemand sich an die Cluster-Grösse einer Partition erinnert, nachdem diese einmal formatiert wurde (siehe 6.d.).

    3. Verifizieren Sie die Größe (oben 20000 MB). Diese Zahl sollte annährend die Größe der verlorenen Partition wiedergeben, die Abweichung sollte nicht mehr als 10% betragen. Trifft dies nicht zu, ist der Eintrag als inkorrekt zu betrachten.

    Weitere Informationen liefern die "Dateisystemdetails" im rechten Fenster in Schritt 2:

    4. Dateisystem-Details in GetDataBack for NTFS:

      • Name: Der Dateisystem-Typ, immer NTFS.

      • Cluster0: Die Lage von Cluster 0 im Dateisystem.

      • Cluster-Größe: Die Anzahl der Sektoren in einem Cluster. Mögliche Werte sind: 1-128 Sektoren, übliche Werte sind 1-8.

      • Sektoren total: Die Gesamtzahl der Sektoren im Dateisystem.

      • 1. Mft-Cluster: Die Cluster-Nr. des Anfangs der Master File Table.

      • 1. MFtmirror Cluster: Die Cluster-Nr. des Anfangs der gespiegelten Master File Table.

      • Index-Puffer-Größe: Die Größe eines Index-Puffers. Ein Index-Puffer ist ein Bereich, in dem Verzeichnisinformationen gespeichert sind.

      • 1. Root-Cluster: Falls vorhanden: der Start-Cluster des Rootverzeichnisses (nur vorhanden für FAT32 Dateisysteme).

      • Cluster total: Die Gesamtzahl der Cluster in diesem Dateisystem.

      • Min Clusters benutzt: Der Mindest-Cluster-Bereich in dem Daten durch den Scan gefunden wurden.

      • Max Cluster benutzt: Der max. Cluster-Bereich in dem Daten durch den Scan gefunden wurden.

      • Datenübereinstimmungen: Die Anzahl der Übereinstimmungen von "Datei-Starts" mit "Mft-Starts". Diese Zahl legt die Sortierreihenfolge der Dateisystemliste in Schritt 2 fest. Je höher ihr Wert, desto höher ist die Anzahl der vermutlich rettbaren Dateien.

      • Debug-Info: B steht für gefundenen Boot Record, B1 z.B. bedeutet, dass wenigstens ein Boot Record gefunden wurde. M steht für gefundene MFTs, die folgende Zahl gibt die Anzahl der gefundenen MFT-Strukturen an.

      Untersuchen Sie folgendes:

    1. Überprüfen Sie den Wert der Cluster-Größe: Üblich sind nur Werte von 1-8.

    2. Überprüfen Sie den Wert der Datenübereinstimmungen: Er besagt, wieviele Dateien vermutlich mindestens gerettet werden können. Bei diesen Dateien handelt es sich um solche, für die sowohl ein Mft-Eintrag existiert, als auch ein entsprechender Ort auf der Festplatte gefunden wurde.

    3. Sehen Sie Sich das "Debug Info" an. Debug Info gibt Informationen dazu, weshalb GetDataBack diesen Eintrag aufgenommen hat. Drei verschiedene Methoden kommen zur Anwendung:

      • B1 oder B2- auf Grund eines oder zweier gefundener Boot Records

      • M1 oder M2- auf Grund einer oder zweier gefundenen MFT-Strukturen (Master File Table)

      • Cnnnn - auf Grund einer Übereinstimmung zwischen Dateianfangssignaturen und gefundenen Dateieinträgen

      Einträge mit C werden nur dann vorhanden sein, wenn Sie die "Exzessive Suche" benutzt haben.

      M und C Einträge sind manchmal zu einem Eintrag zusammengefasst, falls sie das selbe Dateisystem beschreiben (z. B. M1C8933). B Einträge werden nicht zusammengefasst. Dies ist der Grund, warum Einträge in den ersten beiden Reihen des öfteren doppelt erscheinen.

      B Einträge sind normalerweise die Zuverlässigsten. Sie können allerdings auch irreführend sein, besonders dann, wenn eine Festplatte formatiert worden war. O.g. Einträge sollten immer durch das Vorhandensein eines M Eintrages bestätigt werden. Wenn Sie wählen müssen zwischen zwei gleichwertig markierten Einträgen, einem B und einem M Eintrag, wählen Sie B.

      Ein M Eintrag ist der signifikanteste Eintrag, da er eine tatsächlich gefundene MFT wiederspiegelt.

      Ein C Eintrag - der nur vorhanden sein kann, wenn "Exzessive Suche" benutzt wurde- ist besonders hilfreich in Fällen, in denen nur wenig Verzeichnisinformationen oder aber keine oder nur unbrauchbare Boot Record-Informationen zur Verfügung stehen. Er kann auch für die Verifizierung oder den Ausschluss von B oder M Einträgen von Nutzen sein.

  6. Der "Bar Code" in rechten unteren Ecke kann weitere Informationen zu einem bestimmten Eintrag liefern. Je mehr die Streifen in den Reihen in Übereinstimmung sind, desto besser ist das Dateisystem. (ALLERDINGS, letztendlich gibt es bei der Auswahl jedes Dateisystemeintrags nur ein JA oder ein NEIN.)

    Dargestellt sind:

    • Mft-Starts: Der Cluster-Bereich, in dem MFT-Eintragsanfänge gefunden wurden.

    • Datei-Starts: Der Cluster-Bereich, in dem Dateianfänge gefunden wurden.

    Der Prozentsatz von übereinstimmenden Dateianfängen zu MFT-Anfängen ist rechts dieser Reihen angezeigt. Seien Sie aber nicht entmutigt, wenn dieser Wert nicht einmal annähernd 100% ist. Der Prozentsatz erreicht tatsächlich nie 100%. Dies ist dem Umstand geschuldet, dass GetDataBack einen sehr umfangreichen Scan des Laufwerkes vornimmt und in dessen Verlauf immer irgendwelche verwaisten Daten findet, die mit einem Datei- oder Verzeichnisanfang assoziiert werden könnten.

    Der Prozentsatz ist definiert als:

    100 * Matching_File_Starts / MFT_Starts

    wobei

    Matching_File_Starts die Anzahl der Sektoren ist, die als ein Dateianfang und als Sektor auf die ein MFT-Eintrag zeigt, identifiziert sind,

    MFT_Starts die Anzahl der Sektoren ist, auf die ein MFT-Eintrag zeigt.

    Es sind hierbei immer Dateianfänge vorhanden, die nicht identifiziert werden können, von da her wird der Wert von 100% fast nie erreicht. Vielmehr kann sogar trotz eines niedrigen Wertes von 30% eine perfekte Datenrettung erreicht werden.

  7. Weitere Möglichkeiten, die Qualität der Datenrettung zu verbessern:

  • Selektieren Sie in Optionen "Erlaube doppelte Dateinamen" in Schritt 2 oder früher. Hierdurch werden evt. vorhandene verschiedene Versionen einer Datei mit dem selben Dateinamen aufgelistet, die vorher möglicherweise nicht dargestellt wurden.

  • Wählen Sie die Option "Rette gelöschte Dateien" NUR dann, wenn Sie Dateien retten möchten, die vorher mit dem Windows Explorer oder durch Ausleeren des Papierkorbes gelöscht wurden. Diese Option muss in Schritt 2 oder früher angeklickt werden. Sollten Sie diese Option benutzen wollen, ist es empfehlenswert, auch "Erlaube doppelte Dateinamen" zu auszuwählen.

  • Ein Hinweis zu Fragmentierung: BEI NTFS DATENRETTUNG GIBT ES KEIN PROBLEM MIT FRAGMENTIERUNG. Daraus folgt, dass wenn eine Datei beschädigt ist, wurde diese entweder überschrieben oder es wurde ein falscher Eintrag in Schritt 2 gewählt.

Siehe auch: F.A.Q., Support, Vornahme einer Datenrettung


Snapshot

Schnappschuss

Der Schnappschuss fasst den Datenrettungsprozess für Support-Zwecke zusammen. Wichtige Einstellungen und Auswahlen während des Verlaufs der Datenrettung werden hierin dokumentiert. Der Schnappschuss ist eine Kurzform der Log-Datei, hat aber nur eine Größe von ein paar KB.

Um einen Schnappschuss zu erzeugen, durchlaufen Sie den Datenrettungsprozess bis zu Schritt 2 oder Schritt 3 und klicken dann Hilfe->Schnappschuss für Support. Sie werden dann gebeten, einen Dateinamen und den Ort, an dem diese Datei gespeichert werden soll, anzugeben. (Achtung: Geben Sie keinen Ort auf demjenigen Laufwerk an, welches Sie retten möchten!) Es ist eine gute Idee, einen Schnappschuss mitzusenden, wenn Sie uns eine Email für Support schicken.

Siehe auch: Log-Datei, Support


Show Data Structures

Zeige Datenstrukturen

Folgende Informationen hinsichtlich der Datenstruktur des im Datenrettungsbaum gezeigten Laufwerkes bzw. Partition stehen zur Verfügung:

  • Drive: Das Laufwerk/Gerät, auf dem die Datenrettung vorgenommen wurde.
  • Window info: Das Laufwerk/die Partition, die im Datenrettungsbaum dargestellt wird.
  • Entire drive: Gibt Aufschluss darüber, ob das gesamte Laufwerk gescannt wurde.
  • From sector: Start-Sektor des Laufwerkes/der Partition, die im Datenrettungsbaum darstellt wird.
  • To sector: Letzter Sektor des Laufwerkes/der Partition, die im Datenrettungsbaum darstellt wird.
  • File system: Dateisystem des geretteten Laufwerkes.
  • FileSystemDesc: Detaillierte Beschreibung des Dateisystems.
  • Excessive search: Gibt an, ob Exzessive Suche nach Dateisystemen in den Optionen angeklickt wurde.

Alle weiteren Informationen werden für Debug-Zwecke verwendet und sind daher nicht von großem Nutzen für den Benutzer.


Templates

Schablonen

Die Verwendung von Schablonen ist normalerweise nicht notwendig, da GetDataBack in der Lage sein sollte, das Dateisystem automatisch zu erkennen. In Ausnahmefällen - wie z.B. im Falle von Disketten, die nur einige wenige Dateien enthalten - kann die automatische Erkennung fehlschlagen, und die Verwendung einer Schablone kann nutzbringend sein.

Falls Sie die exakten Dateisystems-Parameter des zu rettenden Laufwerkes kennen, können Sie eine Schablone zur Unterstützung der Erkennung des Dateisystems zur Verfügung stellen.

Einige Schablonen (für 1.44 MB Diskettenlaufwerke und einige Jaz- und Zip-Laufwerke) sind in GetDataBack schon angelegt.

Um eine neue Schablone zu erstellen, öffnen Sie die Datei GDBNT.INI. Die Lage der GDBNT.INI ist in Hilfe->Versions-Info angegeben.

Gehen Sie zur Templates section (Schablonen-Sektion) der GDB.INI und geben Sie die Dateisystems-Parameter in der folgenden Reihenfolge ein (durch Komma getrennt):

  • Name der Schablone (freie Wahl)
  • Location (Lage) des Dateisystems (Sektor-Nr. des Boot Records)
  • File system (Dateisystem) (FAT12, 16 oder 32)
  • Anzahl der reserved sectors (reservierten Sektoren) (dieser Wert kann aus dem Boot Record ermittelt werden)
  • Cluster size (Cluster-Grösse) (dieser Wert kann aus dem Boot Record ermittelt werden)
  • Anzahl der total sectors (gesamten Sektoren) (dieser Wert kann aus dem Boot Record ermittelt werden)
  • FAT Length (FAT-Länge) (dieser Wert kann aus dem Boot Record ermittelt werden)
  • 1st root directory cluster (1. Root-Verzeichnis-Cluster) (dieser Wert kann aus dem Boot Record ermittelt werden), nur bei FAT32, für FAT12 oder 16 geben Sie 0 ein.
  • Number of root directory entries (Anzahl der Root-Verzeichnis-Einträge) (dieser Wert kann aus dem Boot Record ermittelt werden), nur bei FAT12 und 16, für FAT32 geben Sie 0 ein.

Beispiel:

1GB-Jaz mit Fat16 als physikalisches Laufwerk=32,16,1,32,2088928,255,0,512

Die Erstellung von Schablonen erfordert einige Erfahrung und einen guten Festplatten-Editor, wie z.B. Runtime's DiskExplorer.