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Preface

The Maple Software
The MapleTM software is a powerful system that you can use to solve complex
mathematical problems. You can also create professional quality documents,
presentations, and custom interactive computational tools in the Maple en-
vironment.

You can access the power of the Maple computational engine through a
variety of interfaces.

DescriptionInterface

Full-featured graphical user interface offering features
that help you create electronic documents that show all
your assumptions, the calculations, and any margin of
error in your results; or hide the computations to allow
your reader to focus on the problem setup and final res-
ults. The advanced formatting features help you create
the customized document you need. Because the docu-
ments are live, you can edit the parameters and, with the
click of a button, compute the new results.

The Getting Started Guide was created using the Stand-
ard Worksheet interface to Maple. An interactive version
of this manual is available in the Standard Worksheet
interface. From the Help menu, select Manuals, Diction-
ary, and more>Manuals>Getting Started Guide.

Standard Worksheet

Basic worksheet environment for older computers with
limited memory.

Classic Worksheet

Command-line interface, without graphical user inter-
faces features, for solving very large complex problems
or batch processing with scripts.

Command-line version

Graphical calculator interface to the Maple computational
engine. Using it, you can perform simple computations
and create customizable, zoomable graphs.

MaplesoftTM Graphing Calculator
(Microsoft® Windows® only)
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DescriptionInterface

Graphical user interface containing windows, textbox
regions, and other visual interfaces, which gives you
point-and-click access to the power of Maple. You can
perform calculations and plot functions without using
the worksheet or command-line interfaces.

MapletTM Applications

This manual describes how to use the Standard Worksheet interface. Not all
features are available in the Classic Worksheet interface and Command-line
version. The Standard Worksheet interface has two modes: Document mode
and Worksheet mode.

Document Mode - Using the Document mode, you can perform quick cal-
culations. You can enter a mathematical expression, and then evaluate, ma-
nipulate, solve, or plot with a few keystrokes or mouse clicks.

Worksheet Mode - The Worksheet mode is designed for:

• Interactive use through Maple commands, which may offer advanced
functionality or customized control not available using context menus
or other syntax-free methods

• Programmatic use of the powerful Maple language

Using either mode, you can create high quality interactive mathematical
presentations or documents.

In This Manual
This manual provides an introduction to the following Maple features.

• Worksheets and powerful interactive documents

• The help system

• Point-and-click interaction with various interfaces to help you solve
problems quickly

• Maple commands and standard math notation

• A road map for solving problems
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For a complete list of manuals, study guides, toolboxes, and other resources,
visit the Maplesoft Web site at http://www.maplesoft.com

Audience
The information in this manual is intended for first time Maple users.

Conventions
This manual uses the following typographical conventions.

• bold font - Maple command, package name, option name, dialog, menu,
and text field

• italics - new or important concept

• Note - additional information relevant to the section

• Important - information that must be read and followed

Customer Feedback
Maplesoft welcomes your feedback. For suggestions and comments related
to this and other manuals, contact doc@maplesoft.com

Preface   •   vii
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1  Introduction to Maple
Don't worry about your difficulties in Mathematics. I can assure you
mine are still greater.

~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating
the total cost of our purchases to the complex calculations used to construct
the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an access-
ible and complete form. That tool is Maple.

1.1  How Maple Helps You
With Maple you can create powerful interactive documents. You can visualize
and animate problems in two and three dimensions. You can solve complex
problems with simple point-and-click interfaces or easy-to-modify example
worksheets. You can also devise custom solutions using the Maple program-
ming language. While you work, you can document your process, providing
text descriptions.

1



Figure 1.1: Example Interactive Document in Maple
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Creating Interactive Documents

Maple allows you to create powerful documents for use as business and
education tools, technical reports, presentations, assignments, and handouts.

You can:

• Include instructions and equations beside your computations

• Integrate calculations, spreadsheets, and equations

• Format text for reports, academic papers, or books

• Insert hyperlinks to other files, Web sites, or email addresses

• Insert images, spreadsheets, tables, and symbols

• Embed graphical user interface components

• Generate two- and three-dimensional plots and animations

• Sketch ideas in the worksheet

• Copy, cut, and paste information

• Bookmark specific areas

• Insert symbols from over 20 palettes

• Easily update, revise, and distribute your documents

Exploring or Visualizing Problems

Maple has many tools to help you examine and demonstrate concepts.

You can:

• Solve problems using point-and-click tutors, assistants, and Maplet ap-
plications

• Create plots and animations in two and three dimensions

• Right-click (Control-click, for Macintosh) to export, convert, manipulate,
plot, and more, using context menus
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Computing Numeric and Symbolic Solutions

Maple is an analytic computation system. It performs mathematical compu-
tations and manipulations to solve problems from various technical discip-
lines. Maple computes both numeric and symbolic solutions to mathemat-
ical problems. For example, Maple performs computations on expressions
that contain symbols, such as π, and returns exact symbolic results.

You can:

• Instantly simplify large equation sets

• Derive sophisticated equations

• Compute parametric solutions to problems

• Use precision control for maximum accuracy

• Include units, measurement of error, and tolerance management within
an expression and perform calculations on this expression

• Process large datasets for industrial, engineering, and research applica-
tions

Solving a Problem

When solving a problem, you can:

• Select the best resource to quickly find the solution or the right guidelines
to a step-by-step process

• Document the solution as you work through the problem
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Figure 1.2: A Selection of Maple Resources for Solving Problems
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Accessing Resources

Your work with the Maple program is supported by numerous resources.

DescriptionTutors, Assistants, Task Templates,
and Maple Calculator

Over 40 interactive tutors help beginner users
gain insight and understanding of topics in precal-
culus, calculus, multivariate calculus, vector cal-
culus, and linear algebra courses. Some tutors
help you work through a problem step-by-step.

• From the Tools menu, select Tutors, and
then one of the topic submenus.

Tutors

Assistants help you accomplish many tasks, such
as solving ODEs and ODE systems, creating plots
and matrices, and supporting curve fitting.

• From the Tools menu, select Assistants, and
then one of the topic submenus.

Assistants
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DescriptionTutors, Assistants, Task Templates,
and Maple Calculator

Tasks show the steps required to solve a problem.
Each template is a collection of Maple worksheet
content, such as 2-D Math, embedded compon-
ents, commands, and plots that you can insert
into your worksheet.

• From the Tools menu, select Tasks, and then
Browse.

Task Templates

Available for use as part of your Maple installa-
tion. A convenient calculator (interface) using
Maple technology.

Microsoft Windows (only)

From the Start menu, select Maple, and then
Maple Calculator.

Maplesoft Graphing Calculator
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DescriptionOnline Help and Examples

The online help system helps you find inform-
ation about a specific topic, command, pack-
age, or feature. You can access help three
ways.

• From the Help menu, select Maple Help.

• In the toolbar, click the Help icon.

• In the worksheet, enter ?topicname. For
example, type ?LinearAlgebra, and then
press Enter.

Help Pages

More than 5000 mathematical and engineering
terms, and over 300 figures and plots.

1. From the Help menu, select Maple Help.

2. In Resources drop-down list, select Defin-
ition.

3. Enter search word or expand alphabetical
listing.

Dictionary
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DescriptionOnline Help and Examples

Applications

Sample applications demonstrate how Maple
can be used to find and document a solution
to a specific problem. Some applications allow
for input or contain animations that you can
run; however, their primary use is as demon-
strations. Topics include:

• DC Motor Control Design

• Digital Filter Design

• Frequency Domain System Identification

• Harmonic Oscillator

• Mathematical Model to Simulation Code

• Mobile Robot, Mobile Robot Modeling
and Simulation

• Black-Scholes Model

• Signal Generation

Example Worksheets

Embedded, executable worksheets covering
topics that demonstrate syntax or invoke
Maplet applications make complex problems
easy to solve and visualize. You can copy and
modify the examples as needed.

Topics include: Algebra, Applications (Fin-
ance, Scientific Constants, Scientific Error
Analysis), Calculus, Connectivity (Code
Generation, External Calling), Differential
Equations, Discrete Mathematics, General
Numerics, General Symbolics, Geometry, In-
tegration, Integral Transforms, Language and
System, and Mathematical Visualizations.

From the Help menu, select Manuals, Diction-
ary, and more and then Applications and
Examples.

Applications and Example Worksheets
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DescriptionTour and New User Roadmap

The Maple Tour consists of interactive ses-
sions on the following topics:

• Ten Minute Tour

• Numeric and Symbolic Computations

• Matrix Computations

• Differential Equations

• Special Functions

• Optimization

• Statistics

• Programming and Code Generation

• Dictionary of Math and Engineering
Terms

• Units and Tolerances

• Education Assessment, Maple T.A.

• OpenMaple

• Maplets and MapleNet

From the Help menu, select Take a Tour of
Maple.

Tour
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DescriptionTour and New User Roadmap

Find the most efficient path to solving a
problem immediately or learning principles
and reviewing major features.

• From the Help menu, select Manuals,
Dictionary, and more, and then New
User Roadmap.

New User Roadmap
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DescriptionWeb Site Resources

Maple Web site and resource for FAQs,
downloads and service packs, links to discus-
sion groups, and request technical support
form.

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
Customer Support, and then Support and
Customer Service.

Technical Support (Online)

Maple Web site resource for free applications
related to mathematics, education, science,
engineering, computer science, statistics and
data analysis, finance, communications,
graphics. Many applications are available in
translation (French, Spanish, and German).

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
User Community, and then Application
Center.

Application Center

Maple Web site resource for free complete
course curricula and add-on Maple packages
and courses, developed by experts in their
fields to help users configure Maple for re-
search in specific application areas.

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
User Community, and then Application
Center.

3. In the sidebar of the Web page, click Re-
search Powertools or Education Powertools.

PowerTools
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DescriptionWeb Site Resources

Maple Web site of productivity tools for en-
gineers and scientists, online seminars and
training, subscription information on the Ex-
tended Maintenance Plan (EMP), and other
resources.

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
Site Resources, Welcome Center, and then
the Corporate and Government link in the
body of the Web page.

Corporate and Government

Maple Web site of productivity tools for en-
gineers, scientists, and applied mathem-
aticians. Covers the following application
areas: finance, signal processing and commu-
nication, optimization, electronics, chemical
and mechanical systems, control systems
design, and biotech and pharmaceutical fields.

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
Site Resources, Welcome Center, and then
the Corporate and Government link in the
body of the Web page.

3. In the sidebar of the Web page, click the
Industry and Government.

Industry and Government
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DescriptionWeb Site Resources

Maple Web site of Maple tutorials and
graphics, help with classes, student FAQs,
instructor pages, applications by students, the
newest release of Maple, and Maple books.

1. Go to http://www.maplesoft.com.

2. In the menu of the main Web page, click
Product and Solutions, and then For Stu-
dents.

Products and Solutions for Students
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2  Maple Tools and Resources
In this chapter:

Launching the program and the user interface

Note: For installation and licensing instructions, refer
to the Install.html file on your Maple Installation CD.

Starting Maple

Accessing help pages and other resourcesMaple Help System

Accessing various interfaces designed to help you solve
problems quickly

Point-and-Click Interaction

Using Maple commands and languageCommands

Interpreting formatting featuresWorksheet Formatting Fea-
tures

Using the (blank sheet) Maple Document environment
for quickly solving problems

Working in Document Mode

This guide was created using Maple.

2.1  Starting Maple
In this section:

• Starting the Standard Worksheet Interface

• The Maple Worksheet

• Basics
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Starting the Standard Worksheet Interface

To start the Standard Worksheet interface in:

• From the Start menu, select Programs, Maple, Maple.

Alternatively:

• Double-click the Maple desktop icon.

Windows

• Double-click the Maple application icon in the Finder.Macintosh®

• Enter the full path, for example, /usr/local/maple/bin/xmaple

Alternatively:

1. Add your Maple directory (for example, /usr/local/maple/bin) to your
command search path.

2. Enter xmaple.

UNIX®

The Maple Worksheet

You can access the power of the Maple computation engine through a variety
of user interfaces.

• Standard Worksheet

• Command-line version

• Classic Worksheet

• Custom-built Maplet applications

• Calculator interface (Windows only)

In this guide, references to the graphical Maple interface refer to the Standard
Worksheet interface. For more information on the various interface options,
refer to the ?versions help page.

The first Maple session opens with the Startup dialog, explaining the differ-
ence between Document mode and Worksheet mode. The dialog contains
links to items, such as various document options, help resources including
updates and other introductory help pages, and application resources on the
Web. Subsequent sessions display Tip of the Day information.
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• Document mode allows you to start solving problems right away, without
needing syntax or Maple commands.

• Worksheet mode is the most familiar mode to users of previous versions
of Maple. You enter commands at an input prompt to get results.

Basics

Maple documents are saved as .mw files. They consist of files created in
Worksheet or Document mode.

To start a Maple session:

• In the Startup dialog, select one of the document options: Blank Docu-
ment, Blank Worksheet, Template, or Open a File.

or

1. Close the Startup dialog.

2. From the File menu, select New, and then one of the following: Worksheet
Mode, Document Mode, or Templates.

• This guide discusses features common to Worksheet and Document
mode. For information on Templates, see Task Templates (page 31). In-
structions for using Document mode are provided in the last section,
Working in Document Mode (page 58).

• In subsequent sessions, Maple starts in Document mode. Every time you
open a Document, Maple displays a Quick Help pop-up list of important
shortcut keys. To invoke Quick Help at any time, press the F1 key.

Important: This guide was created using Maple.
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Figure 2.1: The Maple Standard Worksheet Interface in Worksheet Mode

2.2  The Maple Help System
The Maple program provides a custom help system consisting of almost
5000 reference pages. The help system is a convenient resource for determ-
ining the syntax of Maple commands and for learning about Maple features.

In this section:

• Accessing the Help System

• Using the Help Navigator

• Viewing Help Pages as Worksheets

• Copying Examples
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Accessing the Help System

To access the Maple help system:

• From the Help menu in your worksheet, select Maple Help.

or

• In the worksheet, enter ?HelpOverview.

The Maple help system opens in a separate window. The window has two
panes. The left pane contains the Help Navigator where you initiate searches,
and the right pane displays the final search result, such as a specific help
page.

Figure 2.2: Example Help Page
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Using the Help Navigator
The Help Navigator contains a field for topic or text-based searches.

• Topic searches reveal a list of matching topics sorted by exactness of
match.

• Text searches reveal a list of topics based on keyword frequency.

• You can search all or specific Resources such as Help Pages, Tasks,
definitions in the Maple Math and Engineering Dictionary, Tutorials,
and Manuals.

• Search results are displayed as a list in the Search Results tab of the left
pane. Click the Table of Contents tab to view a structured list of all
topics in the help system.

• A folder icon in the Table of Contents tab indicates that a topic can be
expanded into subtopics.

• Clicking a topic preceded by a question mark icon displays the associated
help page in the right pane.

To display potential matches in the right pane, click a topic preceded by an
icon.

Question mark icon indicates a help page.

WS icon indicates an example worksheet. Example worksheets open in a new
tab in the worksheet window.

D icon indicates a Definition.

T icon indicates a Task template.

M icon indicates a Manual. Manuals open in a new tab in the worksheet win-
dow.
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Viewing Help Pages as Worksheets

In help pages, examples are not executable.

The Maple help system allows you to open help pages as worksheets that
you can execute.

To open a help page as a worksheet:

• With the help page displayed in the right pane of the help system, from
the View menu, select Open Page as Worksheet. A new worksheet
window opens.

Alternatively, in the help system toolbar,
click the open current help page in a work-
sheet window icon.

Copying Examples

Instead of opening the entire page as a worksheet, you can copy the Examples
section to a worksheet.

To copy examples:

1. With the help page displayed in the right pane of the help system, from
the Edit menu, select Copy Examples.

2. Close or minimize the Help Navigator and return to your worksheet.

3. In your worksheet, place the cursor at the location where the examples
are to be pasted.

4. From the Edit menu, select Paste. The Examples section of the help page
is now executable content in your worksheet.
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2.3  Point-and-Click Interaction
Maple contains many built-in features that allow you to solve problems
quickly without learning new commands.

In this section:

• Assistants

• Tutors

• Context Menus

• Task Templates

• Palettes

• Maplet Applications

Assistants

Using the Tools>Assistants menu, you can access tools to help you accom-
plish various tasks.

Figure 2.3: Accessing the Assistants from the Tools Menu
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The Assistants are graphical user interfaces to various routines.

• Back-Solver - a worksheet that allows you to take a mathematical for-
mula, which involves multiple parameters, enter values for all but one
of the parameters and solve for the remaining one. You can also produce
a graph that shows the behavior of the formula as one of the parameters
varies.

• Curve Fitting - a graphical user interface to commands in the CurveFit-
ting package. Data points can be entered as independent and dependent
values.

• Data Analysis - a graphical user interface to the data analysis commands
in the Statistics package.

• Import Data - a graphical user interface to read data from an external
file into Maple. Output is a Maple Matrix.

• Installer Builder - a graphical user interface to the InstallerBuilder
package in which you can create installers for your Maple toolboxes.
For information on toolboxes, go to http://www.maplesoft.com.

• Library Browser - a graphical user interface to manipulate the libraries
in a specified directory.

• Maplet Builder - a graphical user interface to the Maplets package. The
Maplets package contains commands for creating and displaying Maplet
applications (point-and-click interfaces). For a definition of Maplets, see
Maplet Applications (page 39). Using the Maplet Builder, you can define
the layout of a Maplet, drag-and-drop elements (visual and functional
components of Maplets), set actions associated with elements, and directly
run a Maplet application. The Maplet Builder is available only in the
Standard Worksheet interface.

• ODE Analyzer - a graphical user interface to obtain numeric or symbolic
solutions to a single ODE or a system of ODEs. You can also plot the
solution.

• Optimization - a graphical user interface to the solver commands in the
Optimization package. The Optimization package is a collection of
commands for numerically solving optimization problems, which involve

2.3  Point-and-Click Interaction   •   23
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finding the minimum or maximum of an objective function possibly
subject to constraints. You can select one of the methods shown in the
interface to obtain a minimum (or maximum) of an objective function
under the given constraints. When you click the Solve button, the problem
(the objective function, constraints, bounds, and options) is solved using
the indicated method, and the solution is provided in the Solution area
of the Maplet application. When a solution is obtained, clicking the Plot
button displays a plot of the objective function in the region of the solu-
tion or, if the problem is bounded, a plot of the objective function over
the search region.

• Plot Builder - a graphical user interface for creating plots, animations,
and interactive plots with sliders in two and three dimensions.

• Scientific Constants - an interface to the Maple database of scientific
constants with over 20000 values of physical constants and properties
of chemical elements. All of these constants come with the corresponding
unit and, if applicable, with the uncertainty or error, that is, how precisely
we know the value of this constant.

• Special Functions - an interface to the Maple database of the properties
of over 200 special functions, including the Hypergeometric, Bessel,
Mathieu, Heun and Legendre families of functions.

• Units Calculator - a worksheet that allows you to convert between 500
units of measurement.
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Figure 2.4: Assistant Example: Curve Fitting
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Tutors

Using the Tools>Tutors menu, you can access over 40 interactive tutors
that aid in the learning of precalculus, calculus, multivariate calculus, vector
calculus, and linear algebra concepts.

Figure 2.5: Accessing Tutors from the Tools Menu

The Tutors are also accessed through the Student package. For a definition
of the term package, see Commands (page 40).

The Student package is a collection of subpackages designed to assist with
the teaching and learning of standard undergraduate mathematics. The sub-
packages contain many commands for displaying functions, computations,
and theorems in various ways, and support for stepping through important
computations.

• The visualization commands are tools that create plots and animations
showing the geometric interpretation of important concepts.

• The computation commands help you study the techniques of computa-
tion while solving problems. For example, using the Calculus1 package,
you can differentiate a function one step at a time, specifying the differ-
entiation rule applied at each step. At any time during a single-step
computation, you can request a hint about the next step, which you can
then apply to the problem, or proceed directly to the final answer.
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• The interactive commands use Maplet technology to help you explore
concepts and solve problems using a point-and-click interface. These
commands launch tutors that provide a graphical interface to visualization
and computation commands.

Figure 2.6: Tutor Example: Calculus 1 - Curve Analysis

Context Menus

Maple dynamically generates a context menu when you right-click (for
Macintosh, Control-click) an object or expression. The actions available on
the context menu depend on the properties of the object or expression. For
example, you can manipulate and graph expressions, enhance plots, and
format text.
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Example Context Menus

Figure 2.7:  Right-click (Control-click) Expressions
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Figure 2.8: Right-click (Control-click) Expressions to Graph Results
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Figure 2.9: Right-click (Control-click) Plots to Change Display Options

Figure 2.10:  Right-click (Control-click) Text
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Task Templates

Task templates help you perform a specific task in Maple, such as:

• Performing a mathematical computation, for example, solving an equation
symbolically or numerically, or determining the Taylor approximation
of a function of one variable

• Constructing a Maple object, for example, a function

• Creating a document, for example, an application

The tasks are organized in the help system by subject, to help you quickly
find the appropriate task. Each task is a collection of Maple worksheet con-
tent, such as 2-D mathematics, commands, embedded components (for ex-
ample, buttons) and plots that you can directly insert into your worksheet.
You specify the parameters of your problem, and then run the worksheet.
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Figure 2.11 Browse Tasks Dialog

Previewing Tasks

Maple tasks can be previewed in three ways.

• From the Tools menu, select Tasks, and then Browse. The Browse
Tasks dialog opens and displays the list of tasks.

• From the Help menu, select Manuals, Dictionary, and more, and then
Tasks. The Help Navigator opens. In the left pane, click the Tasks folder
to displays the list of tasks.

• From the File menu, select New, and then Templates. The Browse Tasks
dialog opens and displays the list of tasks.
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The tasks are sorted by subject to help you quickly find the desired task. In
the Browse Tasks dialog or Help Navigator, you can view tasks without
inserting them into your worksheet.

Inserting a Task into the Worksheet

From both the Browse Tasks dialog and the Help Navigator, you can insert
a task into a worksheet.

1. Select the Insert into New Worksheet check box.

2. Click Insert Default Content or Insert Minimal Content.

• Default content includes the task title and description.

• Minimal content inserts only the major components (commands and
buttons).

Note: You can view the history of previously inserted tasks. From the Tools
menu, select Tasks.  Previously selected task names are displayed below
the Browse menu item.

Before inserting a task, Maple checks whether the task variables have as-
signed values in your worksheet. If any task variable is assigned, the Task
Variables dialog opens to allow you to modify the names. Maple uses the
edited variable names for all variable instances in the inserted task.

By default, the Task Variables dialog is displayed only if there is a naming
conflict. You can set it to display every time you insert a task.

To specify that the Task Variables dialog be displayed every time you
insert a task:

1. From the Tools menu, select Options.

2. Click the Display tab.

3. In the Show task variables on insert drop-down list, select Always.

4. Click Apply to Session, or Apply Globally, as necessary.
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Updating Parameters and Running the Commands

In tasks, parameters are marked as placeholders or specified using sliders or
other embedded components. Update the parameter values as required.

Note: To navigate between placeholders in the worksheet, press the Tab
key.

After updating any parameters, perform the task by running the commands
or by clicking buttons.

Palettes

The Maple worksheet environment provides access to over 20 palettes.
Palettes are collections of related items that you can insert by clicking or
drag-and-dropping into a document. Palettes contain:

• Symbols, like π, ∞, ∇

• Layouts, like an item with a superscript and subscript

• Mathematical operations, like a definite integral with placeholders for
the integrand, variable of integration, and endpoints of the interval of
integration

You can create a Favorites palette of the expressions and entities you use
often.

The Handwriting palette provides an efficient way to find and insert the
desired symbol. You draw the symbol with your mouse and then Maple
matches your input against symbols available in the system.
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Figure 2.12: Handwriting Palette

By default, palettes are displayed when you launch Maple.

To view palettes:

1. From the View menu, select Palettes.

2. Select Expand Docks.

3. Right-click (Control-click, for Macintosh) the palette dock. From the
context menu, select Show All Palettes.

Alternatively, from the main menu, select View>Palettes>Arrange Palettes
to display specific palettes.

Important: This section provides an overview of the palettes. For instructions
on using palettes with Maple Input (1-D Math) and Standard Math (2-D
Math) Input notation, see Commands (page 40).
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Expression Palettes

• Expression - a palette for constructing expressions such as integrals and
derivatives.

• Matrix - a palette consisting of a dialog that allows you to enter the
number of rows and columns required, designate type, such as zero-filled,
and designate shape, such as diagonal. See Figure 2.14.

• Layout - a palette that allows you to add math content that has specific
layout, such as expressions with one or more superscripts and subscripts.

• Components - a palette that allows you to embed simple graphical inter-
face components, for example, a button, into your worksheet. You can
associate actions with components, for example, a command that is ex-
ecuted when a button is clicked.

• Handwriting - a palette that provides an efficient way to find and insert
the desired symbol. Draw the symbol with your mouse and Maple
matches your input against symbols available in the system.

• Units (SI) - a palette that inserts a unit from the International System of
Units (SI), or any general unit. For details, refer to the ?Units/SI help
page.

• Units (FPS) - a palette that inserts a unit from the Foot-Pound-Second
System (FPS), or any general unit. For details, refer to the ?Units/FPS
help page.
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Figure 2.13: Matrix Palette

Mathematical Palettes

• Common Symbols- a palette of common symbols for constructing ex-
pressions using sums, products, and π among other things. See Figure
2.15.

• Relation Standard - a palette of standard relational operator symbols
for constructing expressions.

• Operators - a palette of operators for constructing expressions.

• Relational Round - a palette of round relational operator symbols for
constructing expressions.

• Large Operators - a palette of large operators for constructing expres-
sions.

• Negated - a palette of negation symbols for constructing expressions.

• Fenced - a palette of fenced symbols for constructing expressions.

• Arrows - a palette of arrow symbols for constructing expressions.

• Constants and Symbols - a palette of constants and symbols for con-
structing expressions.

• Punctuation - a palette of various punctuation symbols, such as the re-
gistered trademark and copyright symbols, for inserting into text regions.
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• Miscellaneous - a palette of miscellaneous math and other symbols
outside the above categories.

Figure 2.14: Common Symbols Palette

Alphabetical Palettes

• Roman Extended Upper Case, Roman Extended Lower Case, Diacritical
Marks, Greek (Figure 2.15), Cyrillic, Script, Open Face, and Fraktur.

Note: Use the Roman Extended Upper Case and Lower Case palettes for
accents, such as grave or umlaut.

Figure 2.15: Greek Alphabet Palette
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Placeholders and the Tab Key

As an illustration, click the exponent button in the Expression palette. The
expression is displayed with the first placeholder highlighted. To move to
the next placeholder, use the Tab key.

The Tab icon in the toolbar allows you to set the Tab key to move between
placeholders or to indent.

Tab icon off. Allows you to move between placeholders using the Tab key.

The Tab icon is disabled when using 2-D Math (Math mode), and as such,
the Tab key allows you to move between placeholders. For details about
2-D Math, see Commands (page 40) .

Tab icon on. Allows you to indent in the worksheet using the Tab key.

Maplet Applications

A Maplet application is a graphical user interface containing windows,
textbox regions, and other visual interfaces, which gives you point-and-click
access to the power of Maple. You can perform calculations, plot functions,
or display dialogs without using the worksheet interface.

The following simple Maplet contains a textbox region, a button, and a label
prompting you to enter an equation.

Figure 2.16: Maplet Application Example

You can create custom Maplets using the Maplets package (syntax-based)
or the Maplet Builder (a graphical user interface tool). For details, refer to
the Maple User Manual.
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2.4  Commands
Maple is powerful, flexible, and customizable. In addition to the point-and-
click features, Maple contains a set of commands and a programming lan-
guage.

In this section:

• The Maple Library

• Commands in the Worksheet

• 2-D Math Input

• Maple Input (1-D Math Input)

• Learning about Commands and Packages

• Using Examples to Learn About Commands

• Equation Labels

The Maple Library

Commands are contained in the Maple library, which is divided into two
groups: the main library and packages.

• The main library contains the most frequently used Maple commands.

• Packages contain related specialized commands for performing tasks
from disciplines such as Student Calculus, Statistics, or General Relativity
Theory.

Commands in the Worksheet

In Worksheet mode, a new worksheet opens with a Maple prompt in the
upper left-hand corner. Enter Maple commands at this prompt for Maple to
recognize your entry as Maple Input (1-D Math) or 2-D Math and execute
the command.
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DescriptionBasic Usage

> Maple prompt

• In the toolbar, click the !!! icon.

• From the Edit menu, select Execute>Worksheet.

Running the entire worksheet
(executing all commands)

Place the cursor in any Maple input region in the execution
group and press the Enter key.

Executing one command

• In the toolbar, click the ! icon.

• From the Edit menu, select Execute>Selection.

Executing selected area

Statement separator. Terminate a 1-D or 2-D command
with a semicolon ; and output is displayed.

Important: All 1-D commands must terminate with a
semicolon or colon.

Semicolon

Statement separator. Terminate a 1-D or 2-D command
with a colon : and output is not displayed.

Important: All 1-D commands must terminate with a
semicolon or colon.

Colon

The restart command causes Maple to clear its internal
memory.

Alternatively, in the toolbar, click the restart icon.

For specific details, refer to the Maple User Manual.

restart;
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DescriptionBasic Usage

Default setting. Executable standard math nota-
tion. Displayed in a format similar to that found
in business and education documents.

> 

Access from the Insert>2-D Math menu.

To switch between 1-D and 2-D Math, press the
F5 key.

When using 2-D Math, the Math mode
icon is highlighted in the toolbar.

2-D Math

Executable Maple notation. Usually an expres-
sion that Maple can evaluate.

> factor(x^2 + 2*x + 1);

Access from the Insert>Maple Input menu.

To switch between 1-D and 2-D Math , press the
F5 key.

When entering Maple Input or text in a
text region, the Text mode icon is highlighted
in the toolbar.

Maple Input (1-D Math)
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2-D Math

The default 2-D Math feature allows you to enter content in standard math
notation.

> 

> 

Tip:  Use the ^ key, that is x^2, to enter . Use the right

arrow key to leave the exponent.

Basic Maple Functions:

The following are examples of basic Maple functions.

> 

> 

> 

> 

2.4  Commands   •   43



To use a palette with 2-D Math:

1. Ensure the palette you require is visible. If necessary, from the View menu,
select Palettes, and then Arrange Palettes.

2. Ensure that you are in Math mode. If necessary, press F5 to switch
between 1-D Math (Text mode) and 2-D Math (Math mode).

3. With your mouse, click a palette expression. The expression is displayed
in 2-D Math notation in the execution group of the worksheet.

4. The first placeholder is highlighted. Enter your expression, and if neces-
sary, use the Tab key to move to the next placeholder.

5. Press Enter.

Why Use Palettes in 2-D Math?

• If you are a new Maple user, palettes make entering expressions easier
than entering syntax and reduce the possibility of introducing typing er-
rors.

• Your worksheet uses standard notation for mathematical content.

In the following figure, compare the 2-D and 1-D Math input.
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You can control the appearance of expressions in the worksheet. You can
convert 2-D Math to 1-D Math.

1. Enter an expression in 2-D Math notation.

2. Select the expression and then right-click (Control-click, Macintosh) to
open the context menu.

3. Select 2-D Math, Convert To, and then 1-D Math Input. The expression
is displayed in 1-D Math input notation.

4. Press Enter to evaluate the expression.

You can change the default math input notation for your Maple session for
future use.

To change math input notation for a session or globally:

1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select 2-D Math Notation.

4. Click the Apply to Session or Apply Globally button.

Important: The selected input display becomes available after the current
execution group.
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Figure 2.17: Options Dialog: Input Display

Maple Input (1-D Math)

Important: With Maple Input, you must terminate commands with a semi-
colon or colon.

restart;>

Enter the Maple input followed by a semicolon. If the input ends with a
semicolon, the result is usually displayed, as seen below.

factor(x^2 + 2*x + 1);>
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However, if the input ends with a colon, the result is computed but the result
is not displayed.

factor(x^2 + 2*x + 1):>

Define custom functions.

f := x -> x * 2;>

f(3);>

f(y + 1);>

Basic Computations:

The following are examples of basic computations using Maple Input (1-D
Math).

cos(alpha)^2+sin(alpha)^2;>

a*x^2+b*x=c;>
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a*int(exp(sqrt(2)*x),x);>

restart;>

limit(f(x),x=infinity);>

sum(a[k]*x^k, k=0..m)=product(b[j]*x^j, j=0..n);>

To use a palette with 1-D Math Input:

1. Ensure the palette you require is visible. If necessary, from the View menu,
select Arrange Palettes.

2. Ensure that you are in Text mode. If necessary, press F5 to switch between
1-D Math (Text mode) and 2-D Math (Math mode).

3. With your mouse, click a palette expression. The expression is displayed
in 1-D Math notation in the execution group of the worksheet.

4. The first placeholder is highlighted. Enter your expression, and if necessary
use the Tab key to move to the next placeholder.

Important: Ensure that your Tab key is set to move to the next placeholder
and not indent. For details, see Placeholders and the Tab Key (page 39).

5. Press Enter.
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Why Use Palettes in 1-D Math?

• Using a palette that uses standard notation, teaches you the related Maple
command syntax.

You can control the appearance of expressions in the worksheet. You can
convert 1-D Math to 2-D Math.

To convert 1-D to 2-D math input:

1. Enter an expression in 1-D Math notation.

2. Select the expression and then right-click (Control-click, Macintosh) to
open the context menu.

3. Select Convert To, and then 2-D Math Input. The expression is displayed
in 2-D Math input notation.

4. Press Enter to evaluate the expression.

Figure 2.18: 1-D Math Input Converted to 2-D Math Input
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Learning About Commands and Packages

Each help page contains the correct syntax for a command: calling sequences,
parameters, and description of use. Examples and links to related subjects
are provided at the bottom of each help page. Many topics include more ex-
amples, which are presented in example worksheets.

To view a list of top-level commands:

1. From the Help menu, select Manuals, Dictionary, and more.

2. Select List of Commands.

A Maple package is a group of related commands. For example, the Optim-
ization package contains commands for numerically solving optimization
problems.

To view a list of packages:

1. From the Help menu, select Manuals, Dictionary, and more.

2. Select List of Packages.

To use a package command, specify both the package and command names
using the syntax package[command](arguments).

If you are using a number of commands in the package, load the package
using the with command.

To load a package:

• At the Maple prompt, enter the with command, followed by the package
name enclosed in parentheses and terminated with a semicolon (1-D
Math input). Then press Enter.
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Using the with command to load the Optimization package

A list of all commands in the package is
displayed. To suppress the display of all
command names, end the with(Optimiz-
ation) command with a colon.

> with(Optimization):

After loading a package, you can use the
short-form names, that is, the command
names, without the package name.

> LSSolve([x-2,x-6,x-9]):

Automatic Command Completion

By default, automatic command completion is enabled. If it is not enabled,
from the main menu, select Tools>Options>Interface tab. Select the
Automatic command completion check box.

1. Begin entering a command in the worksheet. Maple compares your entry
with Maple packages, commands, functions, and other assigned names. If
the entered text has a unique completion, a tool tip containing the matching
command name is displayed above the entry.

2. You can continue typing the command or press Enter to insert the com-
mand.

To disable automatic command completion:

• From the main menu, select Tools>Options>Interface tab. Clear the
Automatic command completion check box.
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Manual Command Completion

Manual command completion is always enabled.

To use manual command completion:

1. Begin entering a command in the worksheet.

2. To list all Maple packages, commands, and functions that match the entered
text, select Tools>Complete Command or use short cut keys.

• Escape, Macintosh

• Ctrl + Space, Windows

• Ctrl + Shift + Space, UNIX

If there is a unique completion, it is inserted. Otherwise, a list of matches is
displayed.

3. Select the correct completion from the list.
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Using Examples to Learn about Commands

Most help pages contain examples you can copy and run in the worksheet.
However, some topics also provide example worksheets that demonstrate
the power of Maple commands. You can use the example worksheets to
learn how commands and options behave.

To access example worksheets:

• In the worksheet, enter ?examples/index. The Index  to Example
Worksheets opens.

Topics presented include:

• Algebra

• Applications (finance, scientific constants, scientific error analysis)

• Calculus

• Connectivity (code generation, external calling)

• Differential Equations

• Discrete Mathematics

• General Numerics

• General Symbolics

• Geometry

• Integration

• Integral Transforms

• Language and System

• Mathematical Visualizations
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Figure 2.19: Example Worksheet

Note: You can also use the Help menu to access Applications—sample
applications that demonstrate how Maple can be used to find and document
a solution to a specific problem.

To access Applications from the Help menu:

• From the Help menu, select Manuals, Dictionary, and more, and then
Applications and Examples. The Applications and Examples help
page opens.

Equation Labels

Equation labeling allows you to reference Maple output in text and math of
your worksheet. The label is associated with all output within an execution
group. You cannot apply equation labels to the following.

• Error, warning, and information messages

• Tables, images, plots, sketches, or spreadsheets
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By default, equation labels are displayed. If equation labels are not displayed,
verify the following.

• From the Tools menu, select Options, and click the Display tab. Ensure
that the Show equation labels check box is selected.

• From the Format menu, select Labels. Ensure that Worksheet is selec-
ted.

Figure 2.20 Inserting an Equation Label

Figure 2.21: Equation Label

To apply equation labels:

1. Enter an expression and press Enter. Note that the equation label is dis-
played to the right of the answer in the worksheet.

2. In a new execution group, enter another expression that will reference the
output of the previous execution group.
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3. From the Insert menu, select Label. Enter the label number in the Insert
Label dialog and click OK. Alternatively, press Ctrl+L (Command+L,
Macintosh) to open the Insert Label dialog.

4. The item is now a label. Press Enter to obtain the result.

You can change the formatting of equation labels.

• From the Format menu, select Labels, and then Label Display. In the
Format Labels dialog, select one of the numbering schemes.

• Optionally, enter an appropriate numbering prefix.

Figure 2.22 Format Labels Dialog: Adding a Prefix
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The Format>Labels>Label Reference menu item allows you to switch
between the label name and its reference content.

Figure 2.23: Label Reference

2.5  Worksheet Formatting Features

Markers

Maple displays markers for formatting features in a vertical bar along the
left pane of the worksheet. These markers (icons) indicate the presence of
hidden attributes in the worksheet such as Document block boundaries, exe-
cution groups marked for autoexecute, annotations, bookmarks, and numeric
formatting.

To activate markers:

• From the View menu, select Markers.

Document Blocks

In Worksheet mode, document blocks allow you to hide input or output (1-
D and 2-D content) within a specified area. You can combine text and 2-D
content in the same line. Document blocks can be collapsed to hide input or
output, or expanded to reveal Maple code. This feature is useful when creating
a presentation where, for example, the Maple programming language is not
essential to the concept and only output, such as a plot, the final answer, or
explanatory text must be displayed. Markers indicate the boundaries of the
document block. Input prompts and execution groups are not displayed in
document blocks.
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For details on using document blocks, see the Maple User Manual.

Bookmarks

A bookmark designates a location in an active worksheet that can then be
accessed from other regions in your worksheet or by using hyperlinks in
other worksheets. Markers indicate the location of the bookmark.

Figure 2.24: Bookmarks

2.6  Working in Document Mode
Document mode allows you start solving problems right away, free of the
syntax of the worksheet environment.

Document mode is described as follows.

• A blank work area

• An input prompt or execution group is not displayed, although it can be
inserted

• You can combine text and math in the same line

• As with Worksheet mode, you can insert images, plots, tables, sketches,
and Maple spreadsheets

• All math is entered as 2-D Math

You execute 2-D Math in Document mode by using any of the following
methods.
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• Pressing Ctrl + = (Command + =, for Macintosh). This evaluates and
displays results inline.

• Using the context-menu item Evaluate and Display Inline.

• Pressing the Enter key. This evaluates and displays results on the next
line, or if set in the Options dialog simply evaluates.

• Using the context-menu item Evaluate.

• Command completion is supported. For specific platform shortcut keys,
see Common Key Strokes for Symbols and Formats (page 60).

Starting a New Document

To start a new document in Document mode:

• From the File menu, select New, and then Document Mode.

Note: By default, Maple opens in Document mode.

Entering Math

Review the following example.

Entering the expression:

1. Enter x.

2. Press the ^ key. The cursor moves to superscript position. Enter 2.

3. Press the right arrow key. The cursor moves right. Enter the + symbol,
and then enter y.

4. Press the ^ symbol. The cursor moves to superscript position. Enter 2.

Evaluating the expression:

1. Right-click (Control-click, for Macintosh) the expression.
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2. From the context menu, select Evaluate and Display Inline.

The result is displayed with an = sign.

Common Key Strokes for Symbols and Formats

Palettes are the quickest way to enter special formats; however, you can also
use the following key strokes.

Automatically Generated in DocumentKeySymbol/Formats

Example using fraction:  versus 1/4F5enter/exit 2-D
Math

• Escape, Macintosh

• Ctrl + Space, Win-
dows

• Ctrl + Shift +
Space, UNIX

command/symbol
completion

/ (forward slash)fraction

Use right arrow key to leave superscript area.

^ (caret)exponent (super-
script)

_ (Shift + underscore )subscript

sqrt, and then com-
mand-symbol comple-
tion shortcut key

square root

Arrow keysnavigating the ex-
pressions
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Opening Documents

Like in Worksheet mode, in Document mode documents are saved as .mw
files.

Files saved in Document mode open automatically in Document mode and
not in Worksheet mode.

Viewing Maple Code in Document Mode

In Document mode, documents are created as a series of document blocks.
As such, you can expand document blocks to view hidden code.

To view code in Document mode:

1. Ensure that the Markers feature is activated. From the View menu, select
Markers. Document block markers are displayed in the left side bar.

2. Insert the cursor in a document block to be expanded.

3. From the View menu, select Expand Document Block.

4. To hide the code again, from the View menu, select Collapse Document
Block.

For more information on document blocks, see the Maple User Manual.
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3  Using Maple
Maple is a powerful application with many resources to guide you. The fol-
lowing examples provide you with scenarios to learn about using Maple re-
sources and the Maple program.

When using Maple to solve a problem, consider the following process.

1. Formulate your problem.

2. Obtain Maple resources that allow you to solve it.

3.1  Calculus Example
Problem

Scenario A:

Your company is designing a bottle for its new spring water product.
The bottle must contain 18 ounces of water and the height is fixed.
The design includes an undulating curved surface. You know the
amplitude and equation of the curve, but you must find the radius.
You require the Volume of Revolution.

Scenario B:

You want to teach your students the concept of a Volume of Revolu-
tion. Specifically, you want to plot and compute the volume of a
solid of revolution generated by rotating f(x), a ≤ x ≤ b, about an
axis or a line parallel to an axis.

63



Check for Existing Tools:Tutor

Begin by examining the Tools menu for a Tutor (graphical user interface)
to a Volume of Revolution problem.

To access a Tutor for the Volume of Revolution:

1. From the Tools menu, select Tutors, and then Calculus-Single Variable.
Notice that a Volume of Revolution tutor exists.

2. Click the Volume of Revolution menu item. The worksheet is populated
with the following Maple command.

> 

The Volume of Revolution Tutor is displayed. (See Figure 3.1) The tutor
is a graphical user interface that allows you to enter a function and an interval,
view and manipulate the corresponding plot, and view the full Maple com-
mand associated with your entries and selections.
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Figure 3.1: Volume of Revolution Tutor

After you Close the tutor, the plot is inserted into your worksheet.

Check for Existing Tools: Task Template

To access a task template for the volume of revolution:

1. From the Tools menu, select Task, and then Browse. The Browse Tasks
dialog opens, displaying a list of tasks. The tasks are sorted by subject to
help you quickly find the desired task.

2. Expand the Calculus folder.

3.1  Calculus Example   •   65



3. From the displayed list, select Volume of Revolution. The Volume of
Revolution task is displayed in the right pane of the Browse Tasks dialog.
(See Figure 3.2)

Figure 3.2: Task Template for Volume of Revolution

4. Select the Insert into New Worksheet check box.

5. Click Insert Default Content. Before inserting a task, Maple checks
whether the task variables have assigned values in your worksheet. If any
task variable is assigned, the Task Variables dialog opens allowing you to
modify the names. Maple uses the edited variable names for all variable in-
stances in the inserted task.
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The command is inserted into your worksheet.

• Parameters are marked as placeholders. Update the parameter values as
required.

• To navigate between placeholders in the worksheet, press the Tab key.

6. After updating any parameters, run the command by pressing Enter.

Check for Instructions: Help Page and Example
Worksheet

The help system provides command syntax information.

To access a help page:

1. From the Help menu, select Maple Help. The Help Navigator opens.

2. In the search field, enter volume of revolution and click Search. The search
results include the command help page, the dictionary definition, and the
associated tutor help page.

3. Review the calling sequence, parameters, and description in the Stu-
dent[Calculus1][Volume of Revolution] help page.(See Figure 3.3)

4. Copy the examples into your worksheet: From the help system Edit menu,
select Copy Examples.

5. Close the Help Navigator.
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6. In your worksheet, from the Edit menu, select Paste. The examples are
pasted into your worksheet.

7. Run the examples and examine results.

Figure 3.3: Student Package Help Page for VolumeOfRevolution Command

To access an example worksheet:

1. In the worksheet, enter ?index/examples. The Example Worksheet Index
opens.

2. Expand the Calculus topic.
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3. Click the Calculus1IntApps link. The Calculus1: Applications of Integ-
ration worksheet opens. (See Figure 3.4)

4. Expand the Volume of Revolution topic.

5. Examine and run the examples.

Figure 3.4: Example Worksheet

Other Ready-To-Use Resources

The Maple Application Center contains free user-contributed applications
related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, graphics, and more.

To access a free application for volume of revolution:

1. Go to the Maplesoft Web site, http://www.maplesoft.com.

2. In the menu of the main Web page, click User Community, and then
Application Center.

3. In the sidebar, click Education PowerTools.
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4. Click the Calculus II link, and then the CalculusII: Complete Set of
Lessons link.

5. Scroll to the Options area and click Download Maple Worksheet. (See
Figure 3.5.)

6. Login in as a guest or Maplesoft Member.

7. Download the .zip file.

8. Extract the L2-volumeRevolution.mws file.

9. Run the worksheet and examine the results.

Figure 3.5: Maple Application Center: PowerTools

70   •   3  Using Maple



3.2  Optimization Example
PROBLEM

When sharpening ice-skates, figure skates, speed skates, and hockey skates
each must be processed by three machines.

The following table shows the time in hours required by each machine to
process a pair of skates as well as the (constraints) maximum time in hours,
per day each machine can operate.

Maximum
operation

Hockey
skates

Speed
skates

Figure
skates

2211/21Machine A

231/311Machine B

21111/4Machine C

The profit on sharpening figure skates is $7 per pair, speed skates is $6 per
pair, and hockey skates is $5 per pair.

• How many pairs of each should be sharpened per day to obtain maximum
profit?

• What is the profit?

PROCESS

Formulate the Problem:

f = number of figure skates per day

s = number of speed skates per day

h = number of hockey skates per day

Objective function is 
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Constraints are:

Obtain Resources:

• Check for existing tools

• Follow instructions

• Consider ready-to-use resources

Check for Existing Tools: Assistant

To access an Assistant (graphical user interface) to the optimization
functionality:

• From the Tools menu, select Assistants, and then Optimization. (See
Figure 3.6.)
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Figure 3.6: Optimization Assistant with Values Entered
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To enter values for the problem:

Enter the objective function and constraints:

1. In the Problem group box, click Edit in the Objective Function group
box.

2. In the dialog that returns, enter 7*f+6*s+5*h. Click Done.

3. Click Edit in the Constraints and Bounds group box. The Constraints
dialog opens.

4. In the Add Constraint field:

• Enter f + 1/2*s + h <= 22. Click Add.

• Enter f + s + 1/3*h <= 23. Click Add.

• Enter 1/4*f + s + h <= 21. Click Add.

• 5. In the Add Bound group box, click Assume all variables nonnegat-
ive.

6. Click Done to return to the Optimization Assistant dialog.

7. In the Solver group box, select Linear.

8. Click Variable Types. In the Variable Types dialog, select the Integer
check boxes for all variables.

9. In the Options group box, select Maximize.

10. Click Solve.

11. Click Done to return to the Optimization Assistant.

12. Click Quit to return the solution 167 and the values for f, s, and h to the
Maple document.
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Check for Instructions: Help Page

The help system provides command syntax information.

To access a help page:

1. From the Help menu, select Maple Help. The Help Navigator opens.

2. In the search field, enter Optimization and click Search.

3. The search results include the Overview of the Optimization Package
help page, dictionary definitions, and example worksheets.

4. With the Overview page displayed in the right pane, review the description.
(See Figure 3.7)

Figure 3.7: Help Page: Overview of the Optimization Package
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In general, you can:

• Review the calling sequence, parameters, and description.

• Copy the examples into your worksheet. From the help system Edit
menu, select Copy Examples. Close or minimize the Help Navigator.
In your worksheet, from the Edit menu, select Paste. The examples are
pasted into your worksheet. Run the examples and examine results.

In this case, you can also open the many dictionary definitions and additional
help pages.

1. In the Overview of the Optimization Package help page, click the linear
programs link. (See Figure 3.8. The dictionary link is indicated by one of
the arrows in the figure.)

• The linear programming definition is displayed.

Note: The definition also contains a link to the associated Maple Optimiza-
tion package command, LPSolve.

Figure 3.8: Definition of Linear Programming

2. Click the Optimization[LPSolve] link in either the definition or overview
help page. (See Figure 3.9)

76   •   3  Using Maple



Figure 3.9: Optimization[LPSolve]

You can use one Maple command to solve the skating problem. For inform-
ation on using commands in packages, see Maple Tools and Re-
sources (page 15).

> 

The same solution is returned using the LPSolve command.
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> 

> 

The assume = nonnegint and maximize options are described in the help page.

• assume = nonnegint - Assume all variables are non-negative integers.

• maximize or maximize = true - Maximize the objective function. By default, that is,
if you exclude the maximize option, the LPSolve command computes the minimum.
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4  The Next Step
After you have reviewed the contents of the first three chapters, you can scan
the top Maple packages (topics) and commands.

Additionally, for detailed information about features you have reviewed in
this book, and other advanced features, refer to the Maple User Manual.

To access the Maple User Manual:

1. From the Help menu, select Manuals, Dictionary, and more.

2. Select Manuals, and then User Manual.

4.1  Top Packages
DescriptionPackage Name

The CodeGeneration package is a collection of commands and
subpackages that enable the translation of Maple code to other pro-

gramming languages, such as C, Fortran, Java, MATLAB®, and
Visual Basic.

CodeGeneration

The LinearAlgebra package contains commands to construct and
manipulate Matrices and Vectors, and solve linear algebra problems.
LinearAlgebra routines operate on three principal data structures:
Matrices, Vectors, and scalars.

LinearAlgebra

A Maplet application is a graphical user interface containing win-
dows, textbox regions, and other visual interfaces, which gives a
user point-and-click access to the power of Maple. Users can perform
calculations, plot functions, or display dialogs without using the
worksheet interface.

The Maplets package contains commands and subpackages to create
a Maplet application. To create Maplet applications in a graphical
user interface environment, use the Maplet Builder. The Maplet
Builder is available only in the Standard Worksheet interface. From
the Tools menu, select Assistants, and then Maplet Builder.

Maplets
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The RealDomain package provides an environment in which the
default Maple behavior of assuming that the basic underlying number
system is the complex field is replaced by the assumption that the
basic underlying number system is the field of real numbers.

RealDomain

The ScientificConstants package provides access to the values of
various physical constants, for example, the velocity of light and the
atomic weight of sodium. These values are required to solve equa-
tions in fields such as chemistry and physics. The ScientificCon-
stants package provides the units for each of the constant values,
allowing for greater understanding of the equation. The package also
provides units matching for error checking of the solution.

The quantities available in the ScientificConstants package are di-
vided into two distinct categories.

• Physical constants

• Properties of chemical elements (and their isotopes)

ScientificConstants

The ScientificErrorAnalysis package provides representation and
construction of numerical quantities that have a central value and
an associated uncertainty (or error), which is a measure of the degree
of precision to which the quantity's value is known. Various first-
order calculations of error analysis can be performed with these
quantities.

ScientificErrorAna-
lysis

The Student package is a collection of subpackages designed to assist
with the teaching and learning of standard undergraduate mathemat-
ics. Many commands display functions, computations, and theorems
in various ways, including stepping through important computations.

The Student package contains the following subpackages.

• Calculus1 - single-variable calculus

• LinearAlgebra - linear algebra

• MultivariateCalculus - multivariate calculus

• Precalculus - precalculus

• VectorCalculus - multivariate vector calculus

Student
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The Units package accepts approximately 300 distinct unit names
(for example, meters and grams) and over 550 units with various
contexts (for example, standard miles and U.S. survey miles). Maple
also contains Units palettes that allow you to quickly enter the unit
for an expression.

Units

The VectorCalculus package is a collection of commands that per-
form multivariate and vector calculus operations. A large set of
predefined orthogonal coordinate systems is available. All computa-
tions in the package can be performed in any of these coordinate
systems. It contains a facility for adding a custom coordinate system
and using that new coordinate system for your computations.

VectorCalculus

4.2  Top Commands
DescriptionCommand Name

Create a two-dimensional plot of functions.plot

Solve one or more equations or inequalities for their unknowns.solve

Solve one or more equations using floating-point arithmetic.fsolve

Evaluate an expression at a given point.eval

Numerically evaluate expressions.evalf

Solve ordinary differential equations (ODEs).dsolve

Compute an indefinite or definite integral.int

Compute an ordinary or partial derivative, as the context dictates.diff

Calculate the limiting value of a function.limit

For symbolic summation. It is used to compute a closed form for an
indefinite or definite sum.

sum

Set variable properties and relationships between variables. Similar
functionality is provided by the assuming command.

assume/is

Compute the value of an expression under assumptions.assuming

Apply simplification rules to an expression.simplify

Distribute products over sums.expand
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Normalize a rational expression.normal

Convert an expression to a different type.convert

Type-checking command. In many contexts, it is not necessary to
know the exact value of an expression; it suffices to know that an
expression belongs to a broad class, or group, of expressions that
share some common properties. These classes or groups are known
as types.

type

Generalized series expansion.series

Apply a procedure to each operand of an expression.map
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