
 

Signal Processing Toolbox 
Release Notes

The “Signal Processing Toolbox 6.0 Release Notes” on page 1-1 describe 
the changes introduced in the latest version of the Signal Processing 
Toolbox. The following topics are discussed in these Release Notes:

• “New Features” on page 1-2

• “Major Bug Fixes” on page 1-8

• “Platform Limitations” on page 1-9

• “Upgrading from an Earlier Release” on page 1-10

• “Known Software and Documentation Problems” on page 1-11

If you are upgrading from a release earlier than Release 12.1, you should 
also see:

• “Signal Processing Toolbox 5.1 Release Notes” on page 2-1

• “Signal Processing Toolbox 5.0 Release Notes” on page 3-1

If you are upgrading from a release prior to Release 11.1, see the Release 
11.1 New Features Guide. Note that is a PDF document.

Printing the Release Notes
If you would like to print the Release Notes, you can link to a PDF version.
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New Features
This section summarizes the new features and enhancements introduced in the 
Signal Processing Toolbox.

If you are upgrading from a release earlier than Release 12.1, then you should 
see “Upgrading from an Earlier Release” on page 1-10.

This section is organized into the following subsections:

• “Digital Filter Objects” on page 1-2

• “Window Design and Analysis Tool” on page 1-3

• “Window Objects” on page 1-3

• “Window Function” on page 1-4

• “New Windows” on page 1-4

• “Gaussian Filter Function” on page 1-4

• “New Analysis Functions” on page 1-4

• “Improvements to grpdelay” on page 1-4

• “stepz Function” on page 1-4

• “digitrevorder Function” on page 1-4

• “FDATool Enhancements” on page 1-5

• “FVTool Enhancements” on page 1-6

• “Demos” on page 1-7

Digital Filter Objects
The Signal Processing Toolbox 6.0 adds a new way of creating, viewing, and 
modifying discrete-time filters using objects. With the new discrete-time filter 
object, dfilt, you can use object-oriented programming, such as calling 
constructors to create specific types of filter objects, using get to view the filter 
properties, and using set to change filter properties. See the dfilt reference 
page for detailed information on this new object.

Some advantages of using dfilt objects instead of vectors of coefficients [b,a] 
are:

• The filter’s structure is part of the object.
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• The filter function can be run on any structure without converting to 
transfer function form.

• The filter is contained in a single object instead of two vectors. This simplifies 
passing the filter to another function or GUI. 

• freqz, grpdelay, impz, phasez, stepz, and zplane are now overloaded 
methods. If you pass a dfilt to any of them or if you do not specify any 
outputs, the filter response is displayed in the Filter Visualization Tool 
(fvtool), where you can access other filter analyses. If you pass filter 
coefficients to them, the figure is displayed in a default figure window. 

• You can change a filter’s characteristics quickly and easily by changing one 
or more of its properties.

• You can double-click on a dfilt object in the MATLAB Workspace Browser 
to display the Property Inspector.

• You can highlight a dfilt and right-click in the MATLAB Workspace 
Browser to launch the Filter Visualization Tool. 

Window Design and Analysis Tool
The new Window Design and Analysis Tool (wintool) is a GUI that provides 
an easy way to design and compare spectral windows. All of the windows 
provided in the Signal Toolbox are available in wintool. You start wintool 
from the MATLAB command line. See the wintool reference page for more 
information.

Window Visualization Tool
A new tool for viewing windows, wvtool, has been added. 

Window Objects
A new way of creating, viewing, and modifying windows using objects has been 
added. The new window object, sigwin, uses object-oriented programming. See 
“Digital Filter Objects” above for advantages of using objects. See the sigwin 
reference page for detailed information on this new object. 
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Window Function
Using the window function without specifying an input now launches the 
Window Design and Analysis Tool (wintool).

New Windows
Two new window functions have been added:

• parzenwin computes a Parzen window. This window is also known as a 
de la Vallé-Poussin window.

• flattopwin computes a Flat Top window.

Gaussian Filter Function
The new function, firgauss designs an FIR Gaussian digital filter. 

New Analysis Functions
Three new analysis functions have been added:

• phasedelay - computes the phase delay response of a filter

• phasez - computes the digital phase response of a filter

• zerophase - computes the zero-phase response of a filter. (Previously, this 
function, using a different syntax, was in the Filter Design Toolbox.)

Improvements to grpdelay
The grpdelay function has been updated to be more accurate for IIR filters 
with poles/zeros very close to the unit circle. This improvement is also reflected 
in the Group Delay plot in FDATool and FVTool.

stepz Function
stepz, which is also available as an overloaded dfilt method, is now available 
from the MATLAB command line. Previously, it was available only in fdatool.

digitrevorder Function
A new function, digitrevorder, allows you to pre-order a vector of filter 
coefficients.
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FDATool Enhancements
• New panel control buttons have been added on the lower left side (in a 

sidebar) to change the panel from Design Filter to Import Filter. If the Filter 
Design Toolbox is installed, Set Quantization Parameters and Transform 
Filter control buttons are also included. If the DSP Blockset is installed, a 
Realize Model control button is included to create a subsystem filter block in 
a Simulink model.

• You can specify additional filter design options in the Design panel. These 
options previously were only available from the command line.

• The Filter Visualization Tool (fvtool), which is launched with the Full View 
Analysis toolbar button or Analysis->Full View Analysis, can be linked so 
that it stays synchronized with FDATool. For more information, see the 
FVTool Enhancements section below.

• The following menu items have been added or updated

- File->Export exports vectors of filter coefficients or a dfilt filter object to 
the workspace, a text file, or a MAT file.

- File->Export to SPTool exports the current filter to SPTool.

- Edit->Undo now undoes single actions, one at a time. Undo will also undo 
the design or importing of a filter.

- Edit->Redo redoes the last action.

- Edit->Convert Structure launches a dialog box for converting the 
underlying filter structure. This dialog box is also available from a context 
menu (by right-clicking) in the Current Filter Information frame.

- Edit->Convert to Second Order Sections launches a dialog box for 
converting the filter to Second Order Sections. This dialog box is also 
available from a context menu (by right-clicking) in the Current Filter 
Information frame. (The fields in this dialog box previously were part of 
the Convert Structure dialog box.) 

- Edit->Convert to Single Section converts a second order sections filter 
back to a single section. This option is also available from a context menu 
(by right-clicking) in the Current Filter Information frame. 

The Convert to Second Order Sections dialog box now limits scaling to 
Direct form II structures only.

- Analysis->Analysis Parameters sets analysis-specific parameters for the 
filter responses. You can also access this from the context menu. You can 
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now save your preferred Analysis Parameters by clicking Save as 
Default in the Analysis Parameters dialog box.

- Analysis->Sampling Frequency sets the sampling frequency for the 
current filter.

- The Filter menu has been removed. You can access all items previously on 
this menu from the sidebar and Edit menu.

• Context menus, which you access by right-clicking, are included for setting 
the units, changing the display, setting the sampling frequency, or accessing 
the Analysis Parameters on the response plots and labels. 

• The Pole/Zero Plot can now display the number of poles /zeros in cases where 
multiple poles/zeros occur at a single point.

• A new filter design method—Maximally flat—has been added. Other new 
methods have also been added in the Filter Design Toolbox,

• To perform zero-phase analysis, right-click on the y-axis label of a Magnitude 
plot to display the context menu and select Zero-Phase, or select it in the 
Analysis Parameters dialog box. To display the corresponding phase plot, 
select Continuous Phase from the Phase context menu.

• Data markers have been enhanced so they are now movable.

• The Current Filter Information frame has been updated. The Convert 
Structure button has been removed. To convert a structure, select Convert 
Structure from the right-click context menu or from the Edit menu.

FVTool Enhancements
• FVTool can be synchronized with FDATool with the Activate FDAToolLink 

toolbar button. When activated, any changes made to the filter in FDATool 
are immediately reflected in FVTool. 

• File->FDAToolLink sets the mode for FDAToolLink. Replace current 
filter removes the filter in FVTool and replaces it with the new FDATool 
filter. Add new filter adds the FDATool filter to the current filter in FVTool 
so that multiple filters can be displayed and compared. You can also set the 
mode using the Set Link mode toolbar button.

• The Edit and Insert menus have been customized to FVTool and irrelevant 
menu items have been removed.
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• A new Tools menu, which includes edit plot and zoom options, has been 
added.

• If the Filter Design Toolbox is installed, a new analysis method, Noise 
Loading Method, has been added to the Analysis menu. Refer to the Filter 
Design Toolbox documentation for more information.

• Context menus, which you access by right-clicking, are included for setting 
the units, changing the display, or accessing the Analysis Parameters on the 
response plots and labels. 

• You can now save your preferred Analysis Parameters by clicking Save as 
Default in the Analysis Parameters dialog box. 

• You can name the filter and specify the filter’s sampling frequency with 
Sampling Frequency on the Analysis menu or by selecting Sampling 
Frequency from the context menu. If you have more than one filter, you can 
specify a different name and sampling frequency for each filter.

• To perform zero-phase analysis, right-click on the y-axis label of a Magnitude 
plot to display the context menu and select Zero-Phase, or select it in the 
Analysis Parameters dialog box. To display the corresponding phase plot, 
select Continuous Phase from the Phase context menu.

Demos
You can now launch the Window Visualization Tool (wvtool) from the Vector 
Transition demo (windtrandemo) to view the selected window.

A new Spectral Estimation demo (psddemo) has been added.

A new digital filter object demo (dfiltdemo) has been added.

The spectrogram demo (specgramdemo) has been enhanced with additional 
audio playback and visualization options.
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Major Bug Fixes
You can see a list of the particularly important Version 6.0 bug fixes. 

If you are viewing these Release Notes in PDF form, please refer to the HTML 
form of the Release Notes, using either the Help browser or the MathWorks 
Web site and use the link provided.
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Platform Limitations

FDATool — 800 x 600 Resolution
On all platforms, FDATool requires a screen resolution of at least 800 x 600.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox 5.1 to Version 6.0.

Obsolete Function
freqzplot is now an obsolete function. Although it is included in Release 13 for 
backward compatibility, it might be removed in a future release. Functions 
that previously used freqzplot now use fvtool to display plots. 
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Known Software and Documentation Problems
You can see a list of known software and documentation problems in Version 
6.0. If you are viewing these Release Notes in PDF form, please refer to the 
HTML form of the Release Notes, using either the Help browser or the 
MathWorks Web site and use the link provided.
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New Features
This section introduces the new features added in the Signal Processing 
Toolbox 5.1 since the Signal Processing Toolbox 5.0 (Release 12.0). 
Enhancements are described in the next section.

For information about Signal Processing Toolbox features that are 
incorporated from recent releases, see “New Features” on page 3-2 in the 
Signal Processing Toolbox 5.0 Release Notes.

The Signal Processing Toolbox 5.1 provides a number of new features and 
enhancements, and a completely new facility for analyzing filters, the Filter 
Visualization Tool.

This section is organized into the following subsections:

• “Filter Visualization Tool” on page 2-2

• “New Windows” on page 2-3

• “bitrevorder” on page 2-4

• “downsample/upsample” on page 2-4

• “filternorm” on page 2-4

• “goertzel” on page 2-4

• “New Signal Demo” on page 2-4

Filter Visualization Tool
The new Filter Visualization Tool (fvtool) groups all the filter analysis 
functions, such as magnitude, phase, impulse response, etc., into a single 
window where you can easily switch between analyses, add annotations, and 
print your filter response.
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New Windows
Six new window functions and a general window function have been added to 
the Signal Processing Toolbox. One window has been renamed. The new 
windows are:

• Bartlett-Hann (barthannwin)

• Blackman-Harris (blackmanharris)



2 Signal Processing Toolbox 5.1 Release Notes

2-4

• Bohman (bohmanwin)

• Gaussian (gausswin)

• Nuttall’s Blackman-Harris (nuttallwin)

• Tukey (tapered cosine) (tukeywin)

The general window function is an alternate way to specify any Signal 
Processing Toolbox window.

The rectangular (boxcar) window function has been renamed rectwin. For 
compatibility, boxcar will continue to work in this release.

bitrevorder
The new bitrevorder function returns input data in bit-reversed order.

downsample/upsample
The new downsample and upsample functions decrease and increase the 
sampling rate of a signal, respectively.

filternorm
The new filternorm function computes the 2-norm or inf-norm of a digital 
filter.

goertzel
The new goertzel function implements the Goertzel algorithm, which is an 
alternate method of computing the DFT.

New Signal Demo
A new demo, Vector Transition Processing Using Spectral Windows, has been 
added. This demo is interactive and demonstrates how to smooth the transition 
between two vectors by using various spectral windows.
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Enhancements
This section describes the Signal Processing Toolbox enhancements and is 
organized into the following subsections:

• “FDATool Enhancements” on page 2-5

• “SPTool Enhancement” on page 2-5

• “Enhanced Functions” on page 2-6

FDATool Enhancements
The following items have been added to the FDATool.

• The new Filter Visualization (fvtool) can be launched from Analysis->Full 
View Analysis.

• Print Preview is now an icon on the toolbar and it launches the MATLAB 
standard print preview.

• Clicking on any point on a filter plot line adds a data marker, which displays 
information about the current point.

• New windows are included in Method->FIR->Window and in the Window 
option in the Window Specifications pane.

• The ability to export filter coefficients to a C-header file (File->Create 
Header File) is included.

• The raised cosine (firrcos) filter method is a new option in the Method 
menu and in the Design Filter pane.

• A plug-in for Code Compose Studio™ IDE to provide the ability to download 
coefficients from FDATool to the Developer’s Kit for TI DSP is included.

• FDATool is integrated with DSP Blockset and is accessible from the Digital 
Filter Design block.

SPTool Enhancement
You can print preview and print your filter design in the SPTool Filter Viewer 
and Filter Designer.
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Enhanced Functions
The following functions have been enhanced in the Signal Processing Toolbox 
5.1. 

Function Enhancement

buffer Takes all MATLAB data types in addition to 
double-precision data

chirp Allows you to specify the shape (concave or convex) of a 
quadratic chirp operation

eqtflength Returns the numerator and denominator orders in 
addition to the numerator and denominator

lpc Outputs a vector of prediction error variances in addition 
to the linear prediction filter coefficients

medfilt1 Allows you to specify the matrix dimension along which 
the filter operates

sgolayfilt Allows you to specify the matrix dimension along which 
the filter operates, and it returns row output for row input. 
This is consistent with filter
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Major Bug Fixes
The Signal Processing Toolbox 5.1 includes several bug fixes, including the 
following:

• In FDATool Magnitude and Phase plot, zoom now works properly.

• In FDATool, the highpass FIR design method for Least Squares and 
Equiripple cases now uses the weights correctly when you use the Specify 
Order option.

Bug Fixes Incorporated from Release 12.0
The Signal Processing Toolbox 5.1 includes several bug fixes that were made in 
Release 12.0.
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Known Software Problem

FDATool and FVTool Pole/Zero Plot
In the FDATool analysis window, pole-zero plots do not display more than one 
root at a given point and data markers cannot be displayed for these points.

FDATool and FVTool Magnitude and Phase Plot
In the Magnitude and Phase plot, you can use data markers only on the phase 
curve.
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New Features
This section introduces the new features and enhancements added in the 
Signal Processing Toolbox 5.0 since the Signal Processing Toolbox 4.3 (Release 
11.1). 

The Signal Processing Toolbox 5.0 provides a number of important 
enhancements, and a completely new facility for designing and analyzing 
filters, the Filter Design & Analysis Tool (FDATool).

This section is organized into the following subsections:

• “Filter Design & Analysis Tool (FDATool)” on page 3-3

• “SPTool” on page 3-4

• “Spectrogram Demo” on page 3-5

• “Automatic Order Adjustment in FIR Filter Functions” on page 3-5

• “grpdelay” on page 3-6

• “hilbert” on page 3-6

• “lpc” on page 3-6

• “xcorr” on page 3-6
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Filter Design & Analysis Tool (FDATool)
The Filter Design & Analysis Tool provides a simple and intuitive graphical 
interface to most of the Signal Processing Toolbox’s digital filter design 
functions.

To start the tool, type fdatool at the MATLAB command line.
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SPTool
SPTool has received a number of enhancements:

• The Signal Browser can now play a selected portion of a signal.

• The markers (rulers) have been enhanced in all component tools (Signal 
Browser, Filter Viewer, Filter Designer, and Spectrum Viewer).

• The toolbars have been enhanced in all component tools. (The new Signal 
Browser interface is shown below.)

To start the tool, type sptool at the MATLAB command line.
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Spectrogram Demo
The Spectrogram Demo (specgramdemo(y,Fs)) is a new demo that displays a 
spectrogram, a time plot, and a frequency slice of an input signal, y, assuming 
a sample rate of Fs Hz. 

Automatic Order Adjustment in FIR Filter Functions
Most of the FIR filter functions (fir1, fir2, firls, remez, fircls, fircls1) 
now automatically increase the order of linear phase filters by 1 when 
necessary to meet the design specifications. For example, a Type II (odd order, 
symmetric) linear phase filter must have a zero at  radians. If a gain other 
than zero is instead specified at  radians in any of the above mentioned 
functions, the function adds 1 to the filter order and proceeds to design the 
higher order filter. 

A warning message is produced in the command window whenever a function 
automatically changes the filter order.

π
π
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grpdelay
The grpdelay function now returns more accurate results for IIR filters.

hilbert
The hilbert function no longer zero-pads sequences that have a 
non-power-of-two length, so the transforms are now exact.

lpc
The lpc function can now return an estimate of the prediction error variance 
(power) as a second output.

xcorr
The xcorr function can now efficiently compute the cross-correlation and 
autocorrelation of large vectors.
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Major Bug Fixes
The Signal Processing Toolbox includes several bug fixes, including the 
following descriptions (online only) of particularly important bug fixes.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox 4.3 (Release 11.1) to the Signal Processing Toolbox 5.0. 

Changes to remez
In the Signal Processing Toolbox 5.0, the remez function no longer supports the 
'm' option that previously executed an M-file variant of the function.
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